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 CONVENTIONS USED IN THIS DOCUMENT 
 
 
The following table describes a set of conventions that are used throughout this document: 
 

Table 0-1.  Legend to Assist in Understanding this Document 

Italicized words Titles of windows, names of buttons and other text that is displayed on the 
computer screen.  Example: Click on the Browse button 

→ Main menu selection, where → indicates choosing a submenu or menu 
item.  Example: Select File→Exit indicates that the user is to select the Exit 
entry listed in the File menu found at the top of the application.  

\ Folder separator or folder indicator.  Example: \Data is the name of a folder 
found in the project directory.  

/ Node separator used to indicate forms or categories found in the 
WinMACCS project window.  Example: The entry General/Properties is 
the name of a form in the category General found in the WinMACCS 
project window. 
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1 WINMACCS OVERVIEW 
1.1 Background 
MACCS2 Version 1.12 has been widely distributed and used throughout the Department of 
Energy (DOE) complex, by private industry, and by the Nuclear Regulatory Commission (NRC) 
and its subcontractors. It has also been distributed to Cooperative Severe Accident Research 
Program (CSARP) members and other international organizations. Its successor, MACCS2 
Version 1.13, is similar to Version 1.12 but contains a number of bug fixes and is compiled on a 
newer FORTRAN compiler. Both of these versions require the user to create and edit ASCII 
input files and to run batch processes to perform a consequence analysis. 
 
In 2001, the NRC initiated an effort to create a Windows-based interface and framework for 
performing consequence analyses. This effort was intended to address the following needs: 

• To simplify and make more intuitive the effort required to create or modify input 
files; 

• To reduce the likelihood of user errors in performing consequence analyses;  
• To enable the user to simply and conveniently account for uncertainties in input 

data; and  
• To displace the original batch framework with a Windows-based framework. 

 
The result of this development effort is the WinMACCS code. WinMACCS is currently 
integrated with an updated version of MACCS2, COMIDA2, and LHS (Latin Hypercube 
Sampling) to perform all of the required functionality. The original MACCS2 framework is 
preserved; MACCS2 can still be run in stand-alone fashion as a batch process. However, there 
are significant advantages for migrating to the WinMACCS framework for running consequence 
calculations.  
 
Chapter 1 of this manual explains the WinMACCS framework and components; Chapter 2 
describes how to install WinMACCS onto a Windows computer; Chapter 3 provides a tutorial 
that should be the starting point for the novice user; and Chapter 4 contains a reference document 
for the WinMACCS interface. 

1.2 WinMACCS Framework 
1.2.1 Software used to Develop WinMACCS 
Development of this software is under a Windows XP Professional (Version 2002 Service Pack 
2) operating system within the Sandia National Laboratories (SNL) common operating 
environment (COE). The COE includes Microsoft Office 2003 and Internet Explorer 6.0 
installed on the development machines. 
 
Microsoft Visual Basic Pro 6.0 (Service Pack 5) was used to develop the user interface. Compaq 
Visual FORTRAN Professional, Version 6.6B, was used in the development of the modeling 
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engines, MACCS2, and COMIDA2. The Microsoft database library, DAO 3.6, is used to 
communicate with the project database.  
 
Several third party packages were purchased for use in the WinMACCS development as follows: 

• True Data Grid Pro 7.0, published by Component One, is used for the data grids 
in WinMACCS.  

• Teechart Pro ActiveX Version 6.0, published by Steema Software, is used to 
create plots in WinMACCS. 

• Professional Wise Installation System 9, published by Wise Solutions, is used to 
create the software installations file, setup.exe. 

• Microsoft Visual SourceSafe, version 6.0a, is used for version control. 
 
Latin Hypercube Sampling (LHS), published by Sandia National Laboratories, is used to perform 
sampling from user-defined probability distributions that represent uncertain input parameters. 
LHS is licensed by Sandia National Laboratories. 
 

1.2.2 WinMACCS Components 
 
 

User Enters Model
Input and 

Commands WinMACCS

COMIDA2LHS

PopMod

MACCS2

Project Files
•Data
•Input
•Output

Multiple file input:
Atmos.inp
Early.inp

Chronc.inp
Meteorological file

Site file
Comida2.bin

DCF file

Multiple file results
Modeln.out
Modeln.bin
FortErr.log

MaxStat.log

LHS.inp

Comida.inp
Comida.par
Comida.var

DCF file

Multiple file 
results

LHS.out Comida2.bin Comida2.dmp
Comida2.lst Comida2.cnc

Multiple file 
input

Project Database
(Access 2000 file
project.mxd)

DAO library

MACCS2

SecPOP 2000 Site file

Site file > angular data

 
Figure 1-1  WinMACCS Components 
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Components illustrated in Figure 1-1 are as follows: 

User Enters Model Input and Commands 
After installing WinMACCS on a Windows-based operating system, a project file can be 
opened. The user interacts with the WinMACCS application to modify model input, initiate 
deterministic and uncertain simulations, and view MACCS2 output. 

WinMACCS 
The executable, WinMACCS.exe, was created using a Visual Basic compiler. Multiple instances 
of WinMACCS are supported. This allows the user to run multiple calculations simultaneously 
on a computer, which is especially useful when the computer has more than one processor. 
 
Using WinMACCS, the user can do the following: 

• Modify model input variables and model settings. These settings are saved in the 
project database. 

• Initiate a MACCS2 deterministic simulation. WinMACCS builds the MACCS2 
input files using the values saved in the project database.  

• Initiate a COMIDA2 simulation to create the binary file containing food chain 
data that is used by MACCS2. 

• Initiate a MACCS2 simulation with uncertain input parameters represented by 
probability distributions. WinMACCS initiates LHS to generate values of the 
uncertain variables and builds the MACCS2 input files for each simulation. 

• Run successive MACCS2 simulations without using LHS. In this case, which is 
called cyclical execution, MACCS2 input can be varied using successive input 
files. One application of this feature is to run successive MACCS2 simulations 
using multiple source terms from MELCOR simulations. The interface utility, 
MELMACCS, can be used to create the input files containing the source-term 
data. This feature is called cyclical because it can be combined with sampling of 
uncertain input data. The input files are cycled if there are more realizations than 
input files. 

• View, export, and aggregate results of MACCS2 simulations in various formats 
such as text, Microsoft Excel, JPEG, BMP, XML and HTML. 

Latin Hypercube Sampling (LHS) 
The executable file, Lhs.exe, generates values of uncertain variables using LHS. This program is 
initiated from WinMACCS. 
 
The following input files are required: 

• Lhs.inp – generated by WinMACCS. This file contains the probability 
distribution types and values and the number of samples to generate. 

• Sipra.inp – software settings used by LHS. 
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The following output files are generated: 
• Lhs.out – contains results from LHS execution, i.e., sampled values.  This file is 

read by WinMACCS and it is used to create MACCS2 and COMIDA2 input files 
using the sampled values. 

• Lhs.err – present if an error is detected during LHS execution. 
• Lhs.msg – contains details of LHS execution. 

COMIDA2 
The executable file, Comida2.exe, is a semi-dynamic food chain model that estimates annual 
concentrations (dose-to-source ratios) given a set of radionuclides and transfer coefficients for 
each crop type considered.   
 
The input files are generated by WinMACCS. Uncertainty is supported in this input. The 
following input files are required: 

• Comida2.inp, a model input file 
• Comida2.var, a model input file 
• Comida2.par, a model input file 
• A dose Conversion Factor (DCF) file 

 
The following output files are generated by COMIDA2: 

• Comida2.bin, which is used as input to MACCS2  
• Comida2.dmp, a detailed output file 
• Comida2.lst, a detailed output file 
• Comida2.cnc, a detailed output file 

PopMod 
The executable, PopMod.exe, was created using a Visual Basic compiler.  This software reads an 
ASCII population file, created by SECPOP2000.  PopMod creates a new population file 
containing more compass sectors.  The work of PopMod is primarily formatting.  No new 
information is added to the new site data file. 
 
This software is used when the user is unable or does not want to rerun SECPOP2000 to create a 
file with a finer grid mesh (i.e., support of more compass directions). SECPOP2000 supports 
exactly 16 compass sectors, hence a finer polar grid was not available. 
 
The purpose behind the development of this software is to support a finer polar grid used for 
evacuation studies using WinMACCS and MACCS2. 
 
The following input is required: 
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• Site data file 
• Number of angular sectors, greater than number in site data file 
•  

The following output file is generated: 
• New site data file 

 

MACCS2 
The executable, MACCS2.exe, was created using Compaq Visual FORTRAN Professional. The 
modeling engine can be initiated via either WinMACCS or a command prompt window.   
 
The following input files may be required (depending on models chosen). These files are either 
created by WinMACCS or supplied by the user if the modeling engine is initiated via a 
command prompt window: 

• ATMOS input (atmospheric transport, dispersion, and deposition parameters) 
• EARLY input (parameters pertaining to the emergency phase, up to the first seven 

days after the accident, including mitigative actions such as evacuation, 
sheltering, and dose-dependent relocation) 

• CHRONC input (parameters pertaining to the intermediate and long-term phases) 
 
The following auxiliary files are always required by MACCS2: 

• Maccs2.tmp is a text file containing the paths and names for the MACCS2 input 
files. (WinMACCS assigns the name Maccs.tmp using the –i option in the 
MACCS2.exe command. See Appendix A for more details.) 

• Indexr.dat is an ASCII file containing decay-chain information. This file is 
included as part of the installation. 

 
The following data files are optionally required by MACCS2 (depending on models chosen): 

• Meteorological file describing weather conditions for one or more years 
• Site file describing population, land use, and economic parameters 
• Dose conversion factor (DCF) file used to calculate health effects from various 

radionuclide exposures for each pathway 
• Comida2 binary file, created by COMIDA2.exe, is used to define food-chain 

doses. 
 
Output Files Created by MACCS2. WinMACCS names the MACCS2 output files model1.out, 
model2.out, etc., where the number corresponds to the sample number. If the calculation is 
deterministic, then only model1.out is created. In the following description of the files created by 
WinMACCS, n is an integer that differentiates each of samples that are evaluated. 
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• Modeln.out is a readable text file containing output from MACCS2. 
• Modeln.bin is a binary file containing output from MACCS2. This file can be 

viewed as text or it can be used to create plots within the WinMACCS interface.  
• FortErr.log is created when MACCS2 terminates abnormally. A trace of the 

offending call stack is written to this file. (WinMACCS assigns the name 
ModelnFortErr.log using the –p option in the MACCS2.exe command. See 
Appendix A for more details.) 

• MaxStat.log contains the character string “OK” when MACCS2 terminates 
normally, “NO” when MACCS2 terminated abnormally or when MACCS2 does 
not complete the simulation. This file contains an error message if termination is 
due to an error detected by MACCS2 (as opposed to an error detected by the 
Windows operating system). (WinMACCS assigns the name ModelnMaxStat.log 
using the –p option in the MACCS2.exe command. See Appendix A for more 
details.) 

Project Files 
1. Data files managed by WinMACCS consist of auxiliary files such as the site file, the 

meteorological file, the COMIDA2 binary file(s), and the DCF file(s). 
2. Input files are created by WinMACCS using the model input settings. This set can 

include Atmosn.inp, Earlyn.inp, Chroncn.inp, Comidan.inp, and Lhs.inp input files 
Output files are created by MACCS2 and its preprocessors (e.g., LHS and COMIDA2). One 

or more MACCS2 output files, Modeln.out, are normally created. Other files may or 
may not be created, depending on settings in WinMACCS. 

Project Database 
An Access 2000 database file is created from a database template file, Initialize2000.mdb, by 
WinMACCS when a new project is created. The project database is modified by WinMACCS 
using the Microsoft DAO 3.6 library. The database includes the following: 

• Model input values input by user, 
• Model default values, 
• Model variable descriptions and limits, 
• Information to construct model input forms, and  
• Information to construct model input files, 
• LHS results 
• MACCS2 results read from binary result files. 
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2 INSTALLATION OF WINMACCS 
2.1 System Requirements 
The WinMACCS software requires the following: 

• A personal computer with Microsoft Windows NT, 2000, or XP Pro installed 
• Screen resolution set to a minimum of 1024 by 768  
• 500 MG of free disk space for installation 

2.2 Installing from CD-ROM 
To install WinMACCS, run Setup.exe as follows: 

1. Click on the Microsoft Windows Start button and select the Run command. 
2. Click on the Browse button and locate Setup.exe on the installation CD. 
3. Click Open. 
4. Click OK in the Run dialog box. 

 
The WinMACCS installation procedure executes. A numeric key is required to complete the 
installation. This key is provided with the WinMACCS CD. 
 
On certain installations, MDAC (Microsoft Data Access Components) automatically installs 
before WinMACCS installs. Some system files are updated in this case. This is a Microsoft 
update that is required for WinMACCS to store projects as database files.  

2.3 Troubleshooting Installation Problems 
When the installation is complete, the user can select readme or WinMACCS help from the 
WinMACCS program group for additional information. The file readme.txt, identical to readme 
from the WinMACCS program group, is also on the installation CD in case the installation was 
unsuccessful.   
 
Users should contact their system administrator for assistance if difficulty is experienced 
installing MDAC.   
 

2.4 Uninstalling WinMACCS 
From the Start menu, select Uninstall from the WinMACCS program group. There is no uninstall 
for MDAC. Microsoft considers this to be a system upgrade and does not offer an uninstall 
procedure. 
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3 TUTORIALS 
The following tutorials demonstrate how to modify an existing WinMACCS project and how to 
convert a legacy MACCS2 project into a WinMACCS project.  Following the tutorials are some 
guidelines for constructing a new project from scratch, i.e., without the benefit of an existing 
project. 
 
Tutorial One demonstrates how to:  

• Open the existing sample project, sample1 
• Modify parameters in sample1 
• Create uncertain parameters 
• Access WinMACCS online help  
• Modify models 
• Run simulation 
• View and export results 

 
Tutorial Two demonstrates how to: 

• Import  MACCS2 1.12 or 1.13.1 input files to create a sample WinMACCS 
project  

• Connect the meteorological file, site data file, dose conversion factor file and 
COMIDA2 file with the imported project 

• Understand how specific input cards are related to the models selected for the 
imported example 

• Understand the importance of knowing the type of dose conversion factor (DCF) 
file before importing a sample project into WinMACCS.  Auto recognition of 
FGR-11 and 12 type DCF file is not supported in the import process. 

• Understand that some modifications to the older input are required to run 
MACCS2.  In particular, it is necessary to enter chemical group names in 
ATMOS (variable GRPNAM), to enter CHRONC shielding factors, and to ensure 
that WTFRAC sums to 1 across EARLY scenarios. 

• Understand that if the number of EARLY evacuation scenarios (cohorts) is two or 
more, the value is not changed to one while importing a MACCS2 input set even 
if the imported file contains only one evacuation scenario.  The number of 
evacuation scenarios must be set to one in the Project Properties form. 
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3.1 Tutorial One 

Table 3-1.  Loading the Project 

User Action WinMACCS response 

Double-click on the WinMACCS icon 
on the desktop or select WinMACCS 
from the WinMACCS group within 
the Windows Start Menu. 

WinMACCS starts and displays pull-down menus on the top 
of the screen. File and Help are accessible. 

Choose File→Open Project. 

Change directory to WinMACCS 
Samples\Tutorials. 

WinMACCS shows available sample project folders. 

Double-click on the sample1 folder. Folder opens and shows three sub-folders: Data, Input, and 
Output plus the project file sample1.mxd. 

Double-click on sample1.mxd. WinMACCS loads the project and displays two tabs on the 
bottom of the Project window: Parameters and Files. Above 
the tab, WinMACCS displays a list containing the following 
headings: GENERAL, ATMOS, EARLY, CHRONC, and 
COMIDA2. 

Select File→Save As from the main 
menu.  

Verify that the current directory is 
called WinMACCS Projects. 

Type Sample 1 in the Project Name 
field. 

A new copy of the sample project, Sample 1, is created in the 
default WinMACCS project directory, WinMACCS Projects. 

The path shown in the caption of the main WinMACCS 
window is as follows: 

C:\WinMACCS Projects\Sample 1 

Click on the Files tab in the window. Above the tab, WinMACCS displays a list containing the 
following headings: Data, Input, and Output. 
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Table 3-2.  Viewing Parameters 

User Action WinMACCS response 

Click on the Parameters tab in the 
Project window. 

Each + button, when clicked, displays sub-lists until the lowest 
level is reached. At the lowest levels, black bullets appear next 
to the names of variables. For example, METCOD is one of the 
variables under ATMOS/Property Form Parameters. 

Open the ATMOS or EARLY heading 
by clicking on the + button. Peruse the 
different lists by clicking on the + 
buttons. Notice the solid green 
octagon. 

     A solid green octagon next to a form entry means that all 
of the variables under that entry are required and have 
been properly defined.  

  A solid orange diamond next to a form entry means that 
all of the optional variables under that entry have been 
properly defined.  

      An empty orange diamond next to a form entry means 
that the optional variables have not been defined. 

  An empty red octagon means that there are variables 
that must be defined before proceeding with a MACCS2 
simulation. 

   A solid gray octagon containing a diagonal line means 
that the variables are not used in a MACCS2 simulation 
because they are not needed under the current choices. 
This symbol also indicates that all of the variables have 
been defined. 

       An empty gray octagon containing a diagonal line 
means that the variables are not used in a MACCS2 
simulation because they are not needed under the 
current choices. This symbol also indicates that not all 
of the variables that have been defined. 

Choose ATMOS/Property Form 
Parameters. 
Double-click on the box next to 
METCOD. 

The Property Form Parameters form opens. At the bottom of 
the form, the variable type "Integer" and range of values 
"[1,5]" is shown, as well as a description of the METCOD 
variable. Values on this form are read only; the values indicate 
choices made on GENERAL/Properties/Properties form. 
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Click inside the other variable boxes. Notice that the variable type, range, and description change for 
each variable. 

Close the property form by clicking 
OK or Cancel. 

Property Form Parameters form closes. 

Click on the ATMOS/Deposition 
category 

Notice that this entry on the Parameters tab contains a list of 
several forms, namely Wet/Dry Depos Flags, Wet Deposition, 
and Dry Deposition.   

A solid green octagon means the information under that 
category is required and has been properly specified. This also 
means that there are no optional variables in this category.  No 
more user attention is required. 

Click on the ATMOS/Radionuclides 
category 

Notice that the Pseudostable Radionuclides form is optional.   

  A yellow diamond, empty or solid, indicates that there 
is at least one optional form in this category. 

  An empty red octagon means that there are forms in this 
category containing variables that must be defined before 
proceeding with a MACCS2 simulation.  

Click on the EARLY/Dose Model 
category 

Notice that none of these forms are used in a simulation 
consistent with the current model settings on the Properties 
Form.   

 All forms in this category have a grey symbol, hence 
the category symbol is grey. No user attention is required. 
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Table 3-3.  Changing Active Models to Include EARLY 

User Action WinMACCS response 

Click on the + sign next to General. 
Click the + sign next to Properties. 
Double-click on the solid green 
octagon next to Properties. 

The Project Properties window opens with tabs showing 
different model options. The model definition state is 
displayed in color at each of the tab headings. A solid green 
octagon indicates that the data have been defined; if there were 
an empty red octagon on this form, it would indicate that the 
data were not defined or the data were inconsistent with other 
choices. 

Only tabs relevant to the ATMOS module, namely Scope, 
Dispersion, Weather, and Plume Rise, have a solid green 
octagon next to them in this example. The rest of the headings 
are prefixed with a solid gray octagon containing a diagonal 
line, indicating the model selections are valid but are not 
needed. 

Press F1 on the keyboard. An online help window opens describing the selected tab in the 
Properties Window. Pressing the F1 key opens a context-
sensitive help window for all windows in WinMACCS. 

Close the WinMACCS help form.   

Click on the Scope tab.  
Add Early Consequences to the 
calculation scope by clicking the box 
beside Early Consequences.  

A check appears inside the Early Consequences box. 

Notice that all of the labels within the Parameters tab in the 
Project window under the EARLY heading continue to have 
gray icons associated with them, indicating that the 
requirements of the EARLY module have not yet been 
displayed. 

Click the Show Required Forms 
button. 

The EARLY module is temporarily activated. 

Notice that many of the labels within the Parameters tab in the 
Project window in the EARLY category now have a solid green  
octagon associated with them. Notice that the icons next to the 
tab headings in the Properties window associated with the 
EARLY module now have solid green octagons  associated 
with them. 

Click the OK button to save the 
changes. 

The Project Properties window closes. 
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Table 3-4.  Running a Project 

User Action WinMACCS response 

Choose Execute→Run Models on the 
top menu. 

The Run Models window opens. 

Click Run Simulation. WinMACCS executes the run and shows the steps in the 
process in the Results window at the bottom of the screen (e.g., 
“Verifying data are defined”). A progress bar in the Run 
Models window shows the number of the simulation in 
progress. 

Notice one of the messages written in the Results window is 
“Model execution SUCCESSFUL,” indicating that the 
simulations were successful. If an error had occurred, an error 
condition would have been reported in the Results window. 

Close Run Simulation box by clicking 

on the . 
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Table 3-5.  Viewing Run Results 

User Action WinMACCS response 

Click on the Files tab on the bottom of 
the Project window. 

Above the tab, WinMACCS shows a list containing the 
following headings: Data, Input, and Output. 

Click the + next to Input.   

Double-click on the input file for 
Latin Hypercube Sampling, LHS.inp. 
(LHS.inp contains a summary of 
uncertain variables and their 
distributions.) 

Notice that the following variables were sampled: 

CWASH1, Normal (.000095, .00003) 

CWASH2, Bounded Normal (.8, .1, 0,1) 

EFFACA(1), Uniform (1,10) 

VDEPOS(1), Continuous Linear (CCDF) 

(.01, 0), (.02,.4), (.025, 1) 

WinMACCS created MACCS2 input files Atmos1.inp, 
Early1.inp…Atmos6.inp, Early6.inp, one set of files for each 
realization from LHS using the data in LHS.out. 

Close LHS.inp by clicking on the 
        . 

The text editor closes. 

Click on the + next to Output. Model1.out through Model6.out are displayed. 

Double-click on Model2.out.  

Search for AVERAGE INDIVIDUAL 
RISK ERL FAT/TOTAL  0.2-0.5 km. 
(The early fatality risk due to all 
radionuclides to the average 
individual at a spatial range of .2 to .5 
km.) 

Notepad starts and Model2.out opens.  The second number in 
the row (mean risk) should be 6.23E-02. 

Close Model2.out by clicking on the 
        . 

 The text editor closes. 
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Table 3-6.  Sample Effect of Changing a Single Input Parameter 

User Action WinMACCS response 

Click on Parameters tab in the Project 
window. 

  

Go to ATMOS/Release 
Description/Inventory Scale Factor. 
Double-click on CORSCA. 

Radionuclide Inventory Scaling Factor window opens. 

Modify the value of CORSCA from 
0.715 to 1.43. 
Click OK. 

Radionuclide Inventory Scaling Factor window closes. 

Follow the same execution procedures 
specified under “Running a Project,” 
above. 

WinMACCS executes run with the changed input. 

Check the output files as instructed 
above under “Verify Run Results,” 
opening file Model2.out. 

AVERAGE INDIVIDUAL RISK ERL FAT/TOTAL 0.2-0.5 km 
from all causes should be larger than before (i.e., 8.60E-02 as 
compared with 6.23E-02). 

Close Model2.out.   
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Table 3-7.  Changing Parameters from Uncertain to Deterministic  

User Action WinMACCS response 

Click on the Files tab in the Project 
window.  
Click on the + in front of the Input 
category.  
Double-click on LHS.out. 
(LHS.out lists the uncertain variables 
in the model and their values.) 

Four variables with distributions and parameters are listed: 
CWASH1, CWASH2, EFFACA(1), and VDEPOS(1). 

Close the LHS.out window via 
File→Exit or by clicking the         in 
the upper left of the window. 

LHS.out window closes. 

Click on the Parameters tab.  

Open the Wet Deposition Data 
window by clicking on 
ATMOS/Deposition/Wet Deposition.  

Double-click on CWASH1. 

A Parameter Modification form containing both the CWASH1 
and CWASH2 boxes displays the word Uncertain. 

Click the Make Uncertain button. The CWASH1 distribution window opens. A pull-down menu 
of distribution types appears with Normal indicated. 

Click on the down arrow and select 
Constant, the first choice on the pull-
down menu. 

A blank text box labeled Value appears. 

Enter 9.5E-5 into the text box. 

Click OK. 

The CWASH1 window closes and the value 0.000095 appears 
in the CWASH1 box of the Wet Deposition Data window. 

Repeat the previous three steps for 
CWASH2, setting CWASH2 to 0.8. 

The Wet Deposition Data window now shows 0.8 for 
CWASH2. 

Click OK. The Wet Deposition Data window closes. 

Click on the Edit→Find Parameter 
window.  

The Open Parameter Form window appears. 
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Scroll down to EFFACA using the 
scroll bar. 

Click on EFFACA.  

Click OK. 

The Early Fatality Effects window opens with the word 
Uncertain highlighted under the column heading EFFACA. 

Click on the word Uncertain in row 
one under the column heading 
EFFACA.  

The EFFCA window opens showing a normal distribution and 
its associated parameters. 

Click on the Make Uncertain button. The form used to assign uncertainty for the EFFACA variable 
opens. 

Change the distribution to Constant 
and enter in the value of 3.8.  

Click OK. 

The EFFACA window closes and the Early Fatality Effects 
window shows 3.8 as the value of EFFACA for A-Red Marr. 

Click OK. Early Fatality Effects window closes. 

Change the value of VDEPOS(1) to 
0.01 using the method used to modify 
EFFACA above. 

  

Choose File→SaveAs Project.  

Specify “sample1 deterministic” for 
the Project name. 

WinMACCS creates a new project, sample1 deterministic. 

Choose Execute→Run Models→Run 
Simulation. 

WinMACCS executes ATMOS and EARLY only once and 
generates one output file. Notice that it was not necessary to 
change the number of simulations to one. WinMACCS 
automatically runs one simulation if there are no uncertain 
variables and the MACCS2 Cyclical File Set option is turned 
off. (See the Help file for more information on the Cyclical 
File Set option.) 

Click on the Files Tab. 

Double-click on Output\Model1.out. 

Model1.out opens. 

Look for the value of AVERAGE 
INDIVIDUAL RISK ERL 
FAT/TOTAL 0.2-0.5 km 

AVERAGE INDIVIDUAL RISK ERL FAT/TOTAL  
is 9.19E-02.  
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Close the Model1.out window via 
File→Exit or by clicking the         in 
the upper left of the window. 

Model1.out closes. 

Choose PostProcessing→Create 
Custom Report. 

A window summarizing all of the MACCS2 output requests is 
opened.  Click on the check box shown in the Report column 
for all of the entries where the Report Description column is 
labeled Individual Risk.  There are five entries.  

Click the Create Report button. A report named Summary.out is created and placed in the 
project Output directory. 

Click on the Files tab in the Project 
window. 

Click on the + next to Output. 

Double-click on Summary.out. 

The summary report, Summary.out, opens in Notepad.   

Scroll down to the entry labeled 

Request 2  Individual Risk 

The Average Individual Risk corresponding to the entry from 
the Model1.out file is reported: 

Evacuation Overall ERL FAT/TOTAL [.16,.52](km)  

"Average Individual Risk (none)"  9.187E-02   

(The Summary.out  file can be used to report overall statistics 
when multiple realizations are being calculated with sampled 
variables. However, it can also be used to conveniently 
calculate additional quantile information for a single 
calculation.) 

Close file Summary.out. 

Click OK in window Create a Custom 
Report. 

Selections made in check boxes are saved when this window is 
closed. 

Double-click on General/Reporting 
Options on the Parameters tab. 

A window labeled Reporting Options opens. 

Enter the following quantiles: 

.50, .75, .99; Click OK 

Create a new summary report by 
opening the Create a Custom Report 
window and clicking Create Report. 
Open the report Summary.out. 

Data corresponding to user chosen quantiles are calculated by 
interpolating values from the CCDF’s that MACCS2 
calculates. 
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Table 3-8.  Viewing Results as Plots 

User Action WinMACCS response 

Choose PostProcessing→Graphical 
Results→Results over all Weather 
Trials. 

A Results Over All Weather Trials window opens with the 
version of MACCS2 used in the simulation displayed in the 
Window caption. 

Click the + next to Total Centerline 
Ground Concentration.   

Click on Plume 1 CS-137 
[4.83,5.63](km).  

Click on Add. 

Result is placed on chart. 

Click Modify Axis. The Modify Axis Bounds window opens with options for X- 
and Y-axis and their bounds. In addition, the user may choose a 
linear or a logarithmic scale for X and Y. The minimum and 
maximum values must be specified for the logarithmic scale; 
the linear scale can either be automatically set or manually set 
by the user. 

Click OK in the Modify Axis Bounds 
window. 

The Modify Axis Bounds window closes. 

Select PostProcessing→Graphical 
Results→Edit Plots→Modify Titles. 

Close the Modify Titles window by 
clicking the Cancel button. 

The plot title and axis labels can be modified. 

Click the Select button on the plot 
window. 

The data points representing the complimentary cumulative 
distribution function (CCDF) are shown. Notice that the 
sample number is also shown and is labeled LHS1. Only one 
sample is displayed on this plot because this was a 
deterministic simulation. Otherwise, there would be a curve for 
each LHS realization (LHS1, LHS2, LHS3 …). 

The bottom of the plot window displays details describing the 
selected plot series in blue lettering. 

Click the Select button again. The plot is now in an unselected state. Notice that the bottom 
of the plot window displays the words “Selected Series: 
NONE.” 
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Click the Bulls-eye button. The plotted values are now displayed as text. 

Click the Bulls-eye button again. The text values are no longer displayed. 

Select PostProcessing→Graphical 
Results→Edit Plots→Export Plot. 

A Save As window appears. Notice the different file formats 
available, including JPEG image, MS Excel, and ASCII text. 

Enter "MyData" in the text box 
labeled File Name. 

Select MS Excel (*.xls) in the Save as 
Type pull-down menu.  

Click Save. 

WinMACCS saves the data as an Excel file called MyData.xls 
in the \WinMACCSSamp\sample1\Output directory. 

Repeat this, but now select Windows 
BMP Image (*.bmp) in the Save as 
Type pull-down menu. 

WinMACCS saves the data as a .bmp file called MyData.bmp 
into the \WinMACCSSamp\sample1\Output directory.  This 
file can be opened in MS Paint. 

Double-click on file MyData.xls and 
MyData.bmp in the Output directory 
found under the Files tab in 
WinMACCS. 

If MS Excel is installed on your computer, Excel starts and 
MyData.xls opens. 

The .bmp file opens in the associated application, usually MS 
Paint. 

 



 21  

3.2 Tutorial Two 

Table 3.9 Import IN1A.INP, ATMOS Sample Problem A 

User Action WinMACCS response 

Double-click on the WinMACCS icon 
on the desktop or select WinMACCS 
from the WinMACCS group from the 
Windows Start Menu. 

WinMACCS starts and displays pull-down menus on the top 
of the screen. File and Help are accessible. 

 

Choose File→New Project. Navigate to the folder WinMACCS Projects if it isn’t already 
the folder shown. Enter the name Sample 2 in the Project 
Name field.  Click OK. 

A new project is created. The Project Properties form is 
opened.  This form is used to select the appropriate models for 
the simulation. 

Notice that only the ATMOS model is checked.  This is the 
default setting for new projects. 

Click the Cancel button. Models are determined by the content of the MACCS2 input 
files to be imported. It is not necessary to select models.   

On the Parameters tab of the Project 
window, click the plus sign, +, to the 
left of the headings GENERAL, 
ATMOS and EARLY. 

Notice the empty red octagons next to categories of data in the 
GENERAL and ATMOS categories that are required but are 
not yet defined.   

Notice the filled in green octagon next to the heading Property 
Form Parameters.  These are variables that are defined and 
can be changed only by using the Property Form.  They have 
default predefined values. 

Notice the grey octagons with the slash through them in the 
EARLY category.  These data are not required because the 
default setting of the EARLY model is off for new projects.  

Select File→Import MACCS2 Input 
File from the main menu.  Locate the 
ATMOS input file titled IN1A.INP.  
A copy of this file is in \Program 
Files\WinMACCS\MACCS2 Samples 

Click Open. 

The file IN1A.INP is read by WinMACCS.  The data in this 
file is loaded into the interface.  The progress of processing 
this file can be seen in the WinMACCS Results window.   

The ATMOS empty red octagons have turned into solid green 
octagons, indicating that the data on these forms are now 
defined. 

The EARLY model is now on.  This is because a variable, 
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ENDAT1, in the file IN1A.INP, was set to .FALSE. indicating 
that the EARLY model should be executed. 

Expand the Results window by 
moving the mouse to the Title bar on 
that window.  When the mouse turns 
to a double sided arrow, click, drag, 
and release to resize the window. 

The first line indicates the name of the file that is being 
imported is as follows: 

Importing MACCS2 input file C:\Program 
Files\WinMACCS\MACCS2 Samples\IN1A.INP  

The next line shows that the file is being read for the first time, 
to determine which models are turned on in WinMACCS. 

Processing input lines that define models 

The next lines report which MACCS2 input images are used to 
determine the model settings.  These are listed as follows: 

Saving Maccs2 Data for input line: NUM_DIST 

Saving Maccs2 Data for input line: RDPLHEAT 

Saving Maccs2 Data for input line: OCENDAT1 

Saving Maccs2 Data for input line: M1METCOD 

Saving Maccs2 Data for input line: M4NSMPLS 

Open the file that was imported in 
Notepad.  To do this, locate the file in 
Windows explorer.  The file is in 
\Program Files\WinMACCS\MACCS2 
Samples 

Right click on the name IN1A.  Select 
Open With →Notepad 

 

The input lines that are used to define the models are shown in 
the Results window.  These input lines can be located in the 
file IN1A.INP.  The value on those lines determines the value 
of a WinMACCS model setting.  The following are the images 
from the file IN1A.INP with the effect on WinMACCS 
explained: 

NUM_DIST001   50; causes Dispersion Model to be set to 
Lookup Tables 

RDPLHEAT001     3.7E+6     1.7E5 ;causes Plume Rise Model 
to be set to Power Model 

OCENDAT1001  .FALSE.; causes the EARLY model to be 
enabled  

M1METCOD001  2;  M4NSMPLS001  4; causes the Weather 
Model to be set to Uniform Bin Sampling. 

The models that are set in WinMACCS can be viewed on the 
Properties form. 

WinMACCS imports data in two 
stages. First, the basic model settings 

The second stage, only the data relevant to the current model 
settings are extracted. 
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are imported and values in the Project 
Properties are modified. Then, the 
variables relevant to the updated 
model settings are extracted from the 
file.   

Example output in the Results window from the second pass is:

Processing input lines for file section 1 

Saving Maccs2 Data for input line: RIATNAM1 

Saving Maccs2 Data for input line: GENUMRAD 

After the first period in column one is 
encountered in file IN1A, 
WinMACCS looks for change card 
data.  Change card data refers to input 
cards that change only variables 
referenced in the change card set.  The 
new data set is then used to rerun the 
model.  MACCS2 only supports 
change cards for ATMOS and 
EARLY.    

In this example, even though a change card set is defined in 
IN1A.INP, those data are not retained by WinMACCS.  
WinMACCS only supports change case data for EARLY.  The 
data not being retained are shown in the following output: 

Processing input lines for card set number 2. 

No data to import for file section 2 

Processing input lines for file section 3 

No data to import for file section 3 

Notice that IN1A had exactly 2 sections (one change card set).  
WinMACCS attempted to read a third section before 
encountering the End of File.   

Select Edit→Project Properties.  
Uncheck Early Consequences.  Click 
OK. 

The EARLY model was turned off.  This can be verified by 
observing that all of the icons to the right of the EARLY 
categories and forms are now grey with a slash through them. 

Click the plus sign, +, to the left of the 
heading GENERAL\File 
Specifications.  Double click on the 
form name Meteorological File. 

The form titled Specify Meteorological File is opened. 

Click on the button labeled Browse. 
Locate file titled MetsurMxHt.inp.  A 
copy of this file is in \Program 
Files\WinMACCS\MACCS2 Samples. 

Click OK.  

Metsur.inp is an older version of this file.  This file contains 
one year of site specific meteorological data consistent with 
sample problem A.  The hourly meteorological data on 
MetsurMxHt.inp and Metsur.inp are identical.  However, 
additional data consisting of the morning mixing height was 
added to MetsurMxHt.inp.  This line was added to enable 
MACCS2 to read this file without generating an error when the 
Adjust mixing height based on time of day check box is 
checked on the Weather tab of the Properties form. 

The Meteorological file names for sample problem A can be 
found by viewing a line in the batch file used to run the old 
MACCS2 suite in the file Runem.bat as follows:  

CALL RunMACCS2 IN1A IN2A IN3A_N METSUR SURSIT 
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LISTA_N. 

Click the plus sign, +, to the left of the 
heading ATMOS\Radionuclides.  
Double click on the form name 
Chemical Names. 

Notice that the variable, GRPNAM, has not been defined.  
This is new and was not defined in the file IN1A.INP.  
However, the number of chemical groups, MAXGRP, is set to 
nine. 

Bring the file IN1A.INP back into the 
foreground.  Search for the string 
RDRELFRC using Edit→Find from 
the main menu of Notepad.  Notice 
that the chemical group names have 
been inserted as a comment two lines 
above the RDRELFRC line.  Enter the 
names in the Chemical Names form.  
Click OK. 

The values used here are for labeling and documentation.  Any 
nine entries can be added.  However, the nine entries in 
IN1A.INP that are entered, one per line on the form, are as 
follows: 

 

Select Execute→Run Models from the 
main menu.  Click on the Run 
Simulation button on the Run Models 
form. 

The ATMOS model runs.  Successful execution can be 
verified by observing that the Results window contains the 
following: 

Running model as follows: 

"C:\Program Files\WinMaccs\MACCS2.exe" -i 
"C:\WinMACCS Projects\Sample 2\Maccs.tmp" -p "Model1" 

Model execution SUCCESSFUL 

OK   

Run Completed 
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Table 3.10 Import IN2A.INP, EARLY Sample Problem A 

User Action WinMACCS response 

Import file IN2A.INP by using the 
File→Import MACCS2 Input File 
feature. 

Notice in the Results window that the variables read to define 
the models are listed.  They are as follows: 

Saving Maccs2 Data for input line: MIENDAT2 

Saving Maccs2 Data for input line: MIIPLUME 

Saving Maccs2 Data for input line: PDPOPFLG 

Saving Maccs2 Data for input line: MIORGDEF 

Saving Maccs2 Data for input line: MIOVRRID 

Saving Maccs2 Data for input line: EZEVATYP 

Saving Maccs2 Data for input line: EZLASMOV 

Saving Maccs2 Data for input line: EFNUMEFA 

Saving Maccs2 Data for input line: EINUMEIN 

Saving Maccs2 Data for input line: LCNUMACA 

Saving MACCS2 Data for input line: EZLASMOV for scenario 
2 

Open the file, IN2A.INP, in Notepad.  

Select Edit →Project Properties. 

The models that have been turned on based on the imported 
variables. 

The following are the images from the file IN2A.INP with the 
effect on WinMACCS explained: 

MIENDAT2001  .FALSE.; causes the CHRONC model to be 
enabled 

MIIPLUME001  2; causes Wind Shift with Rotation model to 
be enabled. 

PDPOPFLG001  FILE; causes Site Data Specification to be set 
to Import from File. 

MIORGDEF007  'L-EDEWBODY' ; causes the dose 
conversion factor file type to be set to File Created by 
DOSFAC2. If MIORGDEF007  ‘ICRP60ED’; was present, the 
model would have been set to FGR-13. 

MIOVRRID001  .FALSE.; causes the Wind Rose set to the 
default, uniform distribution. 

EZEVATYP001     'RADIAL'; EZLASMOV001     15; causes 
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the Evacuation Model for Scenario One to be set to Radial.  If 
EZLASMOV001     0; was present, the model would have 
been set to None. 

EFNUMEFA001   2; EINUMEIN001  7; LCNUMACA001   
7; each of these correspond to check boxes in the Early Effects 
tab in the Project Properties window.  A zero value has the 
effect of unchecking the box, where a non-zero value causes 
the related check box to be checked. 

EZLASMOV001     0; This is part of the first change set, and 
has the effect of adding an additional evacuation scenario and 
setting the evacuation type to None.  This can be observed by 
looking at the Evac/Rotation tab of the Project Properties 
window.  

Check the Results window for any 
warning messages, indicating a 
problem with the import procedure. 

Notice the warning message written to the Results window: 

WARNING - Check the Properties form for model settings.         
When importing older MACCS2 input files, some models are 
not specified. 

One rule, with the exception of the dose conversion factor file 
(default is the new FGR-13 file type), is that new models 
added after MACCS2 1.13.1 are turned off by default.   

If an input file using an older FGR-11/12 dose conversion 
factor file is imported, WinMACCS cannot detect the file type.  
In this case, the WARNING message above is applicable.  It is 
necessary to open the Project Properties form and select the 
radio button Federal Guidance Report (FGR-11 and –12) on 
the Dose tab. 

Click the Scope tab of the Project 
Properties window.  Uncheck Late 
Consequences.  Click OK 

In preparation for running ATMOS and EARLY only, the 
CHRONC (corresponding to Late Consequences) model was 
turned off.  This can be verified by observing that all of the 
icons to the right of the CHRONC categories and forms are 
now grey with a slash through them. 

Click on the + next to the headings 
GENERAL, ATMOS, EARLY and 
CHRONC if these headings are not 
already open. 

Click on the + next to the category 
File Specifications. 

The forms that still need attention are displayed. 
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Define the site file by double clicking 
on the form name GENERAL/File 
Specifications/Site File. Click on the 
Browse button to find the file 
Sursit.inp, and then click on OK. 

User is prompted to answer the question  

Do you want to update the spatial grid to be consistent with 
the site file? 

Answer Yes.  This updates the values of variable SPAEND.  
SPAEND and the site file should be consistent. 

In a similar manner, open the form 
Dose Conversion Factor File.  Select 
the file DOSDATA.INP.  

The Dose conversion factor file name is specified in the file 
IN2A.inp on the following lines: 

DCF_FILE001 'DOSDATA.INP' 

Select Execute→Run Models from the 
main menu.  Click on the Run 
Simulation button on the Run Models 
form. 

Click on the entry on the task bar: 

 

The ATMOS and EARLY model are now running.  The 
progress is displayed in the command prompt window. 
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Table 3.11 Import IN3A.INP, CHRONC, Sample Problem A 

User Action WinMACCS response 

Import file IN3A_N.INP by using the 
File→Import MACCS2 Input File 
feature. 

Select Edit →Project Properties. 

Check Late Consequences.  Click OK 

The Results window displays the variables read to define the 
models.  They are as follows: 

Saving Maccs2 Data for input line: CHFDPATH 

The CHRONC model is now enabled. The CHRONC model 
was not turned on automatically because the variable to enable 
this model is ENDAT2 in the MACCS2 EARLY input file, 
IN2A.INP. 

Open the file IN3A_N.INP in 
Notepad.  Locate the line starting with 
the character string CHFDPATH001. 

The following image is from the file IN3A_N.INP with the 
effect on WinMACCS explained: 

CHFDPATH001 'NEW'; causes the COMIDA2 food model 
User supplies COMIDA2 File option to be on.  

It is not possible to import the option Create COMIDA2 File 
because this is a WinMACCS and not a MACCS2 option. 

Click on the + next to the headings 
GENERAL, EARLY and CHRONC if 
these headings are not already open. 

Double click on the form name 
Shielding and Exposure in CHRONC. 

 

Notice that the CHRONC variables LPROTIN, LBRRATE 
and LGSHFAC are not defined.  These are new variables that 
do not have images in the imported file. 

Click on the + next to the EARLY 
category Emergency Scenario One. 

Double click on the form name 
Shielding and Exposure in the 
EARLY category Emergency 
Scenario One. 

Enter the related data in the row 
labeled Normal into the CHRONC 

LPROTIN is set to 0.41, LBRRATE is set to 2.66E-4, and 
LGSHFAC is set to 0.33. 

Adding these CHRONC variables ensures that consistent 
values are independent of the EARLY evacuation scenarios.  
Before this modification to MACCS2, the values used during 
the last EARLY evacuation scenario were used in CHRONC. 
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Shielding and Exposure form. 

Bring the file IN3A_N.INP back into 
the foreground.  Search for the string 
BIN_FILE001 using Edit→Find from 
the main menu of Notepad. 

The complete line is as follows: 

BIN_FILE001 'SAMP_A.BIN' 

This identifies the name of the COMIDA2 binary file.  This 
file contains food chain data.  

Define the COMIDA2 file by double 
clicking on the form name 
GENERAL/File 
Specifications/COMIDA2 File. Click 
on the Browse button to find the file 
Samp_a.bin, and then click on OK. 

The COMIDA2 file must be created using the dose conversion 
factor file that is used in the calculation.  MACCS2 compares 
the headers of these two files to ensure compatibility.  

Select Execute→Run Models from the 
main menu.  Click on the Run 
Simulation button on the Run Models 
form. 

MACCS2 runs successfully.   
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Table 3.12 Changing Input to Run One Evacuation Scenario  

User Action WinMACCS response 

Open the file, IN2A.INP, in Notepad 
if it isn’t already open. 

Select File→SaveAs from the 
Notepad menu.   

Enter the name IN2A_1EVAC.INP 

Save a copy of IN2A_1EVAC.INP in 
the directory  \WinMACCS 
Samples\Tutorials\ 

Scroll to the bottom of the file.  
Delete the last set of change cards, 
from the line following the first line 
with a period in column one to the 
last line in the file. 

Select File→Save 

The file that has exactly one evacuation scenario.  The 
following lines were deleted: 
**************************************************************************** 

* EMERGENCY RESPONSE SCENARIO NUMBER 2 

**************************************************************************** 

* EVACUATION ZONE DATA BLOCK, LOADED BY EVNETW, STORED IN /NETWOR/, 
/EOPTIO/ 

* 

* SPECIFIC DESCRIPTION OF THE EMERGENCY RESPONSE SCENARIO BEING USED 

* 

EZEANAM2001  'NO EVACUATION, RELOCATION MODELS APPLY EVERYWHERE' 

*  

* WEIGHTING FRACTION APPLICABLE TO THIS SCENARIO 

* 

EZWTFRAC001  0.05 

* 

* LAST RING IN THE MOVEMENT ZONE 

* 

EZLASMOV001     0   (A ZERO TURNS OFF THE EVACUATION MODEL) 

. 

 

Import file IN2A_1EVAC.INP by 
using the File→Import MACCS2 
Input File feature. 

Notice that the number of evacuation scenarios was not set to 
one, but remains two.  This can be observed by noticing that 
the icon to the left of EARLY/Additional Emergency 
Scenarios/Emergency Scenario Two is not grey with a line 
through it. 

WinMACCS is unable to know for certain that the user does 
not want to run an additional scenario because they omitted 
EARLY change cards. The user must input this information 
directly. 

Select Edit→Project Properties.  

Click on the Evac/Rotation tab. 

Set the Number of Scenarios to 1. 

Click OK. 

Number of evacuation scenarios has been set to one. 

Notice the icon to the left of the EARLY/Additional Emergency 
Scenarios category is grey with a slash indicating that it is not 
used. 
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Select Execute→Run Models from 
the main menu.  Click on the Run 
Simulation button on the Run Models 
form. 

MACCS2 failed.  The following message is displayed in the 
Results window: 

Model execution FAILED.  Open output file for details.  

NO 

ERROR: WTFRAC must be between .999 and 1.001 when  
running only one evacuation cohort. 

!!! ERROR--FORCING ABNORMAL EXIT !!! called by 
INEVAC 

Error message indicates that WTFRAC is invalid.  WTFRAC 
values for all evacuations need to add to approximately one.  
Previous versions of MACCS2 reassigned the value to be one 
when there was one evacuation scenario.  The current version 
requires consistency. 

Select Edit→Find Parameter 
Window from the main menu. 

Click on the entry WTFRAC. 

Click the OK button. 

The form named Basic Parameters for Scenario One is 
opened.  Type the value 1 for WTFRAC.  Click OK. 

Click on the Run Simulation button 
on the Run Models form. 

MACCS2 runs successfully. 
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The following are a few guidelines for creating a new project from scratch: 
• When a new project is created by selecting File→New Project from the main 

menu, the WinMACCS Properties form is opened.  The settings on this form 
should be reviewed and changed as needed.  After this has been reviewed, click 
OK to save the settings.  The settings on each tab of this form determine the icons 
next to the forms that are required, not required, and are optional. 

• Starting at the top of the Parameters tab, fill in the required forms in order.  A 
form is required if the icon is a hollow red octagon.  Settings on the WinMACCS 
Properties form can be modified as needed.  It is not required that the forms be 
filled out in order, but it may be helpful because information on some forms is 
required on other forms. Filling out the forms in order avoids any such conflicts. 

• When all of the empty red octagons have been converted to solid green octagons, 
then select Execute→Run Models from the main menu.  Click on Run Simulation 
to run.  Look in the Results window to verify that the execution was successful.  
The output files from the execution can be opened by double clicking on the file 
names on the Files tab. 

• It may be easier to debug the input if only the ATMOS model is enabled the first 
time MACCS2 is executed.  After ATMOS is running successfully, change the 
main model to include EARLY on the Properties form.  If needed, continue with 
CHRONC and COMIDA2 as each set of model input is debugged.    
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4 USER INTERFACE REFERENCE GUIDE 
 

4.1 WinMACCS Project 
The following sections describe how WinMACCS project files are organized on the user’s file 
system and how these files are accessed and modified by using WinMACCS. 
 

4.1.1 WinMACCS Project File Structure 
A WinMACCS project folder contains the following components: 

• A database file (e.g., myProject\myProject.mxd). This file is an Access 2000 
database file. In addition to WinMACCS settings, this file contains the parameter 
values used to build the MACCS2 input files when a simulation is run. 

• Three subdirectories as follows:  
1. myProject\Data\ contains user specified input files, such as the site file, the 

meteorological file, and the dose conversion factor file.   
2. myProject\Input\ contains input files created by WinMACCS each time the user 

requests a MACCS2 simulation. 
3. myProject\Output\ contains output from a MACCS2 execution.   

 
To move the location of the project, the user can simply move (or drag and drop) the directory 
myProject\, the files, and subdirectories to a new location.   

4.1.2 Overview of the Project Graphical Structure 
When a project is opened using the File→Open Project command or a new project is created 
using the File→New Project command, a Project window and a Results window are opened. The 
Project window is used to modify parameter values and view related project files. Figure 4-1 
shows the main components of a project.  
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Figure 4-1  Project and Results Windows 

 

• The caption at the top of the window indicates the name of the open project and 
the location of that project. In the example shown in Figure 4-1, the file 
C:\WinMACCS Samples\Tutorials\sample 1 is open. 

• The main menu options are File, Edit, Execute, PostProcessing, Window, and 
Help. 

• The Project window contains two tabs, the Parameters tab and the Files tab.   
o The Parameters tab contains a list of forms that are used to modify variables and 

to create file links. Forms are opened by double-clicking on their names.   
o The Files tab contains links to active files. A file is opened in a text editor by 

double-clicking on its name.  
• The Results window displays the results of a user initiated action, such as 

importing a file or running a simulation.  
 

4.1.3 Parameters Tab 
The parameters are organized in a tree structure to facilitate access. The example in Figure 4-2 
shows the main categories: GENERAL, ATMOS, EARLY, CHRONC, and COMIDA2. GENERAL 
contains a category named Properties a category named File Specifications and a form named 
Reporting Options. More information under the Properties and File Specification categories can 
be viewed if the + is clicked to display more detail.   
 
Within the ATMOS category, the Radionuclide category has been completed, as shown by the 
solid orange diamond next to the category name. The orange color of the symbol indicates that 
there is at least one form in this category that is optional. 
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Within the ATMOS category, the Deposition category detail is shown. The empty red octagon 
indicates that there is missing information in this category. The Wet/Dry Depos Flags and Wet 
Deposition forms have been completed, as indicated by the solid green octagons. The Dry 
Deposition form still needs attention, as indicated by the red octagon next to the form name. This 
form contains two variables: NPSGRP and VDEPOS. If the form name or the variables are 
double-clicked, the corresponding parameter modification form is opened. 
 

 
Figure 4-2  Parameters Tab 

 
Notice that each entry in the tree has a related icon. This icon reflects the state of the object. The 
objects and icons are as follows: 

 Input associated with a major code module is represented by a lightning bolt icon. 

GENERAL, ATMOS, EARLY, CHRONC, and COMIDA2 are the major categories. The 
GENERAL category contains the links to the minor model settings (for example, the 
weather sampling method) and the links to the auxiliary files to be used in a simulation. 
There are a number of categories within each module. These categories contain forms 
that are used to specify input parameters. An example of a category is Plume 
Specifications. 
 

Forms within categories are represented with icons as follows: 

 An empty red octagon indicates that the user needs to complete this form before running 
MACCS2. 

 A solid green octagon indicates that the user has completed this form and that the data 
defined on this form are needed to perform a calculation. 
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 A solid orange diamond indicates that the user has completed this optional form. The data 
defined on all forms with an orange diamond are used in a subsequent calculation. 

 An empty orange diamond indicates that the user has not completed this optional form.   

 A solid gray diamond with a diagonal line indicates that the user has completed this form, 
but the data are not needed under the current model choices. 

 An empty gray diamond with a diagonal line indicates that the user has not completed 
this form, but it is not required and can be ignored. 

 There is a black circle next to each parameter name. The parameter names are listed for 
easy navigation of WinMACCS. Parameters are given the same names as the MACCS2 
input variables. Double-clicking on a parameter object causes the related form to open, 
with the focus at the selected parameter value. 

Double-clicking on a form or on a variable name associated with a form causes it to open it for 
editing. 
 
Icons next to category names summarize the form states as follows: 

 An empty red octagon indicates that the user needs to complete at least one form in the 
category before running MACCS2. 

 A solid green octagon indicates that the user has completed all necessary forms in this 
category for the choices currently specified. It also indicates that there are no optional 
forms within this category. 

 A solid orange diamond indicates that the user has completed all required forms in this 
category for the model choices that are currently specified. There are optional forms 
within this category that may or may not have been completed.   

 An empty orange octagon indicates that the category contains only forms that are 
optional and that no forms in this category have been completed. It is not necessary to 
complete any forms in this category before proceeding with a calculation. 

 A solid gray octagon with a diagonal line indicates that the user has completed at least 
one of the forms in the category, but because of the current model selections, the data are 
not used when running MACCS2. 

 An empty gray octagon with a diagonal line indicates that the user has not completed any 
of the forms in the category, but does not need to because of the current model choices. 

The Properties form found in the GENERAL category allows the user to modify the model 
choices that are used in a subsequent MACCS2 calculation. Data entry on this form can modify 
the status of the categories and forms as indicated by the icons listed above. 
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4.1.4 Files Tab 
There are three categories on the File tab: Data, Input, and Output. Each of these categories 
corresponds to files stored in the project subdirectories Data\, Input\ and Output\. 
 
The structure emulates the directory structure displayed when the project is viewed in Windows 
Explorer, with differences noted below in the detailed description of each of the three file 
categories. 
 

 

Figure 4-3  Data\ directory as seen from Windows Explorer 
 
4.1.4.1 Data Files 
This category contains data files specified by the user under the General/File Specifications 
category on the Parameters tab of the Project window.   
 
Double-clicking on a file name opens the selected file in Notepad for editing. The user can 
modify the file and save it. The modified file is used when MACCS2 is run. Files in the Data\ 
directory other than those in File Specifications (Figure 4-1) are not shown in this view.  
 

 
Figure 4-4  Project Data Directory 
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Not all of the files shown in Figure 4-4 are necessarily used when MACCS2 is run. Which files 
are used depends on the models that have been selected on the Properties form. For example, if 
the module Early Consequences is not selected, the DCF file is not needed for the simulation. 
 
These file links can be modified by double-clicking on the form or variable name in the 
GENERAL/File Specifications category, as shown in Figure 4-5. 
 

 
Figure 4-5  File Specifications 

 
Model settings that affect the inclusion of data files are modified from the Project Properties 
form shown in Figure 4-6. 
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Figure 4-6  Project Properties Form 
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Table 4-1.  Auxiliary Files Used by WinMACCS 

Name of File 
Variable 

Conditions When File(s) Is 
(Are) Required 

Related Tab 
in Properties 
Form 

Files from sample 
problems 

Meteorological 
File 

Required when meteorological 
file sampling is used. For 
information regarding the file 
format, see section A.1 of the 
MACCS2 User’s Guide 
(Chanin and Young, 1997). 

Weather Metsur.inp 
MH8810.inp 
Metsur_morning.inp 

Site File Required when an EARLY 
simulation is chosen and 
population is not uniform. This 
file can be created using 
SECPOP2000. See section A.3 
of the MACCS2 User’s Guide 
(Chanin and Young, 1997).   

Scope and Site 
Data 

Sursit.inp 
SRS_F.inp 

DCF File Required when an EARLY 
simulation is chosen and the 
Linear No Threshold (LNT) 
dose model is selected. This file 
can be created by the 
preprocessor DOSFAC2 or 
FGRDCF. DCF files based on 
Federal Guidance Report 13 are 
included with the sample 
problems.  See section A.2 of 
the MACCS2 User’s Guide 
(Chanin and Young, 1997). 

Scope and 
Dose 

DosData20Organs.inp 
(created by DOSFAC2) 
and 
DOSD825.inp, 
DOSD60.inp(both 
created by FGRDCF) 
FGR13DCF.inp 

Base DCF File Required when the Annual 
Threshold or Piecewise-Linear 
dose model is selected.  

Scope, Dose, 
and Food 

dosData20Organs.inp 
FGR13DCF.inp 
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Name of File 
Variable 

Conditions When File(s) Is 
(Are) Required 

Related Tab 
in Properties 
Form 

Files from sample 
problems 

Annual 
Differential 
DCF File Set 

Required when the Annual 
Threshold or Piecewise Linear 
dose model is selected. Each of 
the DosData20Organs files was 
created using a special version 
of DOSFAC2. The FGR13DCF 
files are based on interpolated 
and integrated adult absorbed-
dose rate data for organs 
following a unit intake via 
ingestion or inhalation in the 
first year. Annual doses are 
contained in 
DosData20Organsnn.inp and 
FGR13DCFnn.inp, where nn is 
a two-digit integer that 
corresponds to dose received in 
year nn from an exposure that 
occurred in year one. 

Scope, Dose, 
and Food 

dosdata20organs01.inp 
dosdata20organs02.inp 
… 
dosdata20organs50.inp 
 
 
Or 
 
FGR13DCF01.inp 
FGR13DCF02.inp 
… 
FGR13DCF50.inp 

COMIDA2 File Required when doing a 
CHRONC simulation with the 
COMIDA2 food-pathway 
option and the user is supplying 
a COMIDA2 file. This is a 
binary file created by the 
COMIDA2 preprocessor using 
the same DCF file specified 
above. 

Scope and 
Food 

samp_a20Organs.inp 
samp_d.bin 
fgr13samp_a.bin 

Base COMIDA2 
File 

Required when doing a 
CHRONC simulation with the 
Annual Threshold or Piecewise 
Linear dose model. This file 
was created using the Base DCF 
File as input into COMIDA2. 

Scope, Dose 
and Food 

samp_a20organs.inp 
fgr13samp_a.bin 

Annual 
Differential 
COMIDA2 File 
Set 

Required when the Annual 
Threshold or Piecewise Linear 
dose model is selected. Each of 
these files was created using the 
corresponding DCF file 
specified in the Annual 
Differential DCF File Set as 
input into COMIDA2.   

Scope, Dose, 
and Food 

samp_a20organs01.inp 
samp_a20organs02.inp 
… 
samp_a20organs50.inp 
 
fgr13samp_a01.bin 
fgr13samp_a02.bin 
… 
fgr13samp_a50.bin 
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Name of File 
Variable 

Conditions When File(s) Is 
(Are) Required 

Related Tab 
in Properties 
Form 

Files from sample 
problems 

MACCS2 
Cyclical File 
Set 

Required when MACCS2 
Cyclical File Set was selected 
under Properties. Each file 
contains MACCS2 and/or 
COMIDA2 input lines 
(ATMOS, EARLY, CHRONC, 
and/or COMIDA2).  These files 
can be created using 
MELMACCS, an interface that 
creates MACCS2 input from a 
MELCOR plot file. 

Scope  

 
Map files that are displayed behind the spatial grid on the forms supporting the input of the 
network evacuation direction and the network and radial evacuation speeds are also placed in the 
/Data directory.  These .gif files are created to be sized to the spatial grid entered by the user in 
WinMACCS by a separate software program called MapGen.  MapGen reads an interface file 
containing information about the spatial grid written by WinMACCS and creates the map files 
from this interface file.  See section 4.8.2. 
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Figure 4.7 Forms that use Maps 

 
4.1.4.2 Input Files 
This category contains input files that are normally created by WinMACCS before running a 
MACCS2 simulation. If the main menu option, Execute→Refresh Template Input Files before 
Running is not checked, then the template files atmosTemplate.txt, earlyTemplate.txt, 
chroncTemplate.txt, and comidaTemplate.txt are not recreated from the settings within 
WinMACCS before running a simulation. This feature allows the user to edit these files and run 
a simulation using the edited files. 
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Figure 4-7  Input Files 
 
All files in the user’s project directory Project\Input\ are shown in the Project window.  Selecting 
main menu option File→Refresh File View causes the hard drive to be queried and refreshes the 
Project window. Double-clicking on a file causes it to be opened in Notepad. 
 
WARNING: The Input directory is not a good place to put any files that the user wants to 

keep! The Data (Project\Data\) and root directories (Project\) are safe places 
to store files because they are never deleted by WinMACCS. The user can 
also create additional directories for archiving files under the Project\ 
directory. 

 
The following example reflects a run with a scope of Atmospheric Dispersion, Early 
Consequences, Late Consequences, and COMIDA2. In this example, some variables are sampled 
and two simulations are requested. 
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Table 4-2.  Files created by WinMACCS 

Name of File Conditions When File 
Is Created Description 

atmosTemplate.txt Created if option 
Execute→Refresh 
Template Input Files 
before Running is 
checked. 

File atmosTemplate.txt is used to 
create input files Atmos1.inp and 
Atmos2.inp. 

earlyTemplate.txt Created if option 
Execute→Refresh 
Template Input Files 
before Running is 
checked   
 and 
EARLY module is 
selected under the Scope 
tab in the Properties 
form. 

File earlyTemplate.txt is used to create 
input files Early1.inp and Early2.inp. 

chroncTemplate.txt Created when option 
Execute→Refresh 
Template Input Files 
before Running is 
checked  
 and 
CHRONC module is 
selected under the Scope 
tab in the Properties 
form. 

File chroncTemplate.txt file is used to 
create input files Chronc1.inp and 
Chronc2.inp. 

Atmos1.inp 
Early1.inp 
Chronc1.inp 
Atmos2.inp 
Early2.inp 
Chronc2.inp 

Input files are created 
consistently with the 
model scope. For 
example, when the user 
has only specified 
Atmospheric Dispersion 
and Early Consequences 
on the Scope tab in the 
Properties form, then 
Atmos1.inp, Atmos2.inp, 
Early1.inp, and 
Early2.inp are created 
using atmosTemplate.txt 
and earlyTemplate.txt. 
Chroncn.inp is not 
created.   

Files are created using the template 
files in conjunction with data from 
LHS.out relevant to each simulation. If 
any of the variables are uncertain, this 
information is encoded in the relevant 
template file. The actual values used in 
simulation n correspond to realization 
n in the LHS.out file.  
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Name of File Conditions When File 
Is Created Description 

LHS.inp Created whenever 
uncertain variables are 
defined. 

This file contains input to LHS that 
indicates the number of observations, 
probability distributions, variable 
names, and correlations between 
sampled data. 

Sipra.ini Created whenever 
uncertain variables are 
defined. 

This file contains LHS settings and is 
copied from Program 
Files\WinMACCS directory into the 
\Project\Input\ directory. This file is 
read by LHS. If this file needs to be 
changed, it should be modified in the 
Program Files\WinMACCS directory. 

LHS.out 
LHS.msg 

Created whenever 
uncertain variables are 
defined. 

These files are created by LHS.  
LHS.msg is a detailed output file 
describing the run. LHS.out contains 
results in an easy to parse format. 
LHS.out is used to create the input 
files to MACCS2. 

comidaTemplate.txt Created when the Late 
Consequences option is 
selected on the Scope tab 
in the Properties form 
and the Create 
COMIDA2 File option is 
selected on the Food tab 
in the Properties form. 

This file is similar to the other 
template files. It is used with LHS.out 
to create the three input files required 
by COMIDA2, namely Comidan.inp, 
Comidan.par, and Comidan.var, where 
n is the simulation number. 

Comida1.inp 
Comida2.inp 

Created when the Late 
Consequences option is 
selected on the Scope tab 
in the Properties form 
 and 
the Create COMIDA2 
File option is selected on 
the Food tab in the 
Properties form. 

This is one of three input files required 
by COMIDA2.     

Comida1.var 
Comida2.var 

Created when the Late 
Consequences option is 
selected on the Scope tab 
in the Properties form 
 and 
the Create COMIDA2 
File option is selected on 
the Food tab in the 
Properties form. 

This is one of three input files required 
by COMDIA2. It contains 
radionuclide data. 
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Name of File Conditions When File 
Is Created Description 

Comida1.par 
Comida2.par 

Created when the Late 
Consequences option is 
selected on the Scope tab 
in the Properties form 
 and 
the Create COMIDA2 
File option is selected on 
the Food tab in the 
Properties form. 

This is one of three input files required 
by COMDIA2. It contains food-
pathway data. 

 
If the Execute→Refresh Template Input Files before Running from the main menu is checked 
(the default setting), then: 

• When the Run button is clicked on the Run form, all of the files in the 
Project\Input directory are deleted. 

 
If the Execute→Refresh Template Input Files before Running from the main menu is unchecked, 
then: 

• When the Run button is clicked on the Run form, all of the files in the 
Project\Input directory are deleted except for the files atmosTemplate.txt, 
earlyTemplate.txt, chroncTemplate.txt, and comidaInpTemplate.txt 

• The option allows the template files to be manually edited before running 
WinMACCS. While this option would not normally be selected by a user, it is 
helpful if there are new models in MACCS2 that are not yet supported in 
WinMACCS. 

If the user has checked the box labeled Delete Atmos, Early, Chronc and COMIDA2 Input Files 
on the Advanced Execution Parameters form, the input files that aren’t used as templates are 
deleted after they have been used.  In the example above, this means that Atmos1.inp, 
Atmos2.inp, Early1.inp, Early2.inp, Chronc1.inp, Chronc2.inp, LHS.inp, Comida1.inp, 
Comida2.inp, Comida1.par, Comida2.par, Comida1.var and Comida2.var are deleted if specified 
by the user.  See 4.10.2 for more information. 
 
4.1.4.3 Output Files 
This category contains output files created by MACCS2 and COMIDA2. 
 
The entries under the category Output are file names found in the user’s project directory 
Project\Output\ excluding the binary MACCS2 result files, which end with a .bin extension.  
They are created when the Run button is clicked on the Run form. Select main menu option 
File→Refresh File View to query the hard drive and refresh the file list. 
 
The Output directory is a convenient place to store files because they are listed in the file view of 
the project.   
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Figure 4-8  Output Files 

 
WARNING: Do not name any files in the output directory Modeln.out, Modeln.bin, 

Comidan.cnc, Comidan.dmp, or Comidan.lst. These files are deleted from 
the Ouput directory each time a simulation is run. Likewise, never put any 
files in the Project\Input\ directory. These are all deleted each time a 
simulation is run. 

 
Double-clicking on a file opens it in Notepad. The following example reflects a simulation with a 
scope including Atmospheric Dispersion and Early and Late Consequences. Comida2 is run to 
create the .bin files used by the Late Consequences module. In the example, two simulations are 
requested.  
 

Table 4-3.  Output files created by MACCS2 and COMIDA2 
Name of File Description 
Model1.out 
Model2.out  

These are the output files created by 
MACCS2 corresponding to each of the 
LHS samples. 

Model1.bin 
Model2.bin 

These are the binary result files created 
by MACCS2 corresponding to each of 
the LHS samples. These files are not 
shown in the Project\Output\ directory 
in WinMACCS.   

Comida1.lst 
Comida2.lst 
Comida1.cnc 
Comida2.cnc 
Comida1.dmp 
Comida2.dmp 

These are output created by COMIDA2 
for each of the LHS samples. 

 
If the user has checked the box labeled Delete MACCS2 and COMIDA2 Output Files on the 
Advanced Execution Parameters form, the text output files are deleted after each simulation. 
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Similarly, if the user has checked the box labeled Delete MACCS2 and COMIDA2 Binary Result 
Files the binary result files are deleted after the reports have been created.  See 4.10.2 for more 
information. 
 

4.1.5 Results Window 
The Results window is found at the bottom of the application window.  This is created when a 
project is opened. 
 
The Results window communicates progress during 

• MACCS2 simulations. 
• The importing of MACCS2 binary files after selecting an entry from 

PostProcessing→Graphical Results from the main menu. 
• The importing of MACCS2 input files after selecting File→Import MACCS2 

Input File from the main menu. 
 
Text shown in this window can be selected and copied to the Windows clipboard by using the 
copy and paste functions available when right clicking the mouse. Alternatively, the user can use 
the control-C option to copy text from this window. 
 

 
Figure 4-9  Sample Results Window 

4.2 Main Menu Options 
Figure 4-10 shows the main menu options listed at the top of the WinMACCS application. 
 

 
 

Figure 4-10  The Main Menu 
 
This section describes each of the menu selections in detail. 
 

4.2.1 The File Menu 
By selecting items on the File menu, the user can: 
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• Manage WinMACCS projects via the New Project, Open Project, Save Project, 
SaveAs Project, and Close Project commands.  

• Refresh the view of the project files using Refresh File View. 
• Convert MACCS2 files into WinMACCS projects with the utility Import 

MACCS2 Input File. 
• View a MACCS2 binary output file in a text format using utility Export Binary 

Results as Text. 

 
Figure 4-11  The File Menu 

 
File menu commands are as follows: 

File→New Project  
This command creates a new WinMACCS project. 
 
The user is required to type a name for the project in the Project Name text box. This name is 
used as a directory name and as the prefix of the .mxd (MACCS document) project file. The user 
is limited to enter only names that are legal names for windows directories and files. Optionally, 
the user can change the drive and parent directory for this new directory. 
 
By default, the project location is on the drive where WinMACCS is installed. If the program 
was installed on the C:\ drive, then the default project directory is C:\WinMACCS Projects\. 
 
Click OK to close this window and complete the operation of creating a new project. Click 
Cancel to close this window without creating a new project. 
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Figure 4-12  New Project Form 

 

File→Open Project 
This command opens an existing WinMACCS project. The user selects the .mxd file in the 
project root directory.   
 
If the project file is not the same version as WinMACCS, a box similar to one shown in Figure 
4-13 is displayed. 
 

 
Figure 4-13  Database Inconsistency 

 
Click OK  to upgrade the database to the current version of WinMACCS. This does not modify 
the original .mxd file. To modify the original file, select File→Save. To retain the old project, 
select File→SaveAs. 

File→Save Project 
This command saves the changes made to the project variables and settings. 

File→SaveAs Project 
This command copies the current project to a new project. The directory structure and all files 
are copied to the new project. 
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File→Close Project 
This command closes the current project. You must close the current project before opening 
another project. The interface supports only one project at a time. However, you can have 
multiple instances of WinMACCS running at a time provided each instance has a different 
project opened. 

File→Refresh File View 
This command refreshes the data displayed on the project Files tab.  

File→Import MACCS2 Input File 
This command prompts the user to select a MACCS2 input file. The file contents are read and 
data values are substituted into WinMACCS variables.   
 
The MACCS2 input file does not need to be completed. The MACCS2 input lines are read and 
the values overlaid onto the existing project. If vector or array data are present in the MACCS2 
input file, all values associated with that vector or array are cleared before the new data are 
overlaid onto the project. Only the data relevant to the model settings are imported into the 
project.  
 
The model settings are modified while importing a MACCS2 input file. For example, the 
MACCS2 input file modifies the weather model if a METCOD card, indicating the weather 
model, is included in the file. If the model settings are modified, then the data relevant to those 
modified settings are imported.  Data not relevant to model settings are skipped. 

File→Export Binary Results as Text 
This option opens a MACCS2 binary output file in text format. These files are found in the 
Project\Output\ directory, one for each simulation. The binary output files are the same files that 
are used by the WinMACCS postprocessor to display MACCS2 results graphically. 
 

 
Figure 4-14  Import Binary File as Text 
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File→Exit 
This option terminates WinMACCS. 
 

4.2.2 The Edit Menu 
By selecting items on the Edit menu, it is possible to: 

• Modify data grids on parameter modification forms using commands from the 
submenu Edit→Grid.  

• Correlate uncertain variables and enforce a rank order of sampled variables from 
the submenu Edit→Correlate Uncertain Variables. 

• Reset parameters on parameter modification forms to the default values using the 
command Reset Form Variables to Default. 

• Open parameter modification forms by choosing the variable name when using 
the command Edit→Find Parameter Window. 

• Open the Project Properties window to modify basic modeling choices. 
 

 
 

Figure 4-15  Edit Menu 

Edit→Grid 
The options available in the Edit→Grid submenu are enabled if a parameter modification form 
containing a grid has focus. For example, variable SPAEND is displayed in a grid contained in 
form ATMOS/Radial Grid.  
 
There are two types of grids within the parameter modification forms, namely vector and array 
grids. Arrays are variables with both rows and columns, where vectors may display multiple 
variables on a single grid, one variable for each column.  
 
If a parameter form that contains an array (e.g., ATMOS/Release Description/Release Fractions) 
is opened, then the additional array operations, Edit→Grid→Insert Columns and 
Edit→Grid→Delete Columns, are enabled. 
 
If a parameter form contains an array or vectors with a fixed number of rows (for example, 
vector variables CYSIGA, CYSIGB, CZSIGA and CZSIGB all require exactly six rows), then 
the operations Edit→Grid→Insert Rows and Edit→Grid→Delete Row Hint are not enabled.   
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Edit→Grid→Insert Rows 
This option is used to insert rows in a grid. A row on the grid must be selected before this 
operation can be completed. To select a row, click on the small box between the row number and 
the data in the desired column. The row is highlighted as shown below. After the Insert Row 
option is selected, a Grid Insert form opens and requests more detail regarding the insert.  

 
Figure 4-16  Grid Showing a Selected Row 

Edit→Grid→Delete Row Hint  
This option is an aid to give the novice user instructions on how to delete a row in the grid. 
Selecting this option opens the following window. 
 

 
Figure 4-17  How to Delete a Grid Row 

Edit→Grid→Insert Columns  
This option is used to insert columns in an array. A column of the array must first be selected by 
clicking the column header. A selected column is shown in Figure 4-18. After the Insert 
Columns option is selected, a Grid Insert form opens to ask for more detail regarding the insert.  
 

 
Figure 4-18  Grid Showing a Selected Column 

Edit→Grid→Delete Columns  
This option is used to delete the currently selected array column. 

Edit→Grid→Copy to Clipboard  
This option is used to copy a portion of the grid data to the Windows clipboard. To do this, first 
select a portion of the grid in WinMACCS by holding the right mouse button down, dragging 
over the desired area, and then releasing the mouse. Then, either type the keyboard short-cut for 
copying (Ctrl+F) or select Edit→Grid→Copy to Clipboard. The data can be easily pasted into 
another application, such as MS Excel, with the keyboard shortcut (Ctrl+V). Note that the 
shortcut for copying from the grid is different than the standard Windows shortcut because these 
are distinct operations. 
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Edit→Grid→Paste from Clipboard  
This option is used to transfer a portion of the grid data from the Windows clipboard into the 
grid. Before this can be done, first click on a cell in the grid to define the position of the paste 
operation.  To complete the paste operation, either type the keyboard short-cut for pasting 
(Ctrl+G) or select Edit→Grid→Paste from Clipboard. Note that the shortcut for pasting onto the 
grid is different than the standard Windows shortcut because these are distinct operations. 
 
This operation works well for transferring data from an MS Excel spreadsheet into the grid. If 
data are not being transferred from Excel, then it is helpful to know that a TAB character 
separates cells and a new line (i.e., the Enter key) separates rows in a text file. 
 

 
Figure 4.19 Correlate Uncertain Variables 

Edit→ Correlate Uncertain Variables→ Linear Coefficients 
This option opens the Correlate Uncertain Variables form, which allows the user to correlate 
uncertain variables. This is only relevant when LHS is being used to sample a set of uncertain 
variables.  
 

Edit→ Correlate Uncertain Variables→ Enforce Rank Order 
This option opens the Enforce Rank Order of Uncertain Variables form, which allows the user to 
force a chosen uncertain variable (shown as the Reorder Parameter) to be reordered after 
sampling.  The revised order is the same as the basis uncertain variable (shown as the Reorder 
Basis). The relative order can either be ascending or descending.  

Edit→Reset Form Variables to Default  
This option is used to conveniently replace all the data on a form with the default values. This 
option operates in two modes as follows: 

• If the form is open and has focus, the values are set to the default values.  

Note: This is not the same operation as the Erase button  on the parameter form. The 
Erase button clears all values from the form, but does not replace variables with 
their default values. 

• If the form is not open, then the variables defined on that form are reset to their 
default values.  This has the effect of un-defining all data on that form. This 
operation does not affect read-only variables on the form.  Read-only variables 
have gray backgrounds. 

Note: This is the only way to remove data from required forms.  Simply deleting data 
from a form and saving the empty values by clicking the OK button is not 
allowed. 
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Edit→Find Parameter Window  
This option opens the Open Parameter Form to assist in locating input variables within the user 
interface.   

Edit→Project Properties 
This option is used to modify the basic model choices.  

4.2.3 The Execute Menu 
By selecting items on the Execute menu, it is possible to: 

• Toggle the options, Validate Data before Running and Refresh Template Input 
Files before Running. 

• Trigger importing the binary results files after execution is completed, and 
creating a statistical summary report without further user action. 

• Open the Run form to initiate a MACCS2 simulation. 
 

 
 

Figure 4-19  The Execute Menu 
 

Execute→Validate Data before Running  
This is a toggle that supports the following modes: 

• If it is checked, the data are tested for consistency before a simulation. 
• If it is unchecked, the consistency testing is skipped. This may be desired if a 

minor modification was made and the user doesn't want to wait for the 
consistency check to be performed before executing MACCS2.   

This setting does not persist after the project file is closed. 
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Execute→Refresh Template Input files before Running  
This is a toggle that supports the following modes: 

• If it is checked, the template files are deleted and recreated based on the variable 
values and settings in the project after the Run Simulation button is clicked on the 
Run form. 

• If it is unchecked, the template files are not recreated. This option is used to allow 
direct editing of the MACCS2 input files. In this case, the user can directly 
modify the file atmosTemplate.txt, earlyTemplate.txt, chroncTemplate.txt and 
comidaTemplate.txt. The template files are then used by WinMACCS to create 
the actual MACCS2 input files.  Links to these files can be found in the Files tab 
in the Project window.   

 
WARNING: Changing variables in a template file does not modify variables in the 

database. The files used with MACCS2, atmos1.txt, early1.txt, etc., are always 
recreated using the template files. 

 
This setting does not persist after the project file is closed. 

Execute→Auto Create Summary Report 
This is a toggle that supports the following modes: 

• If it is checked and if reporting has been requested, then after execution of all samples 
has been completed, the binary files are imported into the project database and the 
requested report is created without additional action by the user. 

• If it is not checked, then reports are not created after execution.  The user has the option 
to create reports through the Create Custom Report form that can be opened by selecting 
PostProcessing→Create Custom Report from the main menu. Reporting probabilities can 
also be requested after execution through the General→Reporting Options form.  

 
This setting persists after the project file is closed. 

Execute→Run Models…  
The option is used after the model data are defined and it is desired to initiate a simulation. 
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4.2.4 The PostProcessing Menu 
By selecting items on the PostProcessing menu, it is possible to: 

• Open various graphics windows using the Scalar Results, Statistical Summary 
Results, and Results over all Weather Trials commands. 

• Modify the axis labels and plot title using the Modify Titles command. 
• Select graphs (i.e., plot series) in a graphics window using Select Next Series, 

UnSelect, and Delete Selected Series commands. 
• Save the graphics window as a file, or save the data displayed in the graphics 

window as a file using the Export Plot command. 
• Create custom reports using the Create Custom Report command for user defined 

probabilities. 
 

 
Figure 4-20  Graphical Results Menu 

PostProcessing→Graphical Results→Scalar Results  
This option is used to view results that are not dependent on weather sampling. 

PostProcessing→Graphical Results→Statistical Summary Results 
This option opens a graphics window to view statistical data MACCS2 has calculated over all 
simulations. The probability shown in the plot corresponds to the set of LHS trials, cyclical files, 
or a combination of both. The implicit assumption is that the variations represented by the 
cyclical files are equally probable. 

PostProcessing→Graphical Results→Results over all Weather Trials 
This option opens a graphical window to view the complementary cumulative distribution 
function reported on each individual execution.  The probability shown in the plot corresponds to 
uncertainty in the weather at the time of the accident. 

PostProcessing→Graphical Results→Edit Plots→Modify Titles 
This option is used to change the plot, y-axis, or x-axis title.  

PostProcessing→Graphical Results→Edit Plots →Select Next Series 
This option is used to select the next series drawn on the plot. This performs the same function as 
the Select button on the Plot form. 
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PostProcessing→Graphical Results→Edit Plots →UnSelect 
This option is used to remove the selection of a series on the plot.   

PostProcessing→Graphical Results→Edit Plots →Delete Selected Series 
This option is used to remove the selected series from the plot. 

PostProcessing→Graphical Results→Edit Plots → Export Plot 
This option is used to save the plot that the user has specified.  A variety of formats, such as 
Excel (*.xls), Windows bitmap (*.bmp), Text (*.txt), JPEG (*.jpg), XML (*.xml), and HTML 
(*.html) are available.   
 
PostProcessing→Create Custom Report 
This option is used to create a custom report based on probabilities entered by the user in the 
General→Reporting Options form and the selected output requests.  Output requests are made 
on forms in the Atmos→Output Control, Early→Output Control and Chronc→Output Control 
forms. All output is available even if the reporting option values on the Output Control forms are 
set to NONE or CCDF.   
 

4.2.5 The Window Menu 
By selecting items on the Window menu, it is possible to: 

• Cascade the parameter modification forms and the plot form windows by 
selecting the Cascade function. 

• Change the focus to another window by selecting that window from the list shown 
under the Cascade function. 

 

 
Figure 4-21  The Window Menu 

 

4.2.6 The Help Menu 
By selecting items on the Help menu, it is possible to: 

• Access WinMACCS documentation by selecting either Contents or Search For 
Help On…. 

• Determine the version of WinMACCS by selecting About. 
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Figure 4-22  Help Menu 
 

4.3 Selecting Models on Properties Form  
The Properties form can be opened by selecting Edit→Project Properties from the main menu 
or by double-clicking on General/Properties from the Parameters tab in the Project window. 
 
Basic model selections are made from the Properties form.  By selecting models using the 
Properties form, other variable values relevant to model selection that are used by MACCS2 are 
initialized (e.g., METCOD). The variables affected by the Properties form can be viewed, but 
not modified, by opening the forms ATMOS/Property Form Parameters, EARLY/Property Form 
Parameter and CHRONC/Property Form Parameters.   
 
The Properties form is automatically opened when a new project is created.   
 
The decisions the user makes at this point determine which parameter forms are required. For 
example, if the Late Consequences module is not selected on the Scope tab, then variables in the 
CHRONC category are not required. Consequently, all CHRONC variables in the Project 
window Parameters tab have gray icons associated with them. Additionally, all tabs related to 
the Late Consequences module in the Properties form also have gray icons associated with them. 
 
Each tab on the Properties form has at least one basic model associated with it. There is an icon 
next to the tab name. The meanings of the icons are as follows: 

 A red octagon means that the user must fill in this tab and click OK before proceeding 
with a calculation. 

 A green check mark means that the user has already completed this tab.  If any 
modifications are made to this form, the user must click OK to save them. 

 A gray check mark means that the user has completed this tab, but the information is not 
used in a MACCS2 calculation given the basic modeling options the user has chosen.  
Depending on the selections made, other tabs may or may not be required. 

 A gray octagon means that the user has not completed this tab, but doesn't need to 
because the information is not relevant given the options that have been selected. 

Save Changes  
To save the changes, click OK.   
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Cancel Changes 
To ignore the changes, click Cancel or close the window by clicking the         in the upper right 
corner. 
 
Show Required Forms Given State of Tab 
Click the Show Required Forms button to show which forms in the Project window are required 
if the models shown in the current tab were selected.  Clicking this button also applies the 
selected options to other tabs in the Properties form. This does not save the current selection, but 
is a visual tool to help the user understand what input would be required if the selected options 
were saved. 
 
In Figure 4-23, the Power Law Functions radio button was selected and Show Required Forms 
was clicked. When this was done, the Dispersion Function form name on the left changed from a 
gray octagon to a red octagon. This indicates that additional information is required on the 
Dispersion Function form if OK is clicked and this dispersion model option is saved.   

 
Figure 4-23  Relating Model Selection to Forms 

 

4.3.1 Scope Tab 
Each entry in the Scope tab of the Properties form corresponds to a set of variables that are 
required. 
 
MACCS2 uses variables ENDAT1 and ENDAT2 to determine if the simulation should run the 
models ATMOS, ATMOS and EARLY or ATMOS, EARLY and CHRONC.  The Scope tab 
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determines the value of these variables.  ENDAT1 is set to False if the EARLY model is to be 
run.  ENDAT2 is set to False if the CHRONC model is to be run. 
 

 
Figure 4-24  Scope of Calculation 

 
The Atmospheric Dispersion (ATMOS) box is always checked.   
 
Checking the Early Consequences Module (EARLY) box means: 

• A dose conversion factor file needs to be assigned under the File Specifications 
category on Parameters tab of the Project window.  

• Entries on other tabs, namely Site Data, Dose, Evac/Rotation, Wind Rose, and 
Early Effects determine the other required EARLY input variables. 

 
Checking the Late Consequences module (CHRONC) means: 

• Early Consequences are automatically checked. The CHRONC module cannot be 
run without the EARLY module. 

• Entries on the Food tab determine the other required CHRONC input variables. 
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Checking the MACCS2 Cyclical File Set means: 

• A cyclical file set needs to be assigned under the File Specifications category on 
the Parameters tab of the Project window.  

 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.2 Dispersion Tab 
Select the Dispersion tab and select either Power Law Functions or Lookup Tables. 
 

 
Figure 4-25  Dispersion Tab 

 
Selecting the Power Law Function radio button means: 
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• Power law function parameters are required. These must be defined in the 
Dispersion Function form found in the ATMOS/Dispersion category in the 
Parameters tab. WinMACCS forces a value of zero to be used for NUM_DIST 
when building input images for MACCS2. 

 
Selecting the Lookup Tables radio button means: 

• Lookup table parameters are required. These must be defined in the Dispersion 
Table form found in the ATMOS/Dispersion category in the parameters tab.  
WinMACCS uses the variable NUM_DIST as defined in the Dispersion Table 
form when building input images for MACCS2. 

 
The check box labeled Switch to Time-Based Dispersion Model at User-Specified Distance 
means: 

• If this box is checked, then WinMACCS sets the variable DISPMD to the value 
LRTIME. Parameters in the Long-Range Time Based Parameters form found in 
the ATMOS/Dispersion category in the Parameters tab are required.  

• If not checked, then DISPMD is set to the value LRDIST.  The value LRDIST 
causes MACCS2 to use the model used in MACCS2 1.12. 

 
There are three choices for the plume meander model.  MACCS2 uses a variable, MNDMOD, to 
determine which plume meander model to use. The corresponding value of MNDMOD is shown 
in to the right of each entry. 
 
Selecting the Original MACCS2 radio button means: 

• Model used and required input parameters are consistent with MACCS2 1.12.  The 
parameters on the form ATMOS/Plume Specifications/Original Meander are required. 
WinMACCS sets the variable MNDMOD to the value OLD. 

 
Selecting the US NRC Regulatory Guide 1.145 radio button means: 

• Parameters on the form ATMOS/Plume Specifications/US NRC Reg. Guide 1.145 
Meander are required.  WinMACCS sets the variable MNDMOD to the value NEW.   

 
Selecting the None radio button means: 

• There are no required parameters.  The plume meander model is turned off.  WinMACCS 
sets the variable MNDMOD to the value OFF. 

 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.3 Weather Tab 
Select the Weather tab.   
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Figure 4-26  Weather Tab 

 
MACCS2 uses a variable, METCOD, to determine which weather model to use. The 
corresponding value of METCOD is shown on the right of each entry.   
 
Selecting the Constant Weather radio button means: 

• The following forms found in the ATMOS/Weather category in the Parameters 
tab are required: 

o Constant or Boundary Conditions 
o Fixed Start Time Data 

 
 
Selecting the User supplies 120 Weather points radio button means: 

• The following forms found in the ATMOS/Weather category in the Parameters 
tab are required: 

o Constant or Boundary Conditions 
o Fixed Start Time Data 
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o User-Supplied Weather 
o Boundary Limit 

 
The other weather sampling options require specifying a meteorological file. The format of this 
file is described in Appendix A of the MACCS2 Users Guide.  The meteorological file has been 
generalized to also support data for fifteen-minute and thirty-minute intervals.  See Appendix A 
of this guide for more information. However, this finer time resolution for weather data is not 
supported with the User Supplies 120 Weather points (METCOD=3) option. 
 
If the Weather File Specified radio button is selected, then a meteorological file is required and 
needs to be assigned under the File Specifications category on the Parameters tab. Also, a 
sampling method must be chosen.  These are as follows: 
  
Selecting the Fixed Start Time radio button means that the following forms found in the 
ATMOS/Weather category in the Parameters tab are required: 

• Constant or Boundary Conditions 
• Fixed Start Time Data 
• Boundary Limit 

 
Selecting Uniform Bin Sampling means that the following forms found in the ATMOS/Weather 
category in the Parameters tab are required: 

• Constant or Boundary Conditions 
• Samples per Bin 
• Seed 
• Boundary Limit 
• Rain Data Distance 
• Rain Data Intensities 

 
Selecting Nonuniform Bin Sampling means that the following forms found in the 
ATMOS/Weather category in the Parameters tab are required: 

• Constant or Boundary Conditions 
• Seed 
• Boundary Limit 
• Bins 
• Rain Distances 
• Rain Intensities 

 
Selecting Stratified Random Sampling means that the following forms found in the 
ATMOS/Weather category in the Parameters tab are required: 

• Constant or Boundary Conditions 



 67  

• Samples per Day 
• Seed 
• Boundary Limit 

 
If the Weather File Specified radio button is selected then an optional mixing height model can 
be used.  MACCS2 uses a variable, MAXHGT, to determine which mixing height model to use. 
 
The check box labeled Adjust mixing height based on time of day means: 

• If this box is checked, then WinMACCS sets the variable MAXHGT to the value 
DAY_AND_NIGHT. Parameters in the Site Location form found in the 
ATMOS/Weather category in the Parameters tab are required.  

• If not checked, then MAXHGT is set to the value DAY_ONLY.  This causes 
MACCS2 to use the model used in MACCS2 1.12. 

  
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 

4.3.4 Plume Rise Tab 
Select the Plume Rise tab. 
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Figure 4-27  Plume Rise Tab 

 
 
 
 
Selecting the Power Model radio button means: 

• The original MACCS2 heat model is used. Heat rate input is required for each 
plume, which is found in the ATMOS/Release Description/Heat form on the 
Parameters tab. 

 
Selecting the Density and Flow Model radio button means: 

• Average mass flow rate and mass density are required parameters for each plume. 
These are defined in the ATMOS/Release Description/Density and Flow form 
found on the Parameters tab. 

 
The check box labeled Original MACCS2 1.12 Briggs Model means: 
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• If this box is checked, then WinMACCS sets the variable BRGSMD to the value 
ORIGINAL. The original Briggs model is used to simulate plume rise. The 
default and recommended model is the improved one. 

• If not checked, then BRGSMD is set to the value IMPROVED. This causes 
MACCS2 to use the improved plume rise model. 

 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.5 Site Data Tab 
Select the Site Data tab. 
 
It is necessary to fill out this tab if the Early Consequences module was selected.   
 
MACCS2 uses a variable, POPFLG, to determine the site data source. 
 

 
Figure 4-28  Site Data Tab 



 70 

 
Selecting the Import from File radio button means: 

• A site file is required and needs to be chosen under the File Specifications 
category on the Parameters tab on the Project window. This file can be created 
by a preprocessor, e.g., SECPOP2000, to generate the census and economic data 
relevant to the chosen site. A sample site file, Sursit.inp, is included with the 
WinMACCS CD.  A preprocessor, PopMod, is included with WinMACCS.  This 
is used to increase the angular resolution of a site file, and has been integrated into 
the site file specification form.  See Appendix A of this document for more 
details.  

• WinMACCS sets the variable POPFLG to the value FILE. 
 
Selecting the Uniform radio button means: 

• The population density data are required and are specified on the Population Data 
form found in the EARLY/Model Basis category on the Parameters tab. 

• WinMACCS sets the variable POPFLG to the value UNIFORM. 
• SUMPOP is not available as a value for the Results weighting factor. 

The Results weighting factor value determines the way multiple-evacuation-scenario 
results are combined. The actual weight used for each of the scenarios (cohorts) is stored 
in variable WTFRAC found in the EARLY/Emergency Scenario N/Basic Parameters 
forms, where N is the scenario number. 

• If SUMPOP is selected, then the results are computed by a simple summation. 
The site file must include a separate population distribution for each evacuation 
scenario. 

• If TIME is selected, then the weight fraction in the Evacuation tab refers to 
fraction of time.   

• If PEOPLE is selected, then the weight fraction in the Evacuation tab refers to 
fraction of people. 

 
MACCS2 uses a variable, WTNAME, to determine the result weighting method.  This is set to 
SUMPOP, TIME, or PEOPLE, depending on the choice on this form. 
 
Click OK to save the changes. Click Show Required Forms to see how these changes affect the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.6 Dose Tab 
Choices under the Dose tab must be made if the Early Consequences module was selected.   
 
WinMACCS supports FGR (Federal Guidance Reports 11 and 12) dose conversion files created 
with FGRDCF, files created from Federal Guidance Report 13, and dose conversion files created 
by DOSFAC2. DOSFAC2 bases its dose conversion factors on DOE/EH-0070 (1988). 
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Changing the dose conversion factor file has the consequences of changing the possible values 
for organs in many of the forms.  When this file type has been changed, the user may be required 
to modify other forms.  The required forms display empty red octagons to show that they need 
attention after the user clicks OK on the Properties form.  Optional forms that are incorrect are 
not clearly indicated in the interface, but are opened to be repaired when the user tries to run a 
simulation. 
 
Selecting the Federal Guidance Report (FGR-11 and -12) Dose Conversion Factor File 
(FGRDCF) radio button means: 

• Early injuries and early fatality calculation options are not available. These 
selections, Early Fatality Effects and Early Injury Effects are grayed out on the 
Early Effects tab in the Properties form. 

• Data on the related forms Early Fatality Parameters and Early Injury Parameters 
are not used. 

• Data defined on the Early Fatality Radius form in the Early/Output Control 
category are not used. 

• The Annual Threshold and Piecewise Linear dose models are not available on the 
Dose tab. Only the Linear No Threshold model is available to the user. 

 
Selecting the File Created by DOSFAC2 radio button means: 

• If the Late Consequences module is selected, then the Annual Threshold and 
Piecewise Linear dose models are available for selection. 

• The form Organs of Risk DOSFAC2 is required.   
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Figure 4-29  Dose Model Tab 

 
Selecting the File Created from FGR-13 radio button means: 

• If the Late Consequences module is selected, then the Annual Threshold and 
Piecewise Linear dose models are available for selection. 

• The form Organs of Risk FGR-13 is required.   
 
The user has three dose models to choose from.  MACCS2 uses a variable, DOSMOD, to 
determine the dose model chosen. 
 
Selecting the Linear No Threshold dose model radio button means:  

The linear no-threshold (used in earlier versions of MACCS2) dose model is used to 
calculate doses.  DOSMOD is set to LNT 

 
Selecting the Annual Threshold dose model radio button means: 
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• The EARLY/Dose Model/Annual Threshold form must be completed. 
• The EARLY/Dose Model/Lifetime Threshold form can be optionally completed. 
• DOSMOD is set to AT. 

 
Selecting the Piecewise Linear dose model radio button means: 

• The EARLY/Dose Model/Piecewise Linear form must be completed. 
• DOSMOD is set to PL. 

 
Selecting either the Annual Threshold or Piecewise Linear models means: 

• If the Activate KI Model check box is checked, the EARLY/Dose Model/KI 
Ingestion form must be filled out instead of the EARLY/Emergency Scenario 
One/KI Ingestion form. In this case, only the values 0 or 1 are valid for 
POPFRAC on the KI Ingestion form.  

• On the Food tab the options User supplies COMIDA2 file or No Food Model must 
be chosen. 

• Files must be specified under the GENERAL/File Specifications/Annual 
Differential DCF Files and GENERAL/File Specifications/Annual Differential 
COMIDA2 Files forms.   

 
MACCS2 uses a variable, KIMODL, to determine if the KI model is to be used.  If the check box 
Activate KI Model is checked, then this variable is set to KI.  Otherwise, this variable is set to 
NOKI. 
  
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.7 Evac/Rotation Tab 
It is necessary to fill out this tab if the Early Consequences module was selected.   
 
Choose the number of evacuation scenarios. WinMACCS supports up to 20 scenarios. (Scenarios 
two through twenty correspond to EARLY change sets in the MACCS2 input files.) Evacuation 
scenarios are called cohorts in the MACCS2 Users Manual. 
 
MACCS2 uses a variable, EVATYP, to determine the evacuation model chosen for scenario one.  
This is set to RADIAL, NETWORK, or NONE, depending on the choice on this form. 
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Figure 4-30  Number of Evacuation Scenarios 
 
Choosing the Number of Scenarios greater than one means: 

• Other evacuation scenarios use the same data as the previous scenario. 
• Variable WTFRAC is used to weigh the significance of the evacuation scenarios. 

For example, if 95% of the population evacuates as part of scenario one, and 5% 
evacuates as part of scenario two, then under the EARLY category Emergency 
Scenario One on the Basic Parameters form, WTFRAC must be set to .95; 
similarly, WTFRAC must be set to .05 under Emergency Scenario Two. In this 
example, PEOPLE should be selected on the Site Data tab in the Properties form. 

 
Choosing the Number of Scenarios equal to one means that the value of WTFRAC in the Basic 
Parameters form under the Emergency Scenario One category must be set to one. 
 
Choose the evacuation model for scenario one. 

 
       

Figure 4-31  Evacuation Type 
 
Selecting the No Evacuation option means: 

• The only option for the evacuation type field for subsequent evacuation scenarios 
(if applicable) is None. 

 
Selecting the Evacuation option and Radial from the drop down menu means: 

• The options for the evacuation type for subsequent evacuation scenarios (if 
applicable) are None and Radial. 

 
Choosing the Evacuation option and Network from the drop down menu means: 

• The options for the evacuation Type field for subsequent evacuation scenarios (if 
applicable) are None and Network. 

• The field Wind Shift and Rotation must be set to Wind Shift without Rotation. 
 
Choose the calculation method used to apply nuclide dispersion to the population.  
 
MACCS2 uses a variable, IPLUME, to determine which wind direction model to use. The 
corresponding value of IPLUME is shown on the right of each entry.   
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Figure 4-32  Wind Shift and Rotation 

 
Choosing No Wind Shift with Rotation means: 

• All subsequent plume segments move in the same direction as the initial plume 
segment. 

• All plume segments are rotated around the compass, creating a result for each 
angle, and for each weather trial, if weather bin sampling is selected. There are 
typically sixteen angles per 360 degrees.  The results are weighted using the wind 
rose for the weather bin or the user defined values for the wind rose (see below). 

• IPLUME is set to one. 
 
 
Choosing Wind Shift with Rotation means: 

• Plume segments move in the direction that the wind is blowing at the time of their 
initial release. 

• All plume segments are rotated around the compass, creating a result for each 
angle, and for each weather trial, if weather bin sampling is selected. The results 
are weighted using the wind rose for the weather bin or the user defined values for 
the wind rose (see below). 

• IPLUME is set to two. 
 
Choosing Wind Shift without Rotation means: 

• Plume segments move in the direction that the wind is blowing at the time of their 
initial release. 

• Only the wind direction indicated in the meteorological file or input is used for 
the plume segments. Thus, only a single result is generated per weather trial. 

• IPLUME is set to three. 
 
Enter the evacuation Type for the other scenarios by filling in the grid. 
 

 
Figure 4-33  Additional Evacuation Data 
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Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.8 Wind Rose Tab 
It is necessary to fill out this tab if the Early Consequences module was selected.   

 
Figure 4-34  Wind Rose Tab 

 
The corresponding value of the MACCS2 variable OVRRID is shown to the right of each entry.     
 
Selecting the User Supplied radio button means: 

• Wind rose probability parameters are required. These are defined in the Wind 
Rose Probabilities form found in the EARLY/Model Basis in the Parameters tab. 
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Selecting the Default radio button means:  
• Wind rose probabilities for each weather sampling bin are used. If no wind rose is 

available, a uniform wind rose is used (i.e., the probability is 0.0625 in each 
direction if the compass is divided into sixteen equal angles). 

 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.3.9 Early Effects Tab 
It is necessary to fill out this tab if the Early Consequences module was selected.   
 

 
Figure 4-35  Early Effects Calculations 

 
Select the desired early effects calculations.  
 
If an FGRDCF dose conversion factor file was specified, early fatality and injury results are not 
available. 
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Selecting the Early Fatality Effects check box means: 
• Early fatality parameters must be defined on the Early Fatality Parameters form.   
• The fatalities defined can then be included in the output requests on the Health-

Effect Cases form (type 1), Average Individual Risk form (type 4), Centerline Risk 
form (type 7) and Population-Weighted Risk form (type 8).   

 
Selecting the Early Injury Effects check box means: 

• Early injury parameters must be defined on the Early Injury Parameters form.   
• The injuries defined can then be included in the output requests on the Health-

Effect Cases form (type 1), Average Individual Risk form (type 4), Centerline Risk 
form (type 7) and Population-Weighted Risk form (type 8).   

Note: If the Early Injury Effects check box is not selected, then early injury output 
requests are not calculated by MACCS2. Requests for early injury results must be 
removed from the Health-Effect Cases form (type 1), Average Individual Risk 
form (type 4), Centerline Risk form (type 7), or the Population-Weighted Risk 
form (type 8).  

 
Selecting the Latent Cancer Effects from Early Exposure check box means: 

• Latent cancer parameters must be defined on the forms found under the Latent 
Cancer Parameters  category, namely Latent Cancer Parameters and Latent 
Cancer Thresholds.. 

• The latent cancer results can then be included in the output requests on the 
Health-Effect Cases form (type 1), Average Individual Risk form (type 4), 
Centerline Risk form (type 7) and Population-Weighted Risk form (type 8). 

Note: If the Latent Cancer Effects from Early Exposure check box is not selected, 
output requests on the Health-Effect Cases form (type 1), Average Individual Risk 
form (type 4), Centerline Risk form (type 7), and Population-Weighted Risk form 
(type 8) may no longer be valid if they reference latent cancers that are no longer 
defined. 

 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 
4.3.10 Food Tab 
It is necessary to fill out this tab if Long-Term Consequences was selected.   
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Figure 4-36  Food Chain Model 

 
MACCS2 uses a variable FDPATH to determine which food model to use.  
 
Selecting the No Food Model radio button means: 

• The Annual Threshold and Piecewise Linear dose models are available. If one of 
these models is chosen, a set of fifty-one dose conversion factor files is required. 

•  FDPATH is set to OFF 
 
Selecting the MACCS Food Model radio button means: 

• The older MACCS food-chain model is used instead of the COMIDA2 model.  
• The Annual Threshold and Piecewise Linear dose models are not available. 
• FDPATH is set to OLD. 
• MACCS2 uses variable NTTRM to indicate the number of crop weathering terms 

used if the MACCS2 food model is used.  NTTRM is set to the value indicated on 
this tab. 

 
Selecting the User Supplies COMIDA2 File radio button means: 
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• The Annual Threshold and Piecewise Linear dose models are available. If one of 
these models is chosen, a set of binary COMIDA2 and the corresponding dose 
conversion factor files used to create those binary COMIDA2 files are required. 

• If the Linear (LNT) dose model is chosen, a single COMIDA2 file must be 
selected by the user. The dose conversion factor file must be the same one used to 
create the binary COMIDA2 file. 

• FDPATH is set to NEW. 
 
Selecting Create COMIDA2 File radio button means: 

• The Annual Threshold and Piecewise Linear dose models are not available. 
• The COMIDA2 binary file is created when the simulation is run. Uncertain values 

in the COMIDA2 input are supported. 
 
Click OK to save the changes. Click Show Required Forms to see how this change affects the 
form states in the Parameters tab window and the tab states in the Properties form without 
saving the changes. Click Cancel to close this form without saving any changes. 
 

4.4 Modifying Parameters 
A parameter modification form can be opened in one of two ways  

• Double-click on the variable name or the form containing the variable found on 
the Parameters tab in the Project window. 

• Select the parameter name in the Open Parameter Form and click OK. 
 
To open the Open Parameter Form, select Edit→Find Parameter Window… from the main 
menu. 
 

 
Figure 4-37  Open Parameter Form 
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The list of variables can be navigated by using: 

• The up and down arrow keys on the keyboard. 
• Typing a letter to position the list to parameters starting with that letter. For 

example, typing the letter m positions the list to the parameters starting with the 
letter M. Subsequent typing of that same letter moves the list position to the next 
variable starting with that letter. 

• The scroll bar on the form. 
 
Multiple variables can be selected in the list by: 

• Clicking more than one of the variable names on the list. 
• Navigate through the list using the arrow keys. The hit the space bar on the 

keyboard when the variable name has focus in the combo box. Focus is indicated 
by a dotted rectangle boxing the variable name. 

 
The windows associated with the selected variables can be opened by: 

• Clicking OK. 
• Typing the Enter key on the keyboard. 

 
In some cases, more than one form contains the same variable name. Sometimes the variables are 
separate entities, for example ORGNAM has a different usage on the Early Fatality Effects form 
and Off Centerline Dose form. All of the forms that contain the selected variable are opened. 
 

4.4.1 Parameter Modification Forms 
The following are the main components of a parameter modification form: 

• Enter Comments: Optional comments are entered in this field. The expected usage 
is to enter comments related to the justification or derivation of parameter values. 

•  Eraser Button: Clicking this button clears the values from all non read-only 
variables. 

• Data entry area: The type of the variable that has focus is displayed in blue letters 
below the data entry area along with the variables acceptable bounds and units, if 
applicable.   

• Type and Bounds description area: are shown in blue letters.  This displays the 
type and bounds of the variable that has focus.   
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Figure 4-38  Parameter Modification Form 

 
• Description area: Contains a brief description of the variable that has focus. 
• Change Distribution button: Most real-valued variables can be specified as 

uncertain. Uncertain variables have a probability distribution associated with 
them. To change the value of a variable to uncertain, either double-click on the 
text box or cell, or click on the Change Distribution button. This can also be used 
to change a variable from uncertain back to a constant.   

Note: Not all variables are allowed to be uncertain. If a variable has focus and the 
Change Distribution button is enabled, then this variable can be uncertain.   

• OK button: To save and apply these changes, click OK.   
Note: All of the data on the form must be entered before the user can save any of 
the data on the form. If a box is left blank, and OK is clicked, an error message 
pops up. This serves as a reminder to complete the form before clicking OK to 
save the data. 

 
• Cancel button: To ignore the changes, click Cancel or close the window by 

clicking on the        in the upper righthand corner. 
4.4.1.1 Modifying a Data Grid 
Arrays and vectors are displayed in data grids.  Data grids have the following characteristics: 

• To select a row, click on the small box on the row preceding the data. 
• To delete a row press the Delete key on the keyboard after selecting the row.   

 
If typing in values for a row, press the ESC key on the keyboard to undo your typing.  As long as 
the pencil icon is shown on the left margin of a row, it is possible to click in a cell on that row 
and press the ESC key to undo changes.   

Type and 
Bounds 

Description 

Data Entry 
Area 

{ 



 83  

• Clipboard functionality is provided. To use the copy feature in the grid, select the 
desired data from the grid with a mouse down, drag, mouse up motion. Figure 
4-39 illustrates a selected area in the grid. To copy the data in this selected area to 
the Windows clipboard, select the Edit→Grid→Copy to Clipboard function. 
Similarly, the Edit-Grid→Paste from Clipboard function can be used to replace a 
selected area in the grid with data on the Windows clipboard. This function can be 
used to transfer data from an Excel spreadsheet into WinMACCS. 

 

 
Figure 4-39 Selecting Grid Data for Copy and Paste 

 
When modifying a grid on a parameter form, it may be necessary to insert rows or columns. 
 
To insert a row or column: 

1. Click on the arrow symbol next to the first column on a row to highlight the row or click 
on the column header to highlight the column. 

2. Select Edit→Grid→Insert Columns or Edit→Grid→Insert Rows from the main menu.  
Note: these operations may not be available for some vectors or arrays of fixed size. 

 
After the Grid Insert Form opens: 

1. Choose to insert the rows/columns either before or after the selection.   
2. Enter the number of rows or columns to insert in the grid.  
3. Click OK to insert, or Cancel to cancel the operation. 

 

 
Figure 4-40  Inserting Rows in a Grid 
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The menu option to insert rows is not available when 
• The number of rows on a form is fixed (e.g., the ATMOS/Dispersion/Dispersion 

Function form. 
 
The menu option to insert columns is not available when: 

• Each column on a form represents a vector (e.g., the 
ATMOS/Dispersion/Dispersion Table form). 

4.4.1.2 Supported Data Types 
The following data structures are supported: 

1. Scalar data: These are single values that are associated with variables. A scalar has 
various types, as listed below.   

2. Vector data: These are singly subscripted variables. Multiple vectors can be displayed 
on the same grid; however, each of these vectors must have the same number of rows.   

3. Array data: These are multiply subscripted variables (i.e., arrays). A single array can be 
displayed on a grid.   

 
The following types are supported: 

1. Integer: A number with no decimal point. An integer can be positive, negative, or zero. 
2. Real: A number that has a decimal point.  
3. Logical: Represented by a pull down menu. Value is either True or False. 
4. Characters: A character string. Size requirements are shown in blue letters below the 

data entry area. 
5. Drop-Down Menu: Possible values are displayed as a pull down menu. Only a portion 

of the name needs to be typed. For example, on the ATMOS/Output Control/Spatial 
Intervals for Output form, typing a c for CCDF or an n for NONE and advancing to 
another field completes the data entry for the CCDF enumerated field. 

6. File: The name of a file is specified by clicking the browse button  on 
the parameter modification form. The selected file is copied to the project\data\ 
directory.  

7. Linked Variables: The values of some variables are array sizes calculated by 
WinMACCS. For example, NUM_DIST is the size of the vectors DISTANCE, 
SIGMA_Y_A, etc. This variable is known in the interface as a 'linked variable.'  It 
cannot be directly modified by the user. It is not in a box, which is intended to imply 
that the user cannot edit it. However, if the user clicks on the value, information 
regarding the linked variable is displayed at the bottom of the form. The value of the 
variable is updated as the number of grid rows increase or decrease. Linked variables 
are of type Integer, but can only take on positive values. 
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Figure 4-41  Example of a linked variable, MAXGRP 

 
Note: A gray background in an input area indicates that the variable is read-only. In other 

words, the user cannot change the value of this variable on this form. 
 
Supported data types that may be described in the Type and Bounds description area (see Figure 
4-38) are described in the following examples: 

1. Real [.01, 100.]: A number between 0.01 and 100., inclusive, must be entered in the text 
field. 

2. Integer [1, NUMREL], NUMREL=2: A 1 or a 2 must be entered in the text field. If the 
value of NUMREL, the number of plume segments, is modified and saved on another 
form, then the bounds are changed to reflect the new value of NUMREL. 

3. 1 to 16 Characters: A character string that is at least one character and not more than 16 
characters must be entered in the field. 

4. Row Bounds: [1, 10]: The grid with focus must have at least one row and not more than 
10 rows. 



 86 

5. Nrows = MAXGRP (MAXGRP=9): The grid with focus must have exactly 9 rows. If 
the value of MAXGRP is modified and saved on another form, then the number of 
required rows is changed to reflect the new value of MAXGRP. 

4.4.2 Making a Parameter Value Uncertain 
WinMACCS allows input parameters values to be made uncertain and enables sampling of the 
uncertain variables. The sampling is done using a stratified Monte Carlo method known as Latin 
Hypercube Sampling (LHS). The sampling allows the effect of an uncertain input value on 
predicted results to be explored. Uncertain variables must be assigned a distribution function 
from which samples are selected. The distribution function usually represents degree of belief 
over a range of values that are considered credible for that parameter. There are a number of 
methods for establishing degree of belief, one of which is to perform an expert elicitation. 
 
To make a parameter value uncertain, open the window associated with that parameter. This can 
be done by double-clicking on the variable name in the Parameters tab in the Project window or 
by using Edit→Find Parameter Window to locate the form.  
 
On the form, double-click on the parameter value or click on the parameter value and then on the 
Change Distribution button. 
 
A form opens with the parameter name in the form title (or caption). 
 
Use this form to: 

• Change parameters from constants to uncertain values described by probability 
distributions. 

• Change parameters from distributions to constants. 
• Change the probability distribution associated with the variable. 

 
Notice that the variable name is shown in the title area of the form. If an array or vector element 
is associated with a distribution, then the index is also part of the name shown in the title bar. In 
Figure 4-42, REFTIM(2) in the caption portion of the form indicates that the second value of 
vector REFTIM is being considered for modification. 
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Figure 4-42  Assigning a Probability Distribution to a Parameter 

 
Modify the value of the uncertain parameter as follows: 

• Select the type of distribution from the Distribution pull down list. 
If the parameter is to be changed from a distribution to a constant (deterministic) value, 
set the distribution to CONSTANT.   
 
WinMACCS supports a wide range of distribution types, and each distribution type can 
accept a wide range of values for its parameters. It is possible to specify values for the 
distribution parameters that lead to invalid distributions, causing the LHS sampling to 
fail. The distribution parameter values entered should represent a reasonable distribution 
for the parameter. Furthermore, it is possible to define distributions that lead to illegal 
values (e.g., a negative value for a MACCS2 parameter that must be greater than zero).  
• Enter the values that define the distribution in the edit boxes or tables. The type of 

distribution determines the amount and type of information needed to define the 
value.  

 
These values either consist of a list of (x, y) pairs (known as tabulated data), or a list of 
parameters (such as the mean and standard deviation of the normal distribution). 
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Figure 4-43  Tabulated Uncertain Parameters 

• To delete a row of tabulated data, select the row by clicking on the left margin of 
the row.  Press the Delete key on the keyboard.  Press the ESC key on the 
keyboard to undo typing.  As long as the pencil icon is shown on the left margin 
of a row, it is possible to click in a cell on that row and press the ESC key to undo 
changes.   

• To insert a row of data, select an existing row.  Click the row insert button ( ).  
A new row is inserted before the selected row. 

• Use the left or right arrow key on the keyboard to go to an adjacent cell.  The 
Enter key advances the curser to the next cell. 

• To save changes, click the OK button.  This closes the window and saves any 
changes made to the parameter value.  The value of the parameter in the 
parameter modification form is set to the character string "Uncertain" and has a 
different colored background than constant values on the form. 

 
 

 
Figure 4-44  Uncertain Variable in a Parameter Modification Form 
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• To discard any changes, click the Cancel button. 
• To view the current distribution entered, click the Apply Distribution button.  LHS 

starts, and one hundred samples are returned and displayed.  The data can be 
viewed as a CDF, CCDF, or a Scatter plot.  The mean of the distribution is shown 
in each view.  The sampled values used when running the model may differ from 
those shown on this graph because the input to LHS may not be the same.   

 
To know what values have been set to uncertain after a simulation, open the file LHS.inp, which 
is one of the input files created by WinMACCS. This file can be opened by clicking the Files tab 
within the project, opening the Input category and then double-clicking on the file name 
LHS.inp. The raw data used in the MACCS2 simulation can be viewed by double-clicking on the 
file name LHS.out. 

4.4.3 Correlate Uncertain Parameters 
In many cases, sets of uncertain input variables are correlated to some extent. For example, 
atmospheric dispersion is often considered to have a large degree of uncertainty. In MACCS2, 
crosswind and vertical dispersion are treated independently in terms of the coefficients that 
control them. However, the two are related in the sense that both are governed by the degree of 
turbulence in the atmosphere. Thus, when crosswind dispersion tends to be large, vertical 
dispersion tends to be large as well. If the input parameters for dispersion are treated as 
uncertain, then it makes sense to correlate the values that control crosswind dispersion with those 
that control vertical dispersion so that either both are either large or both are small. It does not 
make physical sense for one to be small while the other is large, but this could be the case if the 
two sets of parameters were sampled and assumed to be uncorrelated.  
 
WinMACCS allows two methods for correlating uncertain input variables. The first uses rank 
correlation coefficients and is described in this subsection; the second method performs a direct 
rank reordering of one variable and is described in the following subsection. 
 
To correlate variables that have been chosen to be uncertain, select Edit→Correlate Uncertain 
Variables→Linear Coefficients from the main menu. This opens the Correlate Uncertain 
Variables table, which lists each rank correlation that is currently defined and allows ones to be 
defined. 
 
It is possible to specify combinations of rank correlations that are not mutually consistent.  Such 
inconsistencies are generally in the form of circular correlations. For example, two parameters 
"A" and "B" can be assigned a correlation of 0.99, parameters "B" and "C" can also be given a 
correlation of 0.99, but parameters "A" and "C" can be assigned a correlation of -0.99.  Each 
correlation is valid by itself, but the three are logically incompatible. The parameter sampling 
may fail if any circular correlations are inconsistently defined. 
 
A correlation can be added in the table's insertion row (indicated by "*") by doing the following: 

1. Click in the "Parameter One" cell and select one of the uncertain parameters from the 
list-box.   

2. Click in the "Parameter Two" cell and select the second parameter from the list-box.   
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3. Enter the desired rank correlation coefficient between the two selected parameters in the 
column labeled "Correlation Coefficient." 

 
Because this is a rank correlation, the correlations apply to the ranks of the parameter values 
rather than to the values themselves. Correlations coefficients must be greater than -1 and less 
than 1. These limits are enforced by WinMACCS. 
 
If any two parameters are uncorrelated, they have an implied correlation coefficient of zero, 
which is the default. Implied correlation coefficients are not listed in the table. Correlations can 
be removed (i.e., set to zero) by selecting the grid row and pressing the delete key on the 
keyboard. 
 
Use the arrow keys to move from cell to cell in the grid.  
 
Click OK to preserve changes. Click Cancel to discard changes made to the correlations. 
 
WinMACCS creates a report titled SampleRank.out in the project Input/ directory that 
summarizes the correlations and the order and values of the uncertain variables used in the 
MACCS2 simulations. 
 

 
Figure 4-45  Correlate Uncertain Variables 
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4.4.4 Enforce Rank Order 
 
After LHS has run and imposed correlations specified by the user, WinMACCS can reorder 
some of the variables to be consistent with the rank order of other variables.  This is a desirable 
feature when there is a need to impose a perfect correlation of 1 or -1 between two sets of 
variables, which LHS does not support. 
 
There are some restrictions on the correlations that WinMACCS allows.  For example, it doesn’t 
make sense to rank correlate two variables, A and B with some coefficient, and then impose a 
rank order of B with respect to the order of A.  WinMACCS does not allow the same pair of 
variables to be rank correlated (as described in the preceding subsection) and also to be reordered 
(as described in this subsection). 
 
To specify a rank order: 

1. Open Parameter Modification forms and set variables to be ranked to probability 
distributions by clicking on the Make Uncertain button. Close the forms, saving the 
values. 

2. Open the Enforce Rank Order of Uncertain Variables form by selecting 
Edit→Correlate Uncertain Variables→Enforce Rank Order. 

3. In the column labeled Reorder Basis select the uncertain variable from the pull down 
menu whose rank order is used to order the variable specified in the column labeled 
Reorder Parameter.  The order of the Reorder Basis variable is not changed from the 
order of values returned from LHS. 

4. In the column labeled Reorder Parameter, select the uncertain variable whose order is 
to be changed. 

5. In the column labeled Rank Order select either Inverse Order  to order the variable in 
the opposite order as the basis parameter, Reorder Basis, or Same Order to order the 
variable in the same relative order as the basis parameter.   

6. Add as many entries as needed in the table. 
7. Click OK to preserve changes. Click Cancel to discard changes. 

 
Rows can be deleted by selecting the grid row and pressing the delete key on the keyboard.  Use 
the arrow keys to move from cell to cell in the table.  
 
WinMACCS creates a report titled SampleRank.out in the project Input/ directory that 
summarizes the correlations and the order and values of the uncertain variables used in the 
MACCS2 simulations.  
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Figure 46 Enforce Rank Order Form 

 
 
In the following example, a perfect positive correlation is imposed between ATMOS variables 
BUILDH(1) and SIGZINIT(1), and a perfect negative correlation is imposed between 
COMIDA2 variables DAIRY_RATE(1) and DAIRY_RATE(3).       
 

 
Figure 47 Enforce Rank Order Example 

This ordering request causes the values of DAIRY_RATE(3) and SIGZINIT(1) to be changed 
from the order returned by LHS.  After execution, LHS.out can be opened by double clicking the 
entry LHS.out found on the Files Tab in the Input/ category. As an example, suppose LHS.out  
contains the following information: 
 
Trial BUILDH(1) DAIRY_RATE(1) SIGZINIT(1) DAIRY_RATE(3) 

1 249.675 5.81245 295.12 9.16814 
2 123.061 10.1165 281.956 10.3411 
3 180.287 15.7363 338.324 12.1482 
4 214.842 21.8037 267.811 13.5931 
5 188.622 19.2878 312.628 5.65193 
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The actual order used in the sequence of MACCS2 simulations can be viewed in the file 
SampleRank.out, found in the project Input directory.  In this example, the reported order is as 
follows: 
 
Sample Value Rank Value Rank Value Rank Value Rank
Trial BUILDH(1) DAIRY_RATE(1)  SIGZINIT(1)  DAIRY_RATE(3) 

1 249.675 5 5.81245 1 338.324 5 13.5931 5
2 123.061 1 10.1165 2 267.811 1 12.1482 4
3 180.287 2 15.7363 3 281.956 2 10.3411 3
4 214.842 4 21.8037 5 312.628 4 5.65193 1
5 188.622 3 19.2878 4 295.12 3 9.16814 2

 
This table tells us which values are used in each MACCS2 simulation.  For example, for trial 
number 3 (corresponding to the output file Model3.out), BUILDH(1) is set to 180.287 and 
SIGZINIT(1) is set to 281.956. 
 
Notice that values of BUILDH(1) and DAIRY_RATE(1) are preserved from the order listed in 
the LHS output.  However, values for SIGZINIT(1) and DAIRY_RATE(3) have been reordered 
so that the rank order for SIGZINIT(1) is the same as that of BUILDH(1), and the rank order of 
DAIRY_RATE(3) is the opposite of that for DAIRY_RATE(1). 
 

4.5 Special WinMACCS Variables  
4.5.1 Chemical Group Identifiers, GRPNAM 
The chemical group names used in WinMACCS do not have a counterpart in MACCS2. This 
variable is entered on form ATMOS/Radionuclides/Chemical Names. In WinMACCS, GRPNAM 
is a required variable used for labeling on the following forms: 

• ATMOS/Release Description/Particle Size Distribution.  
• ATMOS/Release Description/Plume Segment Release Fraction.     
• ATMOS/Deposition/Wet/Dry Depos Flags. 

 
MACCS2 input images often list the chemical group names as a comment as shown in the 
following example taken from input file in1a.inp. 
 
*                         XE/KR    I          CS       TE       SR       RU      LA      CE      BA 
* 
RDRELFRC001  1.0E+0  6.8E-1 6.4E-1 1.7E-1 4.2E-3 2.3E-3 1.6E-4 4.0E-4 6.3E-3 
 
This input was translated into a new variable, GRPNAM, as shown in Figure 4-48. 
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Figure 4-48  Chemical Group Names, GRPNAM 

 
Figure 4-49 shows how GRPNAM is used as a label in the ATMOS/Release Description/Particle 
Size Distribution form. 
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Figure 4-49  GRPNAM Used in Form Labeling 

 
Chemical group names are written to MELCOR plot files. MELMACCS, a software product 
used to interface the output from MELCOR to the input required by WinMACCS, reads the 
chemical group names from the MELCOR plot file.  These names are translated into input 
images read by WinMACCS.  This interface file can then either be imported into WinMACCS 
using the main menu option File→Import MACCS2 Input File or can be specified as a file in the 
MACCS2 cyclical file set in the General/File Specifications/Cyclical File Set form. 
 
MELMACCS writes the chemical name information in a MACCS2 input file as images that are 
recognized by WinMACCS, but not by MACCS2.  The image prefix used is ISGRPNAM, as 
shown in the following example: 

ISGRPNAM001 Xe/Kr 

ISGRPNAM002 I 

ISGRPNAM003 Cs 

ISGRPNAM004 Te 

ISGRPNAM005 Sr 

ISGRPNAM006 Ru 

ISGRPNAM007 La 

ISGRPNAM008 Ce 

ISGRPNAM009 Ba 
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4.6 Annual Differential Threshold Dose Conversion Factor and COMIDA2 
Files 

If the Annual Threshold or Piecewise Linear dose models are chosen on the Dose tab of the 
Project Properties form, then a set of fifty-one dose conversion factor files are needed by 
MACCS2.   Additionally, if the COMIDA2 Food Model is chosen on the Food tab of the Project 
Properties form, then a set of fifty-one COMIDA2 files are needed by MACCS2, each 
COMIDA2 file having been created with its associated DOSFAC2 file.   
 
WinMACCS is distributed with files sets to be used with the annual threshold or piecewise linear 
dose models.  The first set is based on DOE/EH-0070 (1988); the second is based on EPA (2002) 
Federal Guidance Report No.13. 
 
The base DCF file is one that contains the conversion factors for a fifty year commitment period. 
The base Comida2 file is created using the base DCF file.   
 
The annual, differential DCF files contain the dose conversion factors for each year of the 50-
year commitment period. These file names are sequenced to enable the identification of the year 
number. For example, FGR13DCF03.inp corresponds to the dose conversion factors used to 
calculate the dose in year three for an exposure that occurred in year one. The annual COMIDA2 
files are created using the corresponding annual DCF files. 
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Figure 50 Threshold DCF Files 

To specify an annual differential DCF and COMIDA2 file set:  
1. Open the File Specifications/Annual Differential DCF Files form. 
2. Open the folder where the DCF are files are located.  Select the correct hard drive in the 

Select Drive pull down menu and locate the folder on the form.   When WinMACCS is 
installed, a copy of the DCF and COMIDA2 files are put in the Program 
Files\WinMACCS folder.  Additional copies can be found on the installation CD.  

3. Select the base DCF file in the box directly under the title Click Base DCF File.   In the 
example shown in Figure 50, the name of the file is FGR13DCF.inp.  The base file 
name is copied in the box labeled Base DCF File.  Other file names are generated given 
this base file following the algorithm of appending the year number to the file name.  
WinMACCS expects these additional files to be present in the current directory. 

4. Click OK to save changes.  WinMACCS copies the base DCF file and the fifty auxiliary 
files to the project directory. Click Cancel to close this form without saving any 
changes. 

5. Repeat this process to define the COMIDA2 file set if the COMIDA2 model is run.  The 
forms share a code base, and function the same.   In this case, open the File 
Specifications/Annual Differential COMIDA2 Files form.  
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4.7   Cyclical MACCS2 Files 
MACCS2 input can be changed using successive input files as follows: 

• In the Properties form on the Scope tab, click on the checkbox MACCS2 Cyclical 
File Set. Click OK. 

• Specify the cyclical file set by double-clicking on the File Specifications/Cyclical 
File Set form on the Parameters tab of the Project window. 

• Complete this form as described in the next subsection. 
 
The cyclical files must be formatted consistently as MACCS2 input files. However, the ATMOS, 
EARLY, CHRONC, and COMIDA2 input for a single simulation can be combined into a single 
file.   
 
The parameter values specified in each of the cyclical files are used for a simulation.  If a 
required parameter is not specified, the value of that parameter shown in WinMACCS (viewed 
from the Parameter Modification form) is used.  
 
Before executing a set of cyclical files, a complete problem description must be entered into 
WinMACCS. Parameter values in the cyclical files override the parameters in WinMACCS. 
Thus, the cyclical files do not need to contain a complete MACCS2 problem description, but 
only the set of parameters that are to be modified. 
 

4.7.1 Specifying Cyclical MACCS2 Files 
To specify MACCS2 cyclical input files: 

1. Open the File Specifications/Cyclical File Set form. 
2. Navigate to the location of the MACCS2 cyclical files. 
3. Double-click on the MACCS2 cyclical file names to add them to the list on the right 

side of the window. 
4. Click OK to save the file selection. The files are copied to the projects Data\ directory. 

Click Cancel to close the window without copying any files to the Data\ directory. 
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Figure 4-51  Choose Input Files for Cyclical Execution 

 
To remove a file from the cyclical set:  

• Select the file in the list on the right side of the form, as shown in Figure 4-51, 
and press the Delete key. 

 
To change the order of processing the files by WinMACCS: 

• Use the up and down arrow. This changes the order in which the selected file is 
listed.  When MACCS2 executes, the files are used in the order they appear on 
this form. 

 
An interface tool named MELMACCS can be used to create MACCS2-formatted files that 
contain source term information extracted from a MELCOR plot file. They can be specified as 
cyclical files. In this way, a set of source terms for a plant can be run sequentially.  
 

4.7.2 Cyclical Execution with Uncertain Parameters 
It is possible to perform calculations with a cyclical file set and to sample uncertain variables 
using LHS simultaneously. A simple example demonstrates the way MACCS2 input files are 
created. 

Step One: Linking the MACCS2 Cyclical Files 
After running three MELCOR simulations, three MELCOR/MACCS2 interface files 
(Melcor1.txt, Melcor2.txt, and Melcor3.txt) were created using the interface software 
MELMACCS. These files contain legal MACCS2 input cards belonging to the ATMOS module.  
They contain the results of MELCOR simulations that are to be imported into WinMACCS. 
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The MACCS2 Cyclical File Set option is activated on the properties form.  The Specify Cyclical 
MACCS2 Files form is opened, and the files Melcor1.txt, Melcor2.txt, and Melcor3.txt are 
chosen as the cyclical file set, as illustrated in Figure 4-51. 
 
Each of these files contains a different value for the dry deposition velocity associated with 
particle size group number one.   
 
Melcor1.txt contains the following MACCS2 input line:  
DDVDEPOS001 0.01 
Melcor2.txt contains the following MACCS2 input line:  
DDVDEPOS001 0.015 
Melcor3.txt contains the following MACCS2 input line:  
DDVDEPOS001 0.018 

Step Two: Setting a Variable to an Uncertain Value 
Additionally, the variable XPFAC1 is set to an uncertain value as follows: 
 

 
Figure 4-52  Assigning an Uncertain Value to a Variable 

Step Three: Running the Simulation 
The number of simulations is set to six from the Advanced Execution Parameters form. This 
form opens when the user clicks the button labeled Advanced … on the Run Models form. The 
simulations are started when the user clicks the Run Simulation button on the Run Models form. 
The following steps are then performed by WinMACCS: 

• The template files are created as follows:   

atmosTemplateMelcor1.txt  

earlyTemplateMelcor1.txt 
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chroncTemplateMelcor1.txt 

atmosTemplateMelcor2.txt 

earlyTemplateMelcor2.txt 

chroncTemplateMelcor2.txt 

atmosTemplateMelcor3.txt 

earlyTemplateMelcor3.txt 

chroncTemplateMelcor3.txt.   

Because there were no EARLY or CHRONC input cards in the files Melcor1.txt, Melcor2.txt 
and Melcor3.txt, the EARLY and CHRONC template files are identical. 
 
The template files contain the values read from the cyclical input files. A placeholder is inserted 
into these files for the uncertain values.   
 
For example, atmosTemplateMelcor1.txt contains: 
DDVDEPOS001 0.01 
File atmosTemplateMelcor2.txt contains: 
DDVDEPOS001 0.015 
File atmosTemplateMelcor3.txt contains: 
DDVDEPOS001 0.018 
 
Each of the ATMOS template files contain the same placeholder, §3829§, for the uncertain 
value, XPFAC1. The placeholder value, 3829, is an internally generated key used by 
WinMACCS specific to this example.  Each of the ATMOS template files contain: 
 
PMXPFAC1001 §3829§ 

• LHS is invoked, and creates six sample values for the variable XPFAC1. These 
values are in the file LHS.out file. In this example, they are calculated as follows: 

 
Table 4-4.  Example Showing LHS Sample Values 

Sample Value of XPFAC1 
1 0.391692 
2 0.809949  
3 0.352528 
4 0.641766 
5 0.510719 
6 0.111567 

 

• The template files are then used to create the ATMOS, EARLY and CHRONC 
input files for each of the six MACCS2 simulations.   
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Table 4-5.  Example Showing Template Files Created by WinMACCS 

Set 1 atmosTemplateMelcor1.txt 
earlyTemplateMelcor1.txt 
chroncTemplateMelcor1.txt 

Set 2 atmosTemplateMelcor2.txt 
earlyTemplateMelcor2.txt 
chroncTemplateMelcor2.txt 

Set 3 atmosTemplateMelcor3.txt 
earlyTemplateMelcor3.txt 
chroncTemplateMelcor3.txt.  

 
Table 4-6.  Example Showing Relationship of LHS Samples to Template Files 

Simulation 
Number 

Template 
set used 

Value of 
VDEPOS 

Value of 
XPFAC1 

1 1 0.01 0.391692 
2 2 0.015 0.809949 
3 3 0.018 0.352528 
4 1 0.01 0.641766 
5 2 0.015 0.510719 
6 3 0.018 0.111567 
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4.8 Specifying Evacuation Directions and Speeds 
Evacuation directions are required if the network evacuation is enabled.  If the speed multiplier 
option has been activated on the Properties Form, speed multipliers per grid element (i.e., for 
each direction and spatial distance) must be specified for either the radial or network evacuation 
models, depending on which option is selected. 
 

4.8.1 Enabling the Evacuation and Speed Multiplier Model Settings 
Evacuation and speed multiplier models are enabled as follows: 

• Open the Project Properties form by selecting Edit→Project Properties from the 
main menu.   

• Click on the Evac/Rotation tab. 
• Select the evacuation model. 
• Select the evacuation model for each of the scenarios. 
•  If speeds vary within the evacuation grid elements for either the network or the 

radial evacuation models, then check the box Activate Speed Multiplier Model.    
• Click OK 
 

If the Network evacuation is selected for scenario one, then the Network Evacuation Direction 
form is required for scenario one.  A scenario specific Network Evacuation Direction form is 
optional for all additional scenarios where the evacuation model for that scenario is set to 
Network.  
 
If the Activate Speed Multiplier Model is checked the Evacuation Speed form is required for 
scenario one. This information is optional for additional evacuation scenarios when either the 
network or radial evacuation model is selected on the Evac/Rotation tab. 
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Figure 4-50 Activate Speed Multiplier Model 

 
The variables SPAEND and LASMOV must be defined before the Network Evacuation 
Direction forms or Evacuation Speed forms can be successfully opened.  These two variables are 
needed to define the evacuation grid.  As a side effect, NUMEVA must also be defined because 
it is on the same form as LASMOV. 
 

 
Figure 4-53 ATMOS Radial Grid, SPAEND 
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Figure 4-54 Evacuation Boundary, LASMOV 

 
The Network Evacuation Direction forms for each additional network evacuation scenario are 
optionally available.  For example, the form EARLY/Additional Emergency 
Scenarios/Emergency Scenario Two/Network Evacuation Direction is shown as optional if the 
network evacuation model is chosen for scenario two in the Project Properties form.  Similarly, 
the Evacuation Speed forms are optionally available in each additional evacuation scenario.  
However, for both of these forms, LASMOV (and as a side effect, NUMEVA) must be defined 
for each additional scenario.   
 
The Network Evacuation Direction form and the Evacuation Speed form share the same source 
code base.  This means that the navigation of the forms is the same; however, the navigation of 
the forms with respect to specifying the direction or speed variables is different.   

4.8.2 Creating Road Maps to Aid in Evacuation Modeling 
 
Radial distances vary from zero to the upper bound of SPAEND.  Grid elements are numbered 
with 1 for north, 5 for east, etc., when the grid is divided into sixteen equal angles.  Each value of 
SPAEND is represented as a concentric circle. 
 
When a new project is created, neither the Network Evacuation Direction forms nor the 
Evacuation Speed forms show a road map behind the polar grid.  Evacuation directions are 
initially set to be radially outward, as shown in Figure 4-52, and the speed multiplier is set to 
one. 
 
The number or letter drawn at the center of each of the grid elements indicates the associated 
speed multiplier rank.  This is different than the value of the speed multiplier.  If, for example, 
the speed multipliers are either .5 or 1.5, then there would be two possibilities for the multiplier 
rank, namely 1 corresponding to a speed multiplier of .5 and 2 corresponding to a speed 
multiplier of 1.5. 
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Figure 4-55 Initial State of Evacuation Grid 

 
 
If MapGen, a custom software product created specifically for use with WinMACCS, has been 
installed, road maps can be easily created to display behind the grid by clicking on the button 
labeled Create Map File in any of the Network Evacuation Direction forms or the Evacuation 
Speed forms.  When this is done, a file named MapSummary.txt is created and placed in the 
project Input\ directory. 
 
The file, MapSummary.txt is subsequently imported into a separate software package, MapGen, 
to create the road maps. MapGen is implemented as a separate application because of licensing 
issues. No license outside of the NRC licensing requirements is required for WinMACCS or 
MACCS2.  However, the map interface program, MapGen, requires that the Microsoft Map 
Point 2006 libraries be installed.  Thus, to enable the use of maps in the WinMACCS, Microsoft 
Map Point 2006 must be purchased and installed.  
  
 
WARNING: If the Spatial Grid is modified, a consistent set of road maps must be 
regenerated. 
 

Step One: Enter a latitude and longitude 
 
Within the Parameters Tab in the Project window, open the form ATMOS/Weather/Site Location 
by double-clicking on this entry.  Enter the Latitude and Longitude in the form and click OK.  
This form may not be flagged as a required data entry form for the MACCS2 models selected 
(i.e., the icon may have a slash through it), but to generate a set of road maps, it is necessary to 
enter the latitude and longitude of the site. 
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Figure 4-56 Enter Latitude and Longitude 

 
 

Step Two: Create Map Summary.txt file 
 
In any form that shows the polar evacuation grid, click the button titled Create Map File. A file 
titled MapSummary.txt is created and placed into the WinMACCS project Input directory.  
 
 

 
Figure 4-57 Create Map File 

 
Within the Files Tab in the Project window, this file can be optionally viewed by double-clicking 
on the entry Input/MapSummary.txt.   
 
A sample map interface file is as follows: 

* File created using WinMaccs Version 3.1.11 12/7/2006 12:58:24 PM 
* Latitude and Longitude as a decimal 
/LAT           42.10056  
/LON          -91.77722  
* File Name to create, Distance in km from lat, long to edge of square map 
/DAT          Map_0.16.gif   0.1733333  
/DAT          Map_0.52.gif   0.5633333  
/DAT          Map_1.21.gif   1.310833  
/DAT          Map_1.61.gif   1.744167  
/DAT          Map_2.13.gif   2.3075  
/DAT          Map_3.22.gif   3.488333 
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Notice each line of the file that starts with the character string “/DAT”.  Each /DAT lines directs 
MapGen to create a gif file.   
 
Example: 

/DAT          Map_0.16.gif   0.1733333 
  
Two parameters are shown per input line. The first is the name of the file that is created, e.g., 
Map_0.16.gif.  The second parameter is the distance in km from the center of the map to the 
edge of the map as displayed in the WinMACCS interface. 
   
WinMACCS creates a line in the file for each value of SPAEND, the spatial grid distance.  The 
value of SPAEND is built into the name of the GIF file.  This ensures that an incorrect map is 
not shown behind the evacuation grid if the spatial grid entries are modified (SPAEND is 
changed in WinMACCS).  In the above example, the input line corresponds to the spatial grid 
element 0.16 km.   
 
The second number is a measure in km from the center of the map to the outer edge.  This is 
calculated in WinMACCS to allow the map to fit to the edge of the form.   
 
This process assumes that all maps are square.  The control dimensions are fixed; the user has no 
control over these dimensions. 
 

Step Three: Generate road maps using MapGen 
 
Start MapGen from the MapGen group found on the Windows Start Menu. 
Select File/Generate Gif from File from the main MapGen menu. 
 

 
Figure 4-58 Generate Road Map Files 

 
Locate and select the MapSummary.txt file created in the previous step.  Click the Open button. 
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Figure 4-59 Open Map Summary.txt 

 
 
Choose your Data folder under the project folder for the gif file destination.  Click OK. The maps 
are automatically generated. 
 
 

 
Figure 4-60 Complete Creation of Road Maps 

Step Four: View maps in WinMACCS 
 
Observe that when changing the Outer Ring Shown slider, the maps are displayed in the 
background.  If the maps do not display, verify that the Hide Map check box is unchecked, that 
the map .gif files are in the project\Data directory, and that the spatial grid is in agreement with 
the names assigned to the map .gif files.  For example, Map_1609.34.gif corresponds to 1609.34 
km.  This is the map that is displayed when the outer ring in the polar grid is at 1609.34 km.  
This corresponds to an entry in array SPAEND. 
 
The Outer Ring Shown slider must be clicked to refresh the background the first time the maps 
are created. 
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Figure 4-61 Show Maps in WinMACCS 

 

  
4.8.3 Understanding the Polar Grid 
 
Arrows drawn on the grid elements indicate the evacuation direction.  There are four different 
directions supported by MACCS2.  Outward, inward, counter clockwise and clockwise.  Each of 
these directions is shown in a different color. 
 

 
Figure 4-62 Evacuation Grid 

 
The bottom of the screen shows the inner and outer ring displayed on the polar grid.  The integer 
value shown to the right of the sliders labeled Inner Ring Shown and Outer Ring Shown 
correspond to the number in the column preceding the column labeled Radius.  This number is 
the outer boundary of the grid element.  In the example shown in this section, the Inner Ring 
Shown is set to 2, corresponding to a radius of 0.52.  The Outer Ring Shown is set to 3, 
corresponding to a radius of 1.21.  This can be observed by looking at the axis scale shown on 
the polar grid. 
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Figure 4-63 Radius, Sector and Multiplier 

 
 
 

 
Figure 4-64 Inner Ring and Outer Ring Sliders 

 
The numbers, (or letters when more than nine ranks are defined), indicate the speed multiplier 
rank, which is different than the actual speed multiplier.  In this example, the number 1 
corresponds to a multiplier of 0.5, 2 to a multiplier of 1, and 3 to a multiplier of 1.2.  By showing 
ranks, the speed multipliers can be adjusted without requiring the user to adjust the settings on 
the polar grid provided the relative order of speeds hasn’t been modified. 
 
When the grid is clicked, the radial distance from the center of the grid to the click is shown on 
the bottom left portion of the screen. 
 

 
Figure 4-65 Radial Click Distance 

This is useful for diagnostic reasons.  Once a map is displayed behind the grid, the scale may be 
checked if there is a reason to believe that the polar scales and the map scales are inconsistent.  
The number shown in WinMACCS corresponds to the scale of the polar coordinate system.  
From the viewpoint of WinMACCS, the roadmap is simply a picture file. 
 
The roadmap can be displayed in MapGen by entering the latitude and longitude in decimal form 
and the distance from the center to the left edge.  These numbers can be read from the file 
MapSummary.txt in the lines labeled /LAT, /LON, and /DAT, as shown in the following 
example: 
 

* Latitude and Longitude as a decimal 
/LAT           36.19305  
/LON          -115.9819 
* File Name to create, Distance in km from lat,long to edge of square map 
/DAT          Map_1.21.gif   1.289344 
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Enter these numbers and click the Go button in MapGen.  The actual distance from the center to 
the edge can be verified by clicking the edge of the map in MapGen.  This is the shortest distance 
from the center to the edge as calculated by MapPoint, the underlying Microsoft map engine.  
 

 
Figure 4-66 Distance of Line from Center to Edge 

 
The MapPoint interface requires that a viewing altitude be specified. The developers determined 
that the viewing angle is 30.64353 degrees. This viewing angle does not hold at very high 
altitudes.  However, this does not appear to be a problem at distances less than 2000 km.   
 
MapGen is designed to be consistent with MapPoint 2006. Future versions of MapPoint could 
use a different algorithm or viewing altitude formula, and so could produce unexpected results if 
used with MapGen. 
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4.8.4 Modifying the Network Evacuation Direction 
 
The evacuation direction can be modified in two ways.   
 
The first method is to click the grid element.  The direction changes for that grid element each 
time the area is clicked.  The direction rotates ninety degrees clockwise each time the grid 
element is clicked.    
 
When a grid element is clicked, the clicked element is selected in the Radius/Sector list.  In the 
following example, the grid element between 3.22 km and 4.02 km and in the fourth sector is 
selected.  Sector 4 corresponds to ENE in a grid that has been divided into 16 sectors. 
 

 
Figure 4-67 Radius and Sector Selected 

 
The second method is to use the Change button found on the right of the window.   
 
Clicking the UnSelect button clears the selection of the radius and sector. 
 
Selecting a radius from the list and clicking the Change button changes the direction for all grid 
elements at the selected radius by ninety degrees clockwise.  Similarly, selecting a sector but no 
radius changes the direction for all grid elements in the selected sector by ninety degrees.  
Selecting a radius and a sector and clicking on the Change button changes the direction only 
within the selected grid element. 
 

 
Figure 4-68 Select Radius only 

4.8.5 Editing the Speed Multiplier List 
 
A speed multiplier for each grid element is used by MACCS2 to adjust the speed multipliers 
assigned for each evacuation phase in variable ESPEED.  A value of one for the multiplier 
indicates that the speed in that grid element is the same as ESPEED. 
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The default value for the speed rank is one and the speed multiplier has a default value of one.  
To add additional speed multipliers, click the Modify Multipliers button in the Evacuation Speed 
form.  A dialog box like the one in Figure 4-66 opens. 

 
Figure 4-69 Edit Speed Multipliers 

 
Speed multipliers can be added to the list by entering a number followed by Enter or clicking the 
button containing the right arrow symbol.  Multipliers can be deleted by selecting a multiplier 
from the Speed Multiplier list and clicking the button containing the boxed cursive X symbol.   
 
Multipliers are automatically sorted in ascending order.  Multiple entries of the same number are 
not allowed. 
 
Click OK or Cancel when finished. OK accepts the modifications; Cancel deletes them. 
 
Ranks shown on the polar grid are modified when the multipliers are modified.  For example, if 
before editing the multipliers, the rank of 1 corresponded to a speed multiplier of one and a 
multiplier of 0.5 was added in the Edit Speed Multipliers window, the rank of 1 now corresponds 
to a speed multiplier of 0.5. The polar grid continues to show the rank of 1 in the same locations 
as before. 
 
At this time, uncertain speed multipliers are not supported in WinMACCS. 
 

4.8.6 Modifying the Speed Multiplier ranks 
 
The speed multiplier ranks can be modified in two ways.   
 
The first method is to click the grid element.  The rank is incremented by one each time that grid 
element is clicked. For example, clicking a grid element with an initial rank of four results in a 
rank of five if five ranks are defined; otherwise, the rank cycles to one.   
 
When a grid element is clicked, the clicked element is selected in the Radius/Sector list. 
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The second method is to use the Change button shown on the right side of the form.  The first 
step is to clear the radius, sector, and speed multiplier selected, if needed, by clicking the 
UnSelect button.  Selecting a radius and a speed multiplier rank from the list and clicking the 
Change button changes the rank for all grid elements at the selected radius to the selected value.  
Similarly, selecting a sector but no radius changes the rank for all grid elements to the selected 
value. Selecting a radius, a sector, and a speed multiplier rank and clicking on the Change button 
only changes the rank of the selected grid element. 
 
In the example, the speed multiplier rank for the grid element between 0.52 and 1.21 and sector 
two can be changed to 2, if the Change button is clicked, as illustrated below. 
 

 
Figure 4-70 Selecting a Speed Multiplier 
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4.9 Specifying a Site File 
 
Files are generally specified in a general parameter modification form.  However, the site file 
required a custom form because the preprocessor, PopMod.exe, has been integrated with this 
form. 
 
In the past, the site file has been created using an external software source, such as 
SECPOP2000.  This text file is required to be in a format as documented in Appendix A of the 
Code Manual for MACCS2 User’s Guide.  However, SECPOP2000 only supports 16 compass 
directions.  PopMod was written to enable site files to be modified for 32, 48, and 64 compass 
directions.  This software product reads a site file created by SECPOP2000 or some other source.  
The input consists of a total number of compass directions, which must be greater than the 
number of directions on the existing site file.  PopMod creates a site file with data consistent 
with a higher angular resolution.  No new site specific information from the census data source is 
inserted into the site file, but the file is created to be consistent with the existing file.  See 
Appendix A for more information. 
 

 
Figure 71 Specify Site Population File 

 
The Specify Site Population Data File form has components identical to all other parameter 
modification forms.  If a new site file is not needed, then click the Browse… button to define the 
desired site file containing sixteen compass sectors.  The operation of this form is identical to 
any other parameter modification form. 
 
Notice that MACCS2 variable values NUMCOR and Site File are shown on this form. 
 
The Create New button is used to create a new site file with more angular resolution. A label 
titled Angular Directions shows the actual number of angular directions written to the file shown 
in the text box labeled Site File. 



 117  

•  

• 
Figure 72 Create Site File From Existing Site File 

To create a new site file with more angular directions from an existing site file: 
1. Click the Create New button on the Specify Site Population Data File form.  A new 

form titled Create Site File From Existing Site File opens. 
2. Click on the Browse button on this form.  Choose a site file that has a smaller angular 

resolution than the file you need to create.  For the best results, choose a site file that has 
sixteen angular directions.  The actual number of angular directions of the site file 
chosen is displayed on this form next to the label called Angular Directions. 

3. Choose the angular resolution you need from the pull down menu.   
4. Click OK to save the changes.  Click Cancel to close this form without saving any 

changes.  
5. The new file created has the number of new angles appended to the file name.  In our 

example, the source file was Sursit.inp.  Because 48 angles were selected, the new name 
is now Sursit_48.inp.  Notice that the Angular Directions as read from the new site file 
has been updated to 48. 

6. Click OK to save the changes.  Click Cancel to close this form without saving any 
changes.  

 

 
Figure 73 Newly Created Site File 
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4.10 Running Simulations 
To initiate model execution: 

• Open the Run Models form by selecting Execute→Run Models… from the main 
menu. 

• Click on the Run Simulation button. 
 

4.10.1 Run Models Form 
The following are the main components of the Run Models form: 
 
The MACCS2 modules to be used, namely Atmospheric Dispersion, Early Consequences, and 
Late Consequences, can be modified from the Scope tab of the Properties form. The Create 
COMIDA2 File setting can be modified from the Food tab of the Properties form. Scope choices 
cannot be modified on the Run Models form.   
 

 
Figure 4-74  Run a Simulation 

 
MACCS2 Cyclical File Set 
The status of MACCS2 Cyclical File Set can be modified from the Scope tab of the Properties 
form. This cannot be modified on the Run Models form. 
 
Number of Simulations 
The Number of Simulations is the number of cyclical and/or LHS samples to be run. However, 
WinMACCS attempts to prevent redundant simulations. For example, if no cyclical files or 
uncertain parameters are specified within WinMACCS, only a single simulation is performed. 
Likewise, if a set of cyclical files are specified but there are no uncertain parameters, 
WinMACCS performs the same number of simulations as cyclical files. 
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To change the Number of Simulations, click the Advanced… button to open the Advanced 
Execution Parameters form. The user can also modify the seed used by the LHS random number 
generator with this form. 
 
Run Simulation button 
Click the Run Simulation button to initiate LHS, COMIDA2 and MACCS2 simulations. Progress 
is reported in the Results window. 
 
The current simulation number (e.g., the MACCS2 run number) is displayed in the status bar 
found at the bottom of the Run Models form.   
 
Abort Simulation 
Click the Abort Simulation button to abort a MACCS2 run in progress. 
 

4.10.2 Advanced Execution Parameters Form 
To set advanced execution options, open the Run Models window by selecting Execute→Run 
Models from the main menu. Click on the Advanced… button. 
 

 
Figure 4-75  Advanced Execution Parameters Form 

 
The Number of Simulations text box sets the number of times MACCS2 runs.   
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• If there are uncertain parameters, set number of simulations to the number of LHS 
simulations that are to be used in the analysis. Changing this number changes the 
sampled values of the uncertain parameters used in the simulations. 

• If MACCS2 cyclical files are used with or without LHS, enter the number of 
times you want MACCS2 to run. If LHS is not used, the Number of Simulations 
should be the same as the number of cyclical files; if LHS is used, the Number of 
Simulations should normally be an integer multiple of the number of cyclical 
files. Statistical results for the aggregated output assume that the conditions 
represented by the cyclical files are equally likely.  

 
The value in the Seed for Random Generation text box is the random number seed used by LHS 
to create distribution samples of the variables the user has chosen to be represented by 
probability distributions. Changing this number changes the sampled values of the uncertain 
parameters used in the simulations. Powers of two should be avoided. The value of the seed must 
be between 1 and 2,147,483,647. 
 
The section labeled Disposition of MACCS2 Input and Output Files gives the user the option of 
deleting various files that do not need to be referenced.  These are useful options if there are 
many simulations.  The files deleted are removed after MACCS2 has executed a single sample 
with the exception of the MACCS2 binary results files.  The template files are always retained in 
the project Input directory. 
  
If the Delete Atmos, Early, Chronc and COMIDA2 Input Files is checked, then the input files, 
Atmosn.inp, Earlyn.inp, Chroncn.inp, Comidan.inp, Comidan.par, Comidan.var and LHS.inp are 
deleted after the data have been read, where n is the simulation number.  The template files (e.g., 
Atmostemplate.txt) are not deleted.  These files are located in the project /Input directory. 
 
If the Delete MACCS2 and COMIDA2 Text Output Files is checked, the MACCS2 output files 
Modeln.out  and the COMIDA2 output files, Comidan.cnc, Comidan.dmp and Comidan.lst, are 
deleted.  These files are located in the project /Ouput directory. 
 
If the Delete MACCS2 and COMIDA2 Binary Result Files is checked, then the MACCS2 binary 
files are deleted after the requested summary reports are created.  If no summary reports are 
requested, the MACCS2 binary results files are removed after MACCS2 has executed each 
sample. 
 
If summary reports are requested by selecting reporting options in the output request windows 
(type0, type1, etc requests on forms such as Heath Effects Cases in the Output Control category 
shown in the Properties tab of WinMACCS), the binary information is imported into the 
database after all MACCS2 runs have been completed.  The requested reports are created, and 
then all of the MACCS2 binary files are deleted.  As a side-effect of this operation, data for plots 
and additional reports are available through the database, even after the binary files are removed. 
 
If the user turns the Execute/Auto Create Summary Report toggle off (by default it is on each 
time WinMACCS opens) and has requested that the binary files are to be deleted on the 
Advanced Execution Parameter form, no reports and no plots are available after MACCS2 has 
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executed.  WinMACCS is able to create user requested reports (type0, type1, etc requests). The 
user’s request to delete the binary data takes precedence over the request for the creation of the 
reports when the Execute/Auto Create Summary Report toggle is off.  
 
Click OK to save the changes.  Click Cancel or close the window and discard the changes. 
 

4.10.3 Template files 
Template files are created by WinMACCS to facilitate the task of creating input files. These are 
named atmosTemplate.txt, earlyTemplate.txt, chroncTemplate.txt and comidaTemplate.txt. The 
positions where the values of uncertain variables are inserted are tagged within these files. The 
tags can be used to identify the uncertain variables. For example, notice the special characters 
around the number 309 in the following input line taken from a sample atmosTemplate.txt file. 
 

WDCWASH1001 §309§  
 
This line indicates that CWASH1 is uncertain. A sampled value from LHS is inserted into the 
space §309§ when the input file is created from the template file. The number 309 is an internal 
key used by WinMACCS to identify which variable to insert. 
 
The Atmos1.inp, Early1.inp, Chronc1.inp and the three Comida2 input files are recreated from 
the template files when the user clicks the Run Simulation button.   
 
If the user desires to manually modify one or more input parameters within the MACCS2 
template files, the user must first uncheck the main menu option Execute→Refresh Template 
Input Files before Running. Otherwise, the modified file is overwritten before MACCS2 
executes and the modification is lost. 
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4.11 Creating Summary Reports 
Summary reports are based on output requests made on the forms in the ATMOS/Output Control, 
EARLY/Output Control and CHRONC/Output Control categories, probabilities entered on the 
GENERAL/Reporting Options form and the binned CCDF data written to MACCS2 binary file. 
 
If the requests are made on the Output Control forms, found on the Parameters tab of the Project 
window, then after the MACCS2 simulation has completed, the binary output files are imported 
into the database and the summary report, Summary.out, is automatically created.   
 
Report requests can also be made after the simulations are completed by selecting 
PostProcessing→Create Custom Report to open the Create Custom Report form. Reports based 
on any of the output requested (even the value of NONE was associated with the Report Options 
variables) are available.  Additionally, probability input to the custom report module can be 
modified both before and after MACCS2 has run using the General/Reporting Options form.  
These probabilities may be applied to the automatic reports (immediately after the MACCS2 
simulation) and the custom reports. 
 

4.11.1 Creating Automatic Reports 
After MACCS2 simulations have been completed, automatic reports are created if both of the 
following conditions are true: 

• Either REPORT or CCDF & REPORT has been requested in at least one of the 
WinMACCS output request form 

• Execute→Auto Create Summary Report toggle is checked. 
 

 
Figure 76 Automatic Report Request 

To request an automatic report: 
1. Open an output request form.  This is a form that is in on the of the Output Control 

categories that show a linked variable with the name NUMn, where n is an integer or a 
letter.  In the example shown in Figure 76 Automatic Report Request, the variable 
NUM3 indicates that the form corresponds to MACCS2 Type 3 output requests.  
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2. In the Report Options column, choose either REPORT or CCDF & REPORT. Both of 
these selections cause WinMACCS to create an automatic report after execution.  If the 
CCDF & REPORT is chosen, then the additional binned data for each cohort is printed 
in each of the MACCS2 output files associated with the simulation. 

3. Repeat this process for all output requests for which an automatic report is desired.  
Save all of the form changes. 

4. Open the form General/Reporting Options from the Parameters tab. 
5. Review the probabilities requested.  By default, only the mean values of the requested 

output are reported.  Additional information with respect to various interpolated points 
on the CCDF plot can be requested on this form.   

6. Run the MACCS2 simulation. 
7. After the simulation is completed, the binary result files, Modeln.bin, is imported into 

the database.  The report, summary.out, is automatically created based on the user input, 
and place in the project output directory.  Double click on Output/Summary.out found 
on the Files tab of the Project window to open the report. 

 

4.11.2 Creating Custom Reports 

 
Figure 77 Create a Custom Report 

 
To request a custom report: 

1. Select PostProcessing→Create Custom Report to open the Create Custom Report form 
after the MACCS2 simulation has been completed.  If the form is not populated, you 
have to run the simulation before creating the report. 

2. Each output request is listed on the Create Custom Report form. Check or uncheck data 
that you wish to include or now exclude in column three. 

o The row number on the WinMACCS form is shown in the first column. 
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o The second column matches with the form name shown in the interface. 
o If an entry on the third column is checked, then the report contains data 

associated with that output request 
o The last column contains a copy of the MACCS2 image requesting the output.  

This matches data written to the binary file, and enables WinMACCS to locate 
the data on the binary file.   

3. If desired, probabilities for the report may be modified by opening the form 
General/Reporting Options from the Parameters tab and saving the changes by clicking 
the OK button on the Reporting Options form.  This can be done any time before 
creating the report. 

4. Click the Create Report button to create the report and keep the window open, or click 
the OK button to create the report, save the changes made to this form, and keep the 
window open, or click Cancel to close the form and not save the changes. 

5. Double click on Output/Summary.out found on the Files tab of the Project window to 
open the report. 

 

4.11.3 Interpretation of Custom Reports 
The report consists of the grand mean and an estimate for the probability of exceedence for the 
probabilities requested on the General/Reporting Options form based on the binned cumulative 
probability distributions calculated by MACCS2.  The method of calculating these numbers from 
the CCDFs reported in described in the section Method Used to Estimate Probabilities.   
 
If all of the values in the CCDF are identical, e.g., there is no variance in the parameter value, it 
is not possible to calculate a meaningful value for the probability of exceedence.  In this case, the 
report contains the text “Unable to transform CCDF No differences in probability values in 
CCDF”. 
 
In the following example, the report request was made under the form Early/Output 
Control/Health-Effect Cases.  A section of the report relevant to this follows: 
 

************************************************************************ 
Request 1  Health-Effect Cases 
MACCS2 Image:TYPE1OUT007 'ERL INJ/SKIN ERYTHEMA' 1 26 CCDF 
************************************************************************ 
 
Evacuation Evac #  1 ERL INJ/SKIN ERYTHEMA [0.E+00,1609.34](km)  
                                            Probability of Exceedence 
                                               "Grand Mean"   0.5                 0.75               0.9                  0.95            
"Health-Effect Cases (none)"  2.417E+03      5.00E+02       2.00E+02       6.119E+01      2.766E-02       
 
Evacuation Evac #  2 ERL INJ/SKIN ERYTHEMA [0.E+00,1609.34](km)  
                                            Probability of Exceedence 
                                               "Grand Mean"   0.5                 0.75               0.9                  0.95            
"Health-Effect Cases (none)"  2.095E-01      5.857E-02      2.87E-02       1.871E-02      1.622E-02       
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Evacuation Overall ERL INJ/SKIN ERYTHEMA [0.E+00,1609.34](km)  
                                            Probability of Exceedence 
                                               "Grand Mean"   0.5                 0.75               0.9                  0.95            
"Health-Effect Cases (none)"  2.296E+03      5.00E+02       1.414E+02      6.119E+01     6.544E-02 

 
Notice that the two evacuations plus the combined results are reported.  All LHS trials have been 
combined. Interpreting the first line of results for evacuation scenario one, we can say that we are 
90 percent certain that the number of skin erythema injury cases exceeds 61.19.  The mean 
number of injuries over all LHS realizations is approximately 242 cases. 
 

4.11.4 Method Used to Estimate Probabilities 
Given a set of binned CCDF values read from the MACCS2 binary file, the first step is to map 
these values into a set of equally spaced probabilities.  Probabilities are estimated over the range 
0 to 1 in increments of .01. 
 
 The algorithm to do this is as follows:   

• Take the natural log of x, the upper bound of the bin.   
• Search for the first two probabilities that are different.  In the example below, this 

corresponds to ln(x) = -20.0301 and –19.6247. 
 

 
X Prob >= X ln (x) 

1.00E-09 7.47E-02 -20.7233 
2.00E-09 7.47E-02 -20.0301 
3.00E-09 7.42E-02 -19.6247 
5.00E-09 6.62E-02 -19.1138 
7.00E-09 6.53E-02 -18.7774 
1.00E-08 6.43E-02 -18.4207 
2.00E-08 6.28E-02 -17.7275 
3.00E-08 6.17E-02 -17.3221 
5.00E-08 5.59E-02 -16.8112 
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• Calculate a new value of ln(x) for probabilities from .08 to 1.0 (first number 
greater than .0747 that is a multiple of .01) using the line defined by the points 
(7.42E-02, -19.6247) and (7.47E-02, -20.0301) 

• For each value up to the last value, use linear interpolation to calculate the new 
value for ln(x).  For values beyond the smallest probability value, in this case 0, 
.01, .02, .03, .04 and .05, use the line defined by the last two significant points, 
(6.17E-02, -17.3221) and (5.59E-02, -16.8112).   

• In some cases, there are repeated values for the probability.  When interpolating, 
looking from the first point on down, find the first data point that is less than the 
point of interest (say point idx).  Use this point and the previous point for the 
interpolation.  In the above example to interpolate to probability = .06, the first 
probability less than .06 is .0559.  The points (6.17E-2,-17.3221) and (5.59E-2,-
16.8112) are used to interpolate. 

• In the case where the first point less than the point of interest corresponds to idx = 
1, interpolate between idx = 1 and idx = 2.   These are guaranteed to correspond to 
different probabilities. 

• In some cases, the last two points have the same value of probability.  In this case, 
look up the table (from the bottom up) for the first point with a different 
probability.  Use this for the extrapolation.   

• Take the antilog to complete the table.  Result is a table of equally likely values of 
x. 

 
Because of the logarithmic interpolation, the method requires only positive values for x.  The 
algorithm fails to calculate quantiles if there are any zero or negative values of x. 
 
To combine the CCDFs across various LHS runs, sort the arrays of all possible values of x in 
ascending order (using above increments of .01, this results is 101*N values where N is the 
number of LHS realizations).   
 
To calculate the probability of exceedence, consider an array of sorted linearized CCDF values.  
For example, consider the following table of nine values: 
 
Value Probability of 

exceedance 
f Q(f) 

5 1 1 5 
8 7/8 .875 8 
9 6/8 .75 9 
9 5/8 .625 9 
10 4/8 .5 10 
12 3/8 .375 12 
14 2/8 .25 14 
30 1/8 .125 30 
35 0 0 35 
 
The first value, 5, is viewed as a lower bound and not a data point.  Assigned CCDF column is 
the percentage of values that exceed or equal the given data point.   
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The function Q(f) where 0 <= f <= 1, is the distribution value such that the fraction, f, of all 
values exceeds or equals Q(f).   
 
For other values, linear interpolation is done.  In the above example, Q(.7) = 9.  Q(.1) is between 
30 and 35, and is linearly interpolated as 31.  
 
The value, Q(f), is precisely the value reported by WinMACCS, where f is the probability 
entered in form General/Reporting Options. 
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4.12 Viewing Graphical Results 
Graphical output can be displayed after completing a MACCS2 run by selecting an entry from 
the main menu Post Processing→Graphical Results. The following results are available: 

• Scalar results are displayed by selecting PostProcessing→Graphical 
Results→Scalar Results from the main menu. 

• Statistical summary results are displayed by selecting PostProcessing→Graphical 
Results→Statistical Summary Results from the main menu. 

• Probability distribution results representing weather uncertainty are displayed by 
selecting Post Processing→Graphical Results→Results over all Weather Trials 
from the main menu. 

 
When a plot request is made after a simulation (i.e., one of the menu entries such as 
PostProcessing→Graphics→ Results over all Weather Trials) is selected, the MACCS2 binary 
result files (e.g., Model1.bin) are imported into the project database if they were not already 
imported to support automatic or custom reports. This progress can be observed in the Results 
window as shown below. 
 

 
Figure 4-78  Results Window after Processing Binary Files 

 
After the binary result files have been processed into the project database, the result information 
is available for quick access without repeating the import process. 

4.12.1 Scalar Results 
Graphical results can be displayed after completing a MACCS2 run by selecting an entry from 
the main menu item PostProcessing→Graphical Results→Scalar Results. 
 
These results are associated with a single number as opposed to a probability distribution (e.g., 
the fractional release of Co-60 in plume number one). These results are displayed as cumulative 
distribution functions, or CCDFs. If the results are identical across LHS runs, they are displayed 
on the X-axis because the probability of exceedance is zero. The following is sample output from 
a result file, Model1.txt, which corresponds to scalar results for two plumes. 
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Figure 4-79  MACCS2 Plume Inventory 

 

4.12.2 Results  Displayed as a Complimentary Cumulative Distribution Function (CCDF)  
Graphical results can be displayed after completing a MACCS2 run by selecting an entry from 
the main menu PostProcessing→Graphical Results→Results over all Weather Trials from the 
main menu. 
 
Most MACCS2 results from a single execution are probability distributions representing 
uncertainty of the weather during a hypothetical accident. This window displays the CCDF 
distributions for each MACCS2 calculation. For example, if five MACCS2 simulations were run 
using LHS, there would be five CCDF curves for each result. The following is sample output 
from a result file that could be displayed as a single curve in this plot window. 

 
Figure 4-80  MACCS2 CCDF Results 

 
The data correspond to the MACCS2 results reported when the CCDF flag is set on an output 
request line. 
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Even if not requested by the user, all CCDF results are written to the binary results files (e.g., 
Model1.bin). In the example shown in Figure 4-81, even though CCDF results for plume one at 
grid element nine are not reported in the Model1.txt results files, they are saved in the binary-
result files.  
 

 
Figure 4-81  Requesting CCDF Results in WinMACCS 

 

4.12.3 Statistical Summary Results 
Graphical results can be displayed after completing a MACCS2 run by selecting an entry from 
the main menu PostProcessing→Graphical Results→Statistical Summary Results from the main 
menu. 
 
Most MACCS2 results from a single simulation are probability distributions representing 
uncertain weather.  For example, in Figure 4-82 the MACCS2 results for Center Air 
Concentration for Cs-137 for plume number one at 4.8 to 5.6 km is a probability distribution. 
MACCS2 reports statistics such as Prob Non-Zero, Mean, etc., calculated from this distribution. 
These statistics are listed as column headings below. 
 
 

 
Figure 4-82  MACCS2 Statistical Summary Results 

 
The Statistical Summary Results form allows the user to display a CCDF for each of the entries 
in Figure 4-82 (e.g., the mean value of Center Air Concentration for Cs-137 for plume number 
one at 4.8 to 5.6 km). In other words, a plot created with this option displays a probability 
distribution (CCDF) of one of the statistics above over the set of LHS samples.   
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4.12.4 Navigation of the Plot window 
Multiple plot windows can be opened.  Notice that the caption of the plot window contains the 
MACCS2 version used in the simulation.  The date and time correspond to a date/time stamp 
written on the binary output files (e.g., model1.bin).   
 
 

 
Figure 4-83  Plot Window Caption 

 
To add a plot to the graph: 

1. Select the variable you want to plot from the Select Variable list. 
2. Additionally, if a Statistical Summary Results form is being used, click on the desired 

statistic in the Statistic list. 
3. Click on the Add button to add it to the existing graph. 

 

 
Figure 4-84  Add a Plot to a Graph 

 
If the Mean is added, notice that the grand mean (average of all means over all simulations) is 
calculated and displayed on the graph as a vertical line. 
 
To select a plot on the graph do one of the following: 

• Click the Select button. 
• Select Select Next Series from the PostProcessing→Graphical Results→Edit 

Plots  menu. 
• Click on the plot. 

 
When a plot is selected: 
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• The individual points are marked.   
• The details indicating the plot selected are shown in blue at the bottom of the 

window.   
• The Select Variable list and the Statistic list, if applicable, indicate the selected 

plot.   
• If a legend is applicable to the plot, the current selected plot is shown in the 

legend.   
• If the bulls-eye toggle is pushed in, the data values are displayed on the plot. 

 
Plots are selected in the order they were added. Only one plot can be selected at a time. 
If the last plot added is the selected plot and the Select button is clicked, then no plots are 
selected. This feature allows the user to cycle through all the plots, unselect all plots, and then 
start selection again with successive mouse clicks on the Select button. 
 
In Figure 4-85, the Ground-Level Air Concentration for Plume 1, Cs-137 at a spatial distance of 
4.83 to 5.63 km for the mean statistic is selected. Notice that this information is displayed in blue 
at the bottom of the window. Also notice that the Grand Mean is displayed on the plot as a 
vertical line. If the Select button is clicked when the Mean is selected, the Grand Mean would be 
selected. If it was clicked again, then no plots would be selected. 
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Figure 4-85  Plot Window 
 
To place the graph in a state such that no plots are selected do one of the following: 

• Click the Select button successively, cycling through each plot on the graph.  
When the last added plot is selected, clicking the Select button again puts the 
graph in a state such that no plots are selected.    

• Select Unselect from the PostProcessing→Graphical Results→Edit Plots menu. 
 
To delete a plot from a graph: 

1. Select the plot to be deleted by clicking the Select button until the desired plot is 
selected. 

2. Click the Delete button, or select Delete Selected Series from the 
PostProcessing→Graphical Results→Edit Plots menu. 

 
To modify the axis labels or title of a graph: 

1. Select Modify Titles from the PostProcessing→Graphical Results→Edit Plots menu. 
This causes the Modify Titles form to open, allowing the user to modify the plot and 
axis titles. Notice that by default the main plot title and the X axis title corresponds to 
the first plot placed on the graph. 

2. Modify the plot title and axis labels.   
3. Click on OK to save settings. 

 

 
Figure 4-86  Modify Plot Titles 

 
To zoom in the graphics window: 

• Hold the left mouse button down in the top right corner of the desired area. Drag a 
rectangle by moving the mouse down and to the right. Release the mouse. 

 
To unzoom, or restore the graphics window to its original scale: 
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• Hold the left mouse button down anywhere in the plot. Drag a rectangle by 
moving up and to the left. Release the mouse. 

Note: Using the zoom or unzoom feature causes a selected series to be unselected and the bulls-
eye toggle to be pushed out (i.e., shown in an off position).  

 
To display plotted values: 

• Click the bulls-eye toggle button. If this toggle is pushed in, as shown in Figure 
4-87, the associated data points in the selected series are shown on the graphs as 
(x, y) coordinate pairs. To view some of the values, it may be necessary to use the 
zoom feature. 

 

 
Figure 4-87  Data Values as Text Displayed in a Plot Window 

 
To modify the plot axis: 

• Click the Modify Axis button to open the Modify Axis Bounds form as shown in 
Figure 4-88. This allows the user to change the axis limits or switch to a log scale. 

 
To rescale the X or Y axis: 

1. Click the X or Y toggle buttons respectively. By default, the X axis is selected. 
2. Select the scale of the toggled axis by clicking either the Linear or Log radio buttons.   
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3. Bounds can be set to Automatic or Manual.  

a. To have the axis limits calculated by WinMACCS, select the radio button labeled 
Automatic. 

b. To manually enter axis limits, select the radio button labeled Manual.  Enter the axis 
limits in the text boxes labeled Minimum and Maximum.  

4. To save and apply these changes click OK.  To ignore the changes click Cancel or close 
the window. 

 

 
Figure 4-88  Modify Axis Bounds 

 
To export the data, select Export Plot from the PostProcessing→Graphical Results→Edit Plots 
menu. The following file types are supported: 
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• Windows bit map (.bmp): A graphical format that integrates into other Microsoft 
documents such as Microsoft Word, Excel, or WordPad. Files can be edited in 
Microsoft Paint. 

• Jpeg (.jpg): Viewable as a graphic in a web browser or photo editing software. 
Requires less memory than a .bmp file. 

• Text files (.txt): ASCII text that is viewable in a text editor such as Notepad, 
WordPad, or Microsoft Word. 

• XML and HTML: Viewable in a web browser such as Internet Explorer, Netscape 
or can be edited in Microsoft Word. 

• Excel file (.xls): A document that can be opened with Microsoft Excel. Allows the 
user to do further data analysis in the graphical and functionally rich environment 
of Excel. 

The result export file is saved in the Project Output directory unless the path is modified 
in the Save As form. Saved files are shown in the Files tab of the Project window as 
shown in Figure 4-89. Double-clicking on the exported file in the Project window causes 
the associated application to open that file for viewing.   
 
Select File→Refresh File View from the main window to update the file names shown in 
the Files tab of the Project window. 
 

 
Figure 4-89  Exporting Graphics 
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Appendix A: New MACCS2 Model Input Cards 
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INTRODUCTION 
The following sections present modifications to the Code Manual for MACCS2 (NUREG/CR-
6613, Vol. 1). Since the publication of that document, new MACCS2 models have been 
implemented and some variable bounds have been modified. Some entries that follow are 
corrections to the manual that fix typographical errors or improve clarity. A comprehensive 
review of the Code Manual for MACCS2 is expected in the future. 

 
_____________________________ 
 

Page 4-1 Add a paragraph after heading “Running MACCS2”describing new command 
line parameters. 
A MACCS2 run can be generated by using the older batch file method described in the 
MACCS2 1.12 documentation below, or by using command line parameters. The following 
parameters can be specified on the MACCS2.exe command line in any order. 

-a ATMOS input file and path 

-e EARLY input file and path 

-c CHRONC input file and path 

-m meteorological file and path 

-s site file and path 

-o output file and path.  The prefix portion of the output file is used to name the binary 
output file.  For example, if output file is named model.out, then binary file created by 
MACCS2 is named model.bin.  

-i file containing names of MACCS2 input files.  This is the path and name of a file 
containing the ATMOS, EARLY, CHRONC, meteorological, site and output files.  If any 
of these files have been specified on the command line using the –a, -e, -c, -m, -s or –o 
parameter, this file is not used.  If this –i option is not specified and the files have not 
been specified on the command line, the file names are expected to be in a file named 
Maccs2.tmp located in the Maccs2.exe directory.  The file names in the –i file must be in 
order of ATMOS, EARLY, CHRONC, meteorological, site, and output, one file name 
and path per line.  If the file is not relevant to the model, the line should contain a dummy 
file name or two double quotes to indicate no file specified. 

The following example lists the contents of a Maccs2.tmp file.  Only the ATMOS model 
is executed.  The EARLY and CHRONC files are not specified.  A meterological file, 
Metsur.inp, has been specified.  MACCS2 creates the results files Model1.out and 
Model1.bin.  
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C:\WinMACCSSamp\inb\Input\Atmos1.inp 

"" 

"" 

C:\WinMACCSSamp\inb\Data\Metsur.inp 

"" 

C:\WinMACCSSamp\inb\Output\Model1.out 

 

-p is a prefix used in naming the status files. If this isn’t specified, the status files are 
named MaxStat.log and FortErr.log.  If it is specified, then the name of the two status 
files are prefixed with this parameter.  For example, “maccs2.exe -p MyRun”  would 
result in status files MyRunMaxStat.log and MyRunFortErr.log.  These files are placed in 
the same directory as the output file directory specified in the –o parameter.  If the –i 
parameter was used to specify the file names (instead of the –a, -e, -c, -m, -s and –o 
parameters), then the status files are placed in the same directory as the file specified after 
the –i flag.  If neither of these conditions are met, then the status files are placed in the 
same directory as the Maccs2 executable file, MACCS2.exe.  

The status file, MaxStat.log, contains a single line with the string ‘OK’ when the 
MACCS2 execution is successful.  If the execution is not successful, the file contains a 
line with the string ‘NO’.  If MACCS2 detected the error and exited, the line containing 
the string ‘NO’ is followed by a MACCS2 generated error message. 

The FORTRAN error file, FortErr.log, is created only if MACCS2 aborts abnormally.  It 
contains trace back information and system level error messages.  If this file exists when 
MACCS2 crashes, the error messages are appended to the end of the file, retaining 
previously generated error messages. 

The –p parameter is independent of the input file specification, and is always optional. 

If at least one of the command line parameters, -a, -e, -c, -m, -s, or –o, is present then the 
MACCS2.tmp file is not used to define the name and path of the required files.  In this 
case all of the files used by MACCS2 must be specified on the command line.  

Example usage where all files are specified from the command line: 

C:\Program Files\WinMACCS> maccs2.exe -a C:\inb\Input\Atmos1.inp -m 
C:\inb\Data\Metsur.inp -o C:\ inb\Output\Model1.out 

Example usage where there is a file containing names of MACCS2 input files:   

C:\ Program Files\WinMACCS> maccs2.exe -i C:\inb\Maccs.tmp –p inb 

In this example, MACCS2.tmp is renamed Maccs.tmp and the status files, MaxStat.log 
and FortErr.log, are renamed inbMaxStat.log and inbFortErr.log.  These files are placed 
in the directory C:\inb\. 
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Page 4-1 Add a paragraph 
 
Maccs2 version 1.12 stores intermediate values in temporary files.  With the increase in size of 
memory in today’s computers, it has become more efficient to use dynamic memory to store 
these intermediate results.  By default, the current version of MACCS2 uses dynamic memory 
for the storage of these intermediate results, but the user has the option of reverting back to using 
temporary files to store these values.  This is done by creating a file called maccs2.ini and 
placing the file in the same directory as the MACCS2 executable.  If using WinMACCS, this 
directory is usually the following: 
 
C:\ Program Files\WinMACCS 
 
The user simply needs to add the line below to the file maccs2.ini and the MACCS2 program 
uses temporary files rather than trying to use dynamic memory. 
 
FileTempMem = .TRUE. 
 
_____________________________ 
 

Page 5-3 Add a variable to Geometry (GE) Data section. 
Variable Name: NUMCOR 
Variable Type: Integer, Vector 
Allowed Values: 16, 32, 48, or 64  
Purpose:  Number of sectors in spatial grid, i.e., angular compass directions.   

 
Example Usage: 
*  Number of angular compass directions 
GENUMCOR001 16 
 
_____________________________ 
 

Page 5-4 Add a sentence at the end of the purpose section of SPAEND.  
Variable Name: SPAEND 

The user must supply NUMRAD values in this data block. 
 
_____________________________ 
 

Page 5-5 Update the range of MAXGRP. 
Variable Name: MAXGRP 
Allowed Range: 1 ≤ value ≤ 20 
 
_____________________________ 
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Page 5-13 Correct a typographical error in the purpose section of variable DISTANCE.   
Replace NUN_DIST with NUM_DIST. 
Variable Name: DISTANCE 
Purpose: …  The user must supply NUM_DIST values of DISTANCE. 
 
_____________________________ 
 

Page 5-18 Add a new section. 
 
_____________________________ 
 

5.7.4 Long-range, Lateral, Plume Spread Criteria 
Hanna (2002) recommends that plume dispersion beyond 30 km be based on time, not on 
distance. This model allows the user to implement Hanna’s recommendation. The basis for the 
recommended distance, 30 km, is that most measurements upon which dispersion tables are 
based have a limit of about 30 km. The time-based dispersion model is closer to those used in 
several Gaussian puff codes. In the MACCS2 implementation, the user must select the 
downwind distance at which the code switches from distance-based dispersion, described in 
Subsections 5.7.1 and 5.7.2, to time-based dispersion. The user must also select a linear 
coefficient for the time-based dispersion model. Hanna recommends a value of 0.5 m/s. The 
virtual source concept is used to ensure that there is no discontinuity in switching from distance-
based to time-based dispersion. The following equation describes the new model:  
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where  

yσ  = Value of crosswind dispersion (m) 

a = Linear coefficient for crosswind dispersion (m) 

x = Downwind distance (m) 

x0 = Downwind distance scale, 1. m 

b = Exponential parameter for crosswind dispersion (dimensionless) 

xc =  Distance at which dispersion model switches from distance- to time-based 

ac = Linear coefficient for time-based, crosswind dispersion (m/s) 

t = Time since the plume was released from the virtual source (s) 
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When DISTMD is set to LRTIME, time-based dispersion is implemented at distances greater or 
equal to the value of CYDIST. However, distance-based dispersion is always applied within the 
first ring, regardless of the value of CYDIST. Either the power-law function (Subsection 5.7.1) 
or lookup tables (Subsection 5.7.2) can be used to define the dependence of dispersion on 
downwind distance at distances less than CYDIST. 

The following are ATMOS input cards to define the parameters for this model: 

Variable Name: DISPMD 
Variable Type: Character, Scalar 
Allowed Value: LRTIME or LRDIST 
Purpose: Crosswind dispersion model flag.  Value set to ‘LRTIME’ for long-range, 

time-based model; value set to ‘LRDIST’ for long-range, distance-based 
model.  

 
Variable Name: CYDIST 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 1.E+7 m 
Purpose: Distance for switching from distance-based to time-based, crosswind, 

dispersion model. 
 
Variable Name: CYCOEF 
Variable Type: Real, Vector 
Allowed Range: 0.0 < value ≤ 2. m/s 
Purpose: Linear coefficient for time-based, crosswind, dispersion model. 
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Example Usage: 

* New Model Dispersion parameters 
DPDISPMD001 LRTIME 
DPCYDIST001 30000.0 
DPCYCOEF001 0.5 
 
_____________________________ 
 

Page 5-19 Add a new section. 
 
_____________________________ 
 

5.8.1 New Plume Meander Model based on Regulatory Guide 1.145 
A new plume meander model has been added to MACCS2 based on Regulatory Guide 1.145 and 
supporting document NUREG/CR-2260. While this regulatory guide is used primarily for 
licensing activities, it has been deemed to be an appropriate alternative in MACCS2. The NRC 
considers this to be a better representation of plume meander than the original MACCS2 plume 
meander model.  

The Regulatory Guide 1.145 plume meander model differs from the existing model in MACCS2 
in that it accounts for the effects of wind speed and stability class. On the other hand, the existing 
plume meander model in MACCS2 accounts for the duration of the release (related to the length 
of the plume); the new model is calibrated for 1-hour release durations. The plume meander 
model described below would over predict doses for release durations longer than 1 hour; it 
should not be used for release durations that are significantly shorter than 1 hour since it would 
under predict doses.  

The new plume meander model treats plume meander in a similar manner as an area source. The 
meander occurs in the first 800 m downwind, creating a broader plume at that distance. Beyond 
800 m, the plume gradually approaches the size that it would have had if meander had not 
occurred, which is similar to the effect of an area source.  

 

Model Description 

The plume meander model described in Regulatory Guide 1.145 is defined as follows: 

 

σym(x) = fm · σy(x)          (1) 

where 

σy  = lateral plume size not accounting for plume meander (m) 
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fm  = meander factor (dimensionless) 

σym  = lateral plume size accounting for plume meander (m) 

x  = downwind distance measured from the source (m) 

Lateral plume size, σy, can be defined in terms of a power-law equation or as a look-up table. 
The meander factor is defined as follows: 

 

fm = m·f(u)            (2) 

where 

m     =  1 for stability classes A through C 

2 for stability class D 

3 for stability class E 

4 for stability class F 

f(u) = a function of wind speed and is defined in Equation (3) below 

u     = wind speed (m/s) 

 

f(u) = 1      u ≤ 2    

f(u) =  1  – ( u – 2 ) / 4 · (m  –  1)/m    when  2< u < 6     (3) 

f(u) =  1  / m      u ≥ 6 

 

The above equations are valid for distances within 800 m of the source. Beyond 800 m 
downwind, Equation (1) is modified as follows: 

σym(x) = (fm – 1 ) · σym( 800 ) + σy(x)       (4) 

 

The MACCS2 model is similar to the model described above. The differences is that the model 
is integrated with the MACCS2 treatment of a virtual source and generalized in terms of the 
model parameters. The basic equation for x < X is similar to Equation (1) but uses a virtual 
source location to correct for the size of the area source.  

 

σymv(x)  =  fm · σy(x + xyv)         (5) 

fm  =  MNDFAC(i) * f(u) 
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The variables are defined as follows: 

xyv = the location of the virtual source (m) 

MNDFAC(i) = the value of m for stability class i 

WINSP1 and WINSP2 = the wind speed values used in the following way to determine the value 
of f(u) (m/s) 

f(u) = 1       if  u ≤ WINSP1 

f(u) = 1- (u - WINSP1)/(WINSP2 - WINSP1)*(m – 1)/m if  WINSP1< u < WINSP2 

f(u) = 1/m        if  u ≥ WINSP2 

 

MNDIST is used as follows: 

σymv(x) = fm · σy(x + xyv)      x ≤ MNDIST 

σymv(x) = σy(x + xyv)        x > MNDIST 

where 

MNDIST = the transition distance where the effect of plume meander begins to diminish (m) 

Note that the value of xyv is different in the two equations above. In the first equation, xyv is 
calculated to account for the area source for the intial release, usually representing the 
dimensions of a containment, auxiliary, or other building from which the source emits. The value 
of xyv in the second equation is chosen to make σymv continuous at MNDIST. 

 

The following are ATMOS input cards for this model: 

Variable Name: MNDMOD 
Variable Type: Character, Scalar 
Allowed Value: OLD, NEW, and OFF 
Purpose: Plume Meander model flag.  If the value is set to ‘OLD’ original 

MACCS2 1.12 model is used; if the value is set to ‘NEW’ the model 
based on NRC Regulatory Guide 1.145 is used; if the value is set to ‘OFF’ 
the plume meander factor is set to unity, i.e., no plume meander is treated. 

 
Variable Name: MNDFAC 
Variable Type: Real, Vector 
Allowed Range: 1.0 ≤ value ≤ 10 
Purpose: Meander factor m based on Stability Class.  The user must supply six 

values, one for each stability class. 
 
Variable Name: WINSP1 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 20. m/s 
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Purpose: Wind speed coefficient number one 
 
Variable Name: WINSP2 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 20. m/s 
Purpose: Wind speed coefficient number two 
 
Variable Name: MNDIST 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 10000. m 
Purpose: Downwind distance where the effect of meander begins to diminish. 

MNDIST is a breakpoint in the formula for calculating Sigma y. 
 
Example Usage: 

* New Plume Meander Model parameters 
PMMNDMOD001 NEW 
* 
PMMNDFAC001 1. 
PMMNDFAC002 1. 
PMMNDFAC003 1. 
PMMNDFAC004 2. 
PMMNDFAC005 3. 
PMMNDFAC006 4. 
* 
PMWINSP1001 2.0 
* 
PMWINSP2001 6.0 
* 
PMMNDIST001 800. 
 
_____________________________ 

Page 5-21 Add a new section. 
 
_____________________________ 
 

5.9.1 Mixing Height Option 
An option is available to the user to use nighttime mixing height by season. This only applies 
when a meteorological file is being used (i.e. METCOD = 1, 2 or 5). The option allows for two 
mixing height models to be used: 
 
First, the original “DAY_ONLY” model is as follows:  the meteorological file contains 2 sets of 
4 values of maximum mixing height at the end of the file.  The first set is the morning mixing 
height values for each of the four seasons.  The second set is afternoon mixing height values for 
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each of the four seasons.  All eight values are read but only the second set of values is used. The 
mixing height is only dependent on the season.  It does not change with time of day. 
 
The new “DAY_AND_NIGHT” model uses both morning and afternoon values.  If the start time 
of the weather trial is between sunset and sunrise, the morning value is used based on the season 
until the first hour after sunrise.  At the first hour after sunrise and until the hour before sunset 
the mixing height is calculated by interpolating between the morning height value and the 
afternoon height value for that season.  Once the first hour of sunset is reached, the afternoon 
mixing height value is used for the remainder of the simulation. If the start time of the weather 
trial is between the hour after sunrise and the hour of sunset, the mixing height is calculated by 
interpolating between the morning height value and the afternoon height value for that season. 
Again, once the first sunset of the simulation is reached, the mixing height remains the afternoon 
value.  The mixing height is never reduced from the previous hour’s value. It is possible for the 
mixing height to increase if the season changes and the new afternoon mixing height is greater 
than that of the previous season. 
 
Variable Name: MAXMIX 
Variable Type: Character, Scalar 
Allowed Range: DAY_ONLY, DAY_AND_NIGHT 
Purpose: Maximum Mixing Height model flag.  Value set to ‘DAY_ONLY’ uses 

the original MACCS2 model; value set to ‘DAY_AND_NIGHT’ uses the 
new model that treats the dependence of time of day on mixing height. 

 
Variable Name: LATITU 
Variable Type: Real, Vector 
Allowed Range: -360.0 ≤ value ≤ 360.0 
Purpose: Latitude of site location. 
 
Variable Name: LONGIT 
Variable Type: Real, Vector 
Allowed Range: -360.0 ≤ value ≤ 360.0 
Purpose:  Longitude of site location. 

 
 
Example Usage: 

* Maximum Mixing Height Model parameters 
M1MAXHGT001  DAY_AND_NIGHT 
*    deg      min     sec 
M1LATITU001  35.0 5.0 2.4 
M1LONGIT001  106.0 51.0 0.0 

 
_____________________________ 

Page 5-22 BUILDH and SIGYINIT are arrays, not scalars.  Add a sentence to the purpose 
paragraphs. 
Variable Name: BUILDH 
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Variable Type: Real, Array 
Purpose: …  The user must supply NUMREL values for this variable on one or 

more cards. 
 
Variable Name: SIGYINIT 
Variable Type: Real, Array 
Purpose: … The user must supply NUMREL values for this variable on one or 

more cards. 
 
_____________________________ 
 

Page 5-23 SIGZINIT is an array, not a scalar.  Add a sentence to the purpose paragraph. 
Variable Name: SIGZINIT 
Variable Type: Real, Array 
Purpose:  … The user must supply NUMREL values for this variable on one or 

more cards. 
 
_____________________________ 
 

Page 5-24 Update the range of NUMREL. 
Variable Name: NUMREL 
Allowed Range: 1 ≤ value ≤ 200 
 
_____________________________ 
 

Page 5-26 Add additional data requirement at the end of the purpose paragraph for 
PDELAY. 
Variable Name: PDELAY 
Purpose: … Numbers must be in ascending order. 

_____________________________ 
 

Page 5-27 Add a sentence to the purpose paragraph for CORINV. 
Variable Name: CORINV 
Purpose: … The user must supply NUMISO values for this variable in column two. 
 
_____________________________ 
 

Page 5-28  Update the range of  CORINV. 
Variable Name: CORINV 
Allowed Range: 2.7E-10 ≤ value ≤ 1.0E25 
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_____________________________ 
 

Page 5-29 Add sections to Release Description Data. 
 
_____________________________ 
 

5.11.1 Plume Rise Density and Flow Model 
Two options are available to determine plume buoyancy. The original MACCS2 model uses the 
rate of release of sensible heat content in a plume. In some cases, it is easier for the user to 
estimate the rate of mass release and the density of a plume segment. The new option allows 
these values to be specified in place of the rate of release of sensible heat.  

The following are ATMOS input cards for this model: 

Variable Name: PLM_HEAT 
Variable Type: Character, Scalar 
Allowed Value: HEAT or DENSITY 
Purpose: If this variable is set to HEAT, variable PLHEAT is used to calculate the 

plume buoyancy.  If it is set to DENSITY, the variables PLMDEN and 
PLMFLA (density and flow rate) are used to calculate the plume 
buoyancy. 

If this card is not present, the value of PLM_HEAT is assumed to be HEAT.  This is to support 
backward compatibility with MACCS2 1.12 input files.  

Example usage: 

* PLM_HEAT, plume rise model based on heat content 
RDPLMMOD001 HEAT 
* 
* PLHEAT, heat content of each plume segment (watts)  
RDPLHEAT001 3.7E+6 
RDPLHEAT002 1.7E5 
 
_____________________________ 

 

If the value of PLM_HEAT is DENSITY, then the following input is required: 

Variable Name: PLMFLA 
Variable Type: Real, Vector 
Allowed Range: 0.000001 ≤ value ≤ 1.0E+32 kg/s 
Purpose: Specifies the average mass flow rate over the duration of a plume 

segment.  
 
Variable Name: PLMDEN 
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Variable Type: Real, Vector 
Allowed Range: .02 ≤ value ≤ 5.0 kg/m3 
Purpose: Specifies the plume gas density at source conditions. 

 

Example usage: 

* PLM_DEN, plume rise model based on density 
RDPLMMOD001 DENSITY 
* 
* PLMFLO, mass flow rate of each plume segment 
RDPLMFLA001 30. 
RDPLMFLA002 5. 
* 
* PLMDEN, density of each plume segment 
RDPLMDEN001 1.2 
RDPLMDEN002 0.5 
 
_____________________________ 
 

5.11.2 Improved Briggs, Plume-Rise Model 
Two optional models for plume rise are supported in MACCS2. The original MACCS2 plume-
rise model for neutrally stable and unstable conditions is based on work performed by Briggs in 
1973. Since that time, an earlier plume rise model developed by Briggs (1971, 1972) has been 
recognized as better representing plume data (Hanna, 1982). The user can choose between these 
two models. This flag only affects plume rise for unstable and neutrally stable atmospheric 
conditions (stability classes A through D); predicted plume rise under stable conditions (stability 
classes E and F) is identical for these two options. Under most conditions, the improved model 
predicts less plume rise than the original model. The original model is retained so that previous 
results can be reproduced; the new model is recommended for all new applications. 

Variable Name: BRGSMD 
Variable Type: Character, Scalar 
Allowed Value: ORIGINAL or IMPROVED 
Purpose: If BRGSMD is set to 'ORIGINAL', then the original Briggs plume rise 

model from MACCS 1.12 is used. If the value is ‘IMPROVED’, then the 
improved Briggs plume rise model is used.   

If this card is not present, the value of BRGSMD is assumed to be ‘ORIGINAL’. This is to 
support backward compatibility with MACCS2 1.12 input files.   

Example Usage: 

* Improved Briggs model 
RDBRGSMD IMPROVED 
 
_____________________________ 
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Page 5-29 Modify range of IDEBUG 
Variable Name: IDEBUG 
Allowed Range: -1 ≤ value ≤ 8 
 
_____________________________ 
 

Page 5-31 Change “This item is only required if IDEBUG is greater than 0” to “This item 
is always required” 
Variable Name: NUCOUT 
Purpose:  Specifies the radionuclide to appear on the dispersion listing if one is 

produced. The dispersion listing is produced if IDEBUG is greater than 
zero. The specified radionuclide name must appear on the previously 
defined list of radionuclides, NUCNAM, defined in Section 5.4.  This item 
is always required. 

 
_____________________________ 
 

Page 5-36 Top of page, first paragraph, upper bound of NSMPLS depends on other input 
parameters and does not have an upper limit of 10. 
The user controls how many weather sequences are chosen by assigning a value for NSMPLS. 
There are three options in which NSMPLS can be used. If it is set to zero (0) and METCOD = 2, 
nonuniform bin sampling is used. In this case, the user must also select the number of samples 
from each weather bin by defining the vector variable INWGHT.  

In the second option METCOD = 2 and NSMPLS is greater than zero (0), uniform bin sampling 
is used. In this case, NSMPLS samples are chosen from each weather bin.  

The third option, METCOD = 5, is called random stratified sampling. In this case, NSMPLS 
samples are selected for each day of the year. The limits on NSMPLS and further description of 
these options are provided below. 

 
_____________________________ 
 

Page 5-37 Variable type is Real, not integer 
Variable Name: RNRATE 
Variable Type: Real, Array 
 
_____________________________ 
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Page 5-37 NSMPLS bounds have been modified.  Description was rewritten. 
Variable Name: NSMPLS 
Variable Type: Integer, Scalar 
Allowed Range: 0 ≤ value ≤  K*8760 if METCOD = 2 
   1 ≤ value ≤ Κ∗24 if METCOD = 5 

Where K=1 if the meteorological file contains hourly data, 2 if the file 
contains data for each 30 minutes, and 4 if the file contains data for each 
15 minutes. 
 

 When METOCD = 2, it is advisable to set a value of at least 4; the more 
samples that are taken, the more robust is the sampling.  If the user 
supplies a value of 0 for NSMPLS, and METCOD=2, the variables 
NSBINS, INDXBN, and INWGHT allow the user to specify how many 
samples are to be chosen from each of the weather-category bins. 

 
 When METCOD=5, setting NSMPLS=24*K causes the code to sample 

every time period of the year, a capability that can provide insights into 
the adequacy of the operation of the weather binning algorithm.  In using 
the METCOD=5 option, it is advisable to select values for NSMPLS that 
are divisors of 24*K because then each interval is composed of a whole 
number of time periods.  

 
 
_____________________________ 

Page 5-38 Bounds have changed, and are dependant on meteorological  file 
Variable Name: INWGHT 
Variable Type: Integer, Array 
Allowed Range: 0 ≤ value ≤  K*8760 

Where K=1 if the meteorological file contains hourly data, 2 if the file 
contains data for each 30 minutes, and 4 if the file contains data for each 
15 minutes. 

 
_____________________________ 
 
 

Page 5-39 Variable ISTAB referenced.  Should be HRMXHT and IHRSTB 
Variable Name: HRMXHT 
Purpose: These are the mixing layer heights in meters that are used for a single trial. 

The user must supply 120 values of HRMXHT in column 1 of the data 
block. 

 
Variable Name: IHRSTB 
Purpose: Defines the stability classes that are used for the single trial.  The integers 

1 through 6 represent the Pasquill-Gifford stability classes A through F, 
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respectively. The user must supply 120 values of IHRSTB in column 2 of 
the data block corresponding to each of the 120 hours in the weather 
sequence. 

 
_____________________________ 
 

Page 5-40 Variable RHMM referenced.  Should be HRRAIN.   
Variable Name: HRRAIN 
Purpose: Defines the rain rate that is used for a single weather trial. Values are in 

units of millimeters per hour. The user must supply 120 values of 
HRRAIN in column 3 of the data block. 

 
_____________________________ 
 

Page 5-40 Units not millimeters/s, but m/s 
Variable Name: HRWNDV 
Allowed Range: 0.5 ≤ value ≤ 30.0 (m/s) 
 
_____________________________ 
 

Page 5-42 Number of variable entries was not noted.  Add sentence to purpose. 
Variable Name: INDREL 
Purpose: … The user must supply NUM0 values for this variable on one or more 

cards. 
 
Variable Name:  INDRAD 
Purpose: … The user must supply NUM0 values for this variable on one or more 

cards. 
_____________________________ 
 

Page 6-5 Edit existing paragraph starting with “If the DCF file was generated by 
FGRDCF”  
 
If the DCF file was generated by FGRDCF using the dose conversion factors from FGR-11 and 
FGR-12, the first … 

Page 6-5 Add section 6.2.1 description of FGR-13 format 
 
If the DCF file was generated using the dose conversion factors from FGR-12 and FGR-13, the 
first of the two header records contains the letters FGR13DF. When COMIDA2 and MACCS2 
determine that an FGR13DF file is being used, as specified by the first 7 characters in the file 
named by the DCF_FILE variable, the list of available organs is set to the following: 
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A-SKIN 
A-RED MAR 
A-LUNGS 
A-THYROID 
A-STOMACH 
A-LOWER LI 
L-ICRP60ED 
L-RED MARR 
L-BONE SUR 
L-BREAST 
L-LUNGS 
L-THYROID 
L-LOWER LI 
L-BLAD WAL 
L-LIVER 
 
_____________________________ 
 

Page 6-10 Modify available List of organs for DOSFAC2 
 
The list of organs for which dosimetry data are available using DOSFAC2 is presented below. 
 
SKIN Yes No 
LUNGS Yes  Yes 
RED MARR Yes  Yes 
LOWER LI Yes  Yes 
STOMACH  Yes  No 
THYROID No  Yes 
THYROIDH Yes  Yes 
EDEWBODY  No Yes 
BONE SUR No  Yes 
BREAST  No  Yes 
BLAD WAL  No  Yes 
LIVER  No  Yes 
 
_____________________________ 
 

Page 6-11 Add Description of FGR-13 orgrans 
 
The list of organs for which dosimetry data are available when using the dose conversion factor 
data from FGR-12 and FGR-13 are the following: 
 
Organ –Name   Acute  Lifetime 
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SKIN    YES  NO 
RED MAR   YES  YES 
LUNGS   YES  YES 
THYROID   YES  YES 
STOMACH   YES  NO 
LOWER LI   YES  YES 
ICRP60ED   NO  YES 
BONE SUR   NO  YES 
BREAST   NO  YES 
BLAD WAL   NO  YES 
LIVER    NO  YES 
 
Example Usage: 
* 
MIORGDEF017 ‘L-ICRP60ED’ ‘TRUE’ 
_____________________________ 
 
 

Page 6-9 Add to section 6.2 

Annual Differential DCF and Comida2 Binary Files 

If variable DOSMOD is AT or PL, then the user needs to specify a set of dose conversion factor 
files and a corresponding set of Comida2 binary files. 

The base DCF file is one that contains the conversion factors for the total commitment period, 
which is normally fifty years. The base Comida2 file is created using the base DCF file. 

The annual, differential DCF files contain the dose conversion factors for one-year commitment 
periods. These file names are sequenced to enable the identification of the year number. For 
example, Fgr13dcf03.inp corresponds to the dose conversion factors used to calculate the dose in 
year three for an exposure that occurred in year one. The annual COMIDA2 files are created 
using the corresponding annual DCF files. Only the base DCF and COMIDA2 files need to be 
specified in the input cards.   

MACCS2 requires a consistent set of base and annual differential DCF files. These files are 
supplied as part of the distribution.  
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The following file naming convention is used: 

Annual, differential DCF and COMIDA2 data files consist of the base name minus the file 
extension (e.g., “.inp”) followed by a two-digit number identifying the year, followed by the file 
extension. For example, if Fgr13dcf.inp is the base DCF file and fgr13samp_a.bin is the base 
COMIDA2 file, the remaining files are named Fgr13dcf01.inp, fgr13samp_a01.bin, 
Fgr13dcf02.inp, fgr13samp_a02.bin, etc. 
The DCF base name is supplied to MACCS2 using the EARLY variable DCF_FILE. The 
COMIDA2 base name is supplied to MACCS2 using the CHRONC variable BIN_FILE. 

 

Example Usage: 

*Card in the EARLY input file 
DCF_FILE001 ‘C:\Program Files\WinMACCS\DCF and COMIDA2 Files\Threshold\Fgr-13 
\Fgr13dcf.inp' 
   
* Card in the CHRONC input file 
BIN_FILE001 ‘C:\Program Files\WinMACCS\DCF and COMIDA2 Files\Threshold\Fgr-13 
\fgr13samp_a.bin’ 
 
_____________________________ 
 

6.2.3.1 Dose Model Specification 
Three optional models are available to calculate latent-cancer injuries and fatalities. The first 
uses the standard linear, no-threshold, hypothesis (LNTH). This is the only model available in 
earlier versions of MACCS2. In the linear, no-threshold model, the relationship between dose 
and health effect is linear, even for infinitesimal doses. 

The second model is called the annual-threshold model. In this model, the user can specify a set 
of thresholds, one for each year of the calculation. The thresholds are specified in terms of total 
effective dose equivalent (TEDE). When the predicted TEDE falls below an annual threshold, 
there are no contributions to any long-term health effects; when the predicted TEDE exceeds the 
annual threshold, contributions to health consequences are calculated in the same way as with the 
LNTH model. An optional lifetime threshold, also in terms of TEDE, can be specified. If the 
lifetime threshold is exceeded, the health effects are identical to those calculated with the LNTH 
model. 

The third option is called the piecewise-linear model. In this model, the user can construct a 
series of line segments that define the mapping between dose and health effects. The line 
segments form a continuous curve. This model can be used to approximate a dose threshold, to 
create a sublinear dose-response model, or to create a superlinear dose-response model.  

These are EARLY input cards.   
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If a card is not present, the LNT model is assumed. No other dose-model input is required if the 
LNT model is chosen.  However, if either the annual-threshold (AT) or piecewise-linear (PL) 
dose model is chosen, the following are required: 

• A CHRONC calculation must be performed (ENDAT2 = .FALSE.). 
• The COMIDA2 food chain model or the No Food model must be chosen. 
• The KI population fraction (POPFRAC) must be 0 or 1 if the KI model is ON. 
• Other input cards dependent on the value of DOSMOD are required, as described 

below. 

 

Variable Name: DOSMOD 
Variable Type: Character, Scalar 
Allowed Value: AT, PL, or LNT  
Purpose: AT – Annual-threshold model 
 PL – Piecewise-linear model 
 LNT – Linear, no-threshold model 
 

Example Usage: 

 * Annual Threshold model  
LCDOSMOD AT 
 
_____________________________ 
 

6.2.3.2 Annual Threshold Model 
If variable DOSMOD is AT, then the following two input cards described are required: 

Variable Name: DTHNUM   
Variable Type: Integer, Scalar 
Allowed Range: 1 ≤ value ≤ 398 
Purpose:  Number of annual dose threshold values. 
 
Variable Name: DTHANN 
Variable Type: Real, Vector 
Allowed Range: 0. ≤ value ≤ 1.E30 Sieverts/Year 
Purpose: Dose threshold for health effect models for each year. If calculated annual 

L-ICRP60ED dose per person is below the specified threshold, all health 
consequences are zero for that year. Value specified for the last year is 
used for all remaining years in the calculation. First entry corresponds to 
year one, second to year two, etc. …  

 

The following variable can be optionally included. 
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Variable Name: DTHLIF 
Variable Type: Real, Scalar 
Allowed Range: 0. ≤ value ≤ 1.E30 Sieverts 
Purpose: Lifetime dose threshold.  If this dose is exceeded, then all previous and 

future doses are included in the calculation of health effects, regardless of 
annual threshold value. If EXPTIM is greater than 1.57788E9 sec (50 
years), then MACCS2 automatically resets EXPTIM to 1.57788E9. 

 
Example Usage: 
LCDTHNUM 5 (Number of years with defined threshold values) 
 
* Threshold value for year one 
LCDTHANN001 0.05 
* Threshold value for years two, three and four 
LCDTHANN002  0.02 
LCDTHANN003  0.01 
LCDTHANN004  0.005 
* Threshold value for year 5 and all subsequent years 
LCDTHANN005  0.001 
 
LCDTHLIF001 0.10 
 
_____________________________ 
 

6.2.3.3 Piecewise Linear Model 
If variable DOSMOD is PL, then the input cards described in this section are required. 

Variable Name: PWLNUM   
Variable Type: Integer, Scalar 
Allowed Range: 2 ≤ value ≤ 99 
Purpose: Number of piecewise dose, multiplier pairs entered by user. 
 
Variable Name: PWLDOS 
Variable Type: Real, Vector 
Allowed Range: 1.E-10 ≤ value ≤ 1.E30 Sieverts/Year 
Purpose: Dose associated with multiplier, PWLFAC.  Effective doses are calculated 

as the product of the multiplicative factor and the corresponding dose for 
each ordered pair (PWLDOS(i),PWLFAC(i)). Linear interpolation is used 
to calculate an effective dose given an actual dose. Health consequences 
are calculated using the effective rather than the actual dose. PWLDOS 
must be specified in ascending order. 

 
Variable Name: PWLFAC 
Variable Type: Real, Vector 
Allowed Range: 0.0 ≤ value ≤ 1.0E30 
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Purpose: Multiplicative factor associated with dose, PWLDOS. Effective doses are 
calculated as the product of the multiplicative factor and the corresponding 
dose for each ordered pair (PWLDOS(i), PWLFAC(i)). Linear 
interpolation is used to calculate an effective dose given an actual dose. 
Health consequences are calculated using the effective rather than the 
actual dose. The last value in vector PWLFAC must be 1. 

 
Example Usage: 
* 
LCPWLNUM 4 (Number of (dose, multiplier) pairs) 
* 
LCPWLDAT001 0.5 0.1 (dose, multiplier) 
LCPWLDAT002 1.0 0.25 (dose, multiplier) 
LCPWLDAT003 2.0 0.5 (dose, multiplier) 
LCPWLDAT004 3.0 1.0 (dose, multiplier) 
 
_____________________________ 

Page 6-12 add paragraph at end 
 
CSFACT, PROTIN, BRRATE, SKPFAC and GSHFAC can be redefined for each EARLY 
evacuation scenario (cohort).  In other words, these variables can be included in EARLY change 
card sets.  However, neither RESCON nor RESHAF can be included in change card sets.  
 

Page 6-22 Add to end of WTNAME Purpose 
WTNAME should only occur once and should not be included in a change card set.  If 
WTNAME = ‘SUMPOP’, then the WTFRAC variable is not used.   

 
_____________________________ 
 

Page 6-24 Top of page, sequence number missing from card example 
Example Usage: 

* 
* EVACUATION TRAVEL SPEEDS FOR THREE EVACUATION PHASES 
(METERS/SECOND) 
* Initial Middle Late 
EZSPEED001 1.8 1.8 1.8 
 
_____________________________ 
 

Page 6-24 New variable added.  Description follows EZSPEED 
Variable Name: ESPMUL   
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Variable Type: Real, Array 
Allowed Range: 0.0 ≤ value ≤ 1.0 
Purpose: Defines a multiplier to be applied to the evacuation speed variable, 

ESPEED, during periods of precipitation.   
 
If this variable is not included, MACCS2 assumes a value of one for each entry.  For situations 
where evacuation starts before the release begins, the weather prior to release is assumed to be 
the same as at the beginning of release. Precipitation data is from HRRAIN, BNDRAN, or the 
meteorological file, depending on the weather sampling method.  All three values must be the 
same if TRAVELPOINT = 'BOUNDARY'. 
 
The user must supply three values for this parameter. 

Example Usage: 

* 
* EVACUATION TRAVEL MULTIPLIERS FOR THREE EVACUATION PHASES  
* Initial Middle Late 
EZSPMUL001 0.8 0.5 0.4 
 
_____________________________ 
 

Page 6-26 New variable added.  Description follows IDIREC 
Variable Name: ESPGRD   
Variable Type: Real, Array 
Allowed Range: 0.01 ≤ value ≤ 10. 
Purpose: Defines a multiplier for each grid element to be applied to the evacuation 

speed variable, ESPEED, to account for differences in the road network.   
 
If this variable is not included, MACCS2 assumes that the value for each entry is one. The value 
of evacuation speed in an element is calculated with the following formula: 
Evacuation Speed = ESPEED * ESPMUL * ESPGRD  if precipitation is occurring  
Evacuation Speed = ESPEED * ESPGRD    if no precipitation is occurring  
 
ESPEED and ESPMUL are defined for each of the three sub phases (initial, middle, and late) of 
the emergency phase, but are independent of grid element. ESPGRD is independent of the sub 
phase, but is defined for each grid element. 
 
If this variable is included, an input data record must be supplied for every ring in the evacuation 
and sheltering region (i.e., for all intervals extending out to LASMOV).  Each line of data 
contains values corresponding to each of the compass points. 
  
Example Usage: 
* 
* DEFINE THE EVACUATION SPEED MULTIPLIER FOR EACH GRID ELEMENT 
*                      N                      E                     S                      W 
EZESPGRD001  0.5 0.5 1.0 1.0 1.5 1.5 1.5 2.0 2.0 2.0 1.5 1.5 1.0 1.0 0.5 0.5   (FIRST RING) 
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EZESPGRD002  0.5 0.5 1.0 1.0 1.5 1.5 1.5 2.0 2.0 2.0 1.5 1.5 1.0 1.0 0.5 0.5   (SECOND RING) 
EZESPGRD003    1.0 1.0 1.5 1.5 2.0 2.0 2.0 2.5 2.5 2.5 2.0 2.0 1.5 1.5 1.0 1.0   (THIRD RING) 
. 
. 
. 
_____________________________ 
 

Page 6-29 Append to section 6.6.8 
Variable Name: KIMODL   
Variable Type: Character, Scalar 
Allowed Value: KI or NOKI 
Purpose: If the value is ‘KI’ then the consequences calculation account for ingestion 

of KI. If the value is 'NOKI', then the KI model is not used. 

 

The KI ingestion model treats the reduction of uptake of radioiodine by the thyroid gland. The 
ingested KI saturates the thyroid gland so that the effect of inhaling iodine from a plume is 
diminished. The KI ingestion model allows the user to specify a population fraction that ingests 
KI and an efficacy factor. The efficacy factor defines the fractional dose reduction to the thyroid 
gland from inhaled radioiodine. 

If this card is not present, then the value of KIMODL is assumed to be ‘NOKI’. This is to 
support backward compatibility with MACCS2 1.12. 

 

Example Usage: 

* KIMODL, KI model 
EZKIMODL001 NOKI 

 

If variable KIMODL is set to ‘NOKI’, no further input is required. However, if the KI model is 
set to KI for any of the evacuation scenarios, then the POPFRAC and EFFACY variables must 
be present for scenario one. 

If variable KIMODL is set to ‘KI’, the following input are required along with the following 
restrictions and enhancements: 

 
• The value of POPFRAC  must be either 0 or 1 if dose model, DOSMOD, equals 

AT or PL 
• Variables EFFACY and POPFRAC are supported in the EARLY multiple 

evacuation (change card) methodology.   

 

Variable Name: EFFACY   
Variable Type: Real, Scalar 
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Allowed Range: 0.0 ≤ value ≤ 1.0 
Purpose: Efficacy factor for KI model. Thyroid health consequences from 

inhalation of radioiodine are reduced by a factor of (1 - EFFAC). 
 
Variable Name: POPFRAC   
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 1.0 
Purpose: Fraction of the population that ingests KI. 
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Example Usage: 

* KIMODL, KI model 
EZKIMODL001 KI 
* EFFACY, KI Ingestion 
EZEFFACY001 0.7 
* POPFRAC, KI Ingestion 
EZPOPFRC001 0.25 
 
_____________________________ 
 

Page 6-27-28 Variables need to be move to non charge card section on page 6-14. 
TIMHOT 
TIMNRM 
DOSNRM 
DOSHOT 
ENDEMP 
 

Page 6-51 Type 6 output is supported if there is no evacuation. 
Variable Name:  NUM6 
Purpose:  The number of results of this type to be calculated. This result is only 

available when straight-line plume dispersion (IPLUME=1) and radial 
evacuation (EVATYP=’RADIAL’) or no evacuation (LASMOV=0) are 
selected.  If IPLUME>1 or EVATYP=’NETWORK’, an input error occurs 
and MACCS2 execution is terminated. 

 
_____________________________ 
 

Page 6-57 In the paragraph above the description of variable NUMB, the record identifier 
is incorrect. 
If the controlling card (record identifier TYPEBNUMBER) is omitted, the calculations proceed 
on the assumption that the Type B results are not being requested. 

 
_____________________________ 
 

Page 6-58 New output types C and D are added 
 
_____________________________ 
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6.21  Land Area for which Dose is Exceeded   
This optional output provides the land area (hectares) that exceeds a user-specified dose level. 
Optionally, the user can also request dose levels for every grid element in the MACCS2 grid. 

 

These are the EARLY input cards related to this output type. 

 
Variable Name: NUMC   
Variable Type: Integer, Scalar 
Allowed Range: 1 ≤ value ≤ 16 
Purpose: Defines the number of results of this type being requested. 
 
Variable Name: ORGNAM   
Variable Type: Character, Vector 
Allowed Values: Allowed values depend on the dose conversion factor file specified. These 

allowed values are listed below. 
 

Table A-1.  Organs supported by MACCS2 
DCF based on FGR-13  DCF generated by 

DOSFAC2 
DCF generated by FGRDCF 

A-SKIN A-SKIN L-GONADS 
A-RED MARR A-RED MARR L-BREAST 
A-LUNGS A-LUNGS L-LUNGS 
A-THYROID A-THYROIDH L-RED MARR 
A-STOMACH A-STOMACH L-BONE SUR 
A-LOWER LI A-LOWER LI L-THYROID 
L-ICRP60ED L-EDEWBODY L-REMAINDER 
L-RED MARR L-RED MARR L-EFFECTIVE 
L-BONE SUR L-BONE SUR L-SKIN(FGR) 
L-BREAST L-BREAST  
L-LUNGS L-LUNGS  
L-THYROID L-THYROID  
L-LOWER LI L-LOWER LI  
L-BLAD WAL L-BLAD WAL  
L-LIVER L-LIVER  
 L-THYROIDH  
 
Purpose: The land area (hectares) that exceeds a user-specified dose level (Sieverts) 

to a specified organ is reported. Optionally, dose values for all grid 
elements for the specified organ are displayed. 

 
Variable Name: ELEVDOSE   
Variable Type: Real, Vector 
Allowed Range: 0.0 ≤ value ≤ 1.0E12 (Sv) 
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Purpose: Threshold value for calculating land contamination areas. Land area that is 
contaminated above the threshold value is reported in the output. 

 
Variable Name: PRINT_FLAG_C   
Variable Type: Logical, Vector 
Allowed Range: .TRUE. or .FALSE. 
Purpose: If .TRUE., the output includes dose levels to the specified organ for each 

grid element. If .FALSE., only the land area is reported. 

 

Example Usage: 

* 
* Land area for which dose is exceeded 
TYPECNUMBER 1 
* ORGNAM DOSE PRINT_FLAG_C 
TYPECOUT001  'L-EDEWBODY'   0.01 .FALSE.   
 
_____________________________ 
 

6.22 Land Area for which Concentration is Exceeded   
This optional output provides the land area (hectares) that exceeds a user-specified ground 
concentration level for a specified radionuclide. Optionally, the user can also request ground 
concentrations (Sv/m2) and ground-level airborne exposures (Sv-s/m3) for every grid element in 
the MACCS2 grid. 

 

These are EARLY input cards. 

 

Variable Name: NUMD   
Variable Type: Integer, Scalar 
Allowed Range: 1 ≤ value ≤ 40 
Purpose: Defines the number of results of this type being requested. 
 
Variable Name: I1DISTD 
Variable Type: Integer, Vector 
Allowed Range: 1 ≤ value ≤ NUMRAD 
Purpose: Outer spatial interval bounding the region of interest. Area considered is 

from zero to the outer spatial interval. 



 

NUREG/CR-____ 170 

 
Variable Name: NUCLIDED   
Variable Type: Character, Vector 
Allowed Values: Values must appear in vector NUCNAM, a vector of previously defined 

radionuclides.  
Purpose: The land area (hectares) that exceeds a user-specified ground-

concentration level (Bq/m2) of a specified radionuclide is reported. 
Optionally, ground concentrations (Bq/m2) and ground-level airborne 
exposures (Bq s/m3) are reported for all grid elements. 

 
Variable Name: ELEVCONC   
Variable Type: Real, Vector 
Allowed Range: 0.0 ≤ value ≤ 1.0E12 (Bq/m2) 
Purpose: Threshold value for calculating land contamination areas. Land area 

(hectares) that is contaminated above the threshold value is reported in the 
output. 

 
Variable Name: PRINT_FLAG_D   
Variable Type: Logical, Vector 
Allowed Range: .TRUE. or .FALSE. 
Purpose: If .TRUE., the output includes results for each grid element.  If .FALSE., 

only the land area is reported. 

 

Example Usage: 

* Land Area where concentration is exceeded 
TYPEDNUMBER   1 
* I1DISTD NUCLIDED ELEVCONC PRINT_FLAG_D 
TYPEDOUT001 10 Cs-137 550.0 .FALSE.   
 
_____________________________ 
 

Page 7-7 Allowed range documented is in error.   
Variable Name: TMPACT 
Allowed Range: 0. 0 ≤ value ≤  EXPTIM 
 
_____________________________ 
 

Page 7-11 Added data restriction, append to end of purpose 
Variable Name: DSRFCT 
Purpose: … A value must be supplied for each of the LVLDEC decontamination 

levels. 
 
_____________________________ 
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Page 7-18 Added caveat 
Variable Name: VALWF 
Purpose: Add the following caveat (the same as in the previous four variable 

descriptions). 
 
Note:  If a Site Data file is being used (POPFLG=FILE), the value of this input parameter is not 

used by the code; nevertheless a valid parameter value must by supplied. 
 
_____________________________ 
 

Page 7-18 Added caveat 
Variable Name: FRFIM 
Purpose: Add the following caveat (the same as in the previous five variable 

descriptions). 
 
Note:  If a Site Data file is being used (POPFLG=FILE), the value of this input parameter is not 

used by the code; nevertheless a valid parameter value must by supplied. 
 
_____________________________ 
 

Page 7-18 Added caveat 
Variable Name: VALWNF 
Purpose: Add the following caveat (the same as in the previous six variable 

descriptions). 
 
Note:  If a Site Data file is being used (POPFLG=FILE), the value of this input parameter is not 

used by the code; nevertheless a valid parameter value must by supplied. 
 
_____________________________ 
 

Page 7-18 Added caveat 
Variable Name: FRNFIM 
Purpose: Add the following caveat (the same as in the previous seven variable 

descriptions). 
 
Note:  If a Site Data file is being used (POPFLG=FILE), the value of this input parameter is not 

used by the code; nevertheless a valid parameter value must by supplied. 
 
_____________________________ 
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Page 7-22 Add a new possible value for FDPATH 
_____________________________ 
 
… 
If the user wishes to turn off the Food and water dose calculations, this is accomplished by 
setting FDPATH = ‘OFF’. When this is done, no food or water ingestion is treated. No Comida2 
or MACCS2 food-model input parameters are required. 
_____________________________ 
 
Variable Name: FDPATH 
Variable Type: Character, Scalar 
Allowed Range: ‘OLD’, ‘NEW’, or ‘OFF’ 
Purpose: If the value is set to ‘OFF’, no food or water dose calculations are 

performed. 
 
_____________________________ 

Page 7-9 Add a new section 
_____________________________ 
 

7.4.1 Shielding and Exposure 
The shielding and exposure values are those to be used during CHRONC calculations. In earlier 
versions of MACCS2, these were the values used in the last emergency response scenario 
(cohort) defined in the EARLY input. Values used in EARLY for normal activity are reasonable 
values to use for these CHRONC variables.  
 
Variable Name: LPROTIN 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 1.0 
Purpose: Inhalation protection factor. A value of 0 indicates complete protection 

from inhalation of radioactive materials; a value of 1 indicates no 
protection. 

Example Usage: 
* 
* Inhalation protection factor 
CHLPROTIN01 .41 
 
 
Variable Name: LBRRATE 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 1.0 cubic meters/second 
Purpose: Breathing rate. 
Example Usage: 
* 
* LBRRATE - Breathing rate used in CHRONC 
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CHLBRRATE01 2.66E-04 
 
Variable Name: LGSHFAC 
Variable Type: Real, Scalar 
Allowed Range: 0.0 ≤ value ≤ 1.0 
Purpose:  Groundshine shielding factors. A value of 0 indicates complete protection 

from groundshine; a value of 0.5 indicates no protection from 
groundshine. 

Example Usage: 
* 
* LGSHFAC - groundshine shielding factor used in CHRONC 
CHLGSHFAC01 .33 
 
_____________________________ 

Modify second sentence on pg A-1 
_____________________________ 

… The file consists of up to ten years of either fifteen-minute, thirty-minute or hourly averages 
of the wind direction, wind speed, atmospheric stability, and precipitation rate. 

 
_____________________________ 

Modify first sentence paragraph three on pg A-1 
_____________________________ 
 There are a total of 8763 records in a meterological file that represents hourly averages of 
weather conditions.  
_____________________________ 

Page A-1 Modification to paragraph three 
_____________________________ 
 
….CRAC2 meteorological data files may be used with MACCS2.   
 
An optional line has been added to the meteorological data file which, if present, appears as the 
3rd line in the file.  The optional line defines the PERIOD of the data in the file.  The line has the 
following format: 
 
/PERIOD 30 
 
Where 30 is means that each line of data in the file is represents a 30-minute time period.  The 
default value of 60 is assumed if the optional line does not appear in the file. This value is free 
formatted, meaning that the column where /PERIOD starts, and the column where 30 starts is not 
important provided there is at least one space separating the fields.  Values supported are 15, 30, 
and 60. 
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Note: the total time the file covers does not change. In each case, 365 days of weather data must 
be in the file. Therefore if PERIOD is 60, there are 8760 lines of weather data in the file; if 
PERIOD is 30, there are 17520 lines of weather data in the file; if PERIOD is 15, there are 
35040 lines of weather data in the file. 
 
Records 3 (or 4 if the file contains a value of PERIOD) to the next to the last record contain 
meteorological observations.  These data are input as integers.  The format of the information is 
as follows: 
_____________________________ 

Page A-1 Meteorological Data-File Format. Correct description of RNMM 
_____________________________ 
 
The last columns 15-17 of data should be interpreted as a rain rate in millimeters per hour rather 
than in units of millimeters of rain during the time period. This does not change the interpretation 
of values in older meteorological files since the time interval is 1 hour. 
 
_____________________________ 

Page A-1 Meteorological Data File Format. Edit first sentence in second to last paragraph 
to read: 
_____________________________ 
 
The last record of the file (i.e. 8763, 17521, or 35041 etc.) contains a table … 
 
_____________________________ 
 

Page A-2 Modify Range of Height variables from 0 to 999 to 1 to 100 
 

A.4 Preprocessor PopMod 
 
PopMod was developed to support a finer polar using WinMACCS and MACCS2. 
 
This software reads an ASCII population file, created by SECPOP2000, compatible with 
MACCS2 1.13.1 requirements, and creates a new population file containing more compass 
sectors.  The work of PopMod is to interpolate the course-resolution data onto a finer-resolution 
grid.  No higher-fidelity information is added to the new site data file. 
 
SECPOP2000 supports exactly 16 compass sectors, hence site file on a finer polar grid cannot be 
created with the current version of SECPOP2000.  If SECPOP2000 supports a finer polar grid in 
the future, it would be preferable to create the site file directly with SECPOP2000.  
 
An interface to PopMod exists in WinMACCS.  This interface can be accessed through the 
General/File Specification/Site File form. 
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PopMod requires three arguments as follows: 

• Argument One: Full path and name of original population file. Ideally, this should 
be a file created directly with SECPOP2000. Accuracy may be lost if this 
argument refers to a file created by a previous run of PopMod.exe. 

• Argument Two: Full path and name of a new population file that is created from 
the population file specified in Argument One. 

• Argument three: Number of compass sectors to be included in the file specified 
by Argument Two. Argument Three must be greater than or equal to the number 
of compass sectors used in the file specified in Argument One.  WinMACCS only 
allows values of 32, 48, or 64; however, this is not a restriction if using PopMod 
in a command window. 

Arguments are separated by a single space or tab.  If an argument contains spaces, the argument 
needs to be enclosed in double quotes.  Embedded quotes in arguments are not supported. 
 
 This preprocessor can also be executed directly using a command prompt window as 
demonstrated in the following example: 

1. Select Run from the Windows start menu and type cmd.exe. 
2. Change directories to the directory where PopMod.exe is located. 
3. Type the command to run PopMod as shown in Figure 90.  In this example, 

the number of compass sectors is increased from 16 to 48.  Sursit.inp has 16 
sectors, as indicated by a line in the Sursit.inp file: “16 WIND 
DIRECTIONS”.  A file with 48 sectors is created and named Sursit_48.inp.    

 

 
Figure 90 Run PopMod.exe from Command Line 

 

A.3.1 Description of algorithm to create a new population file: 
 
The data in the site file is divided up into sections.  The new file is identical to the old file, with 
the exception of the following sections: 
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COMMENT SECTION: 
The first two lines of the population file contain comments. The previous format allowed only 80 
characters per line.  To adhere to good quality assurance, the first comment line has an additional 
comment appended to the last non blank character, causing this line to exceed 80 characters.  
Line one in the new file contains the name of the original population file argument one, the 
version of PopMod used, and the date and time the new file was created. 
 
WIND DIRECTIONS: 
This value is changed to the value specified in argument three, the number of compass sectors. 
 
POPULATION: 
The population is interpolated onto the new compass sectors.  The software overlays the new 
grid onto the old one and assigns the population to the new grid sectors weighted by new area 
relative to the old area. The populations written to the new file are rounded to the nearest integral 
value. This is necessary to preserve the file format. 
 
LAND FRACTION:  
The value of land fraction is either the same as that of a course sector or the average of two 
course sector values when it overlaps the two. 
 
REGION INDEX: 
If the fine sector falls entirely within a single course sector, then the REGION INDEX of the fine 
sector is assigned the same value as the course sector. If the fine sector overlaps two course 
sectors, the REGION INDEX associated with the course sector to the left (counter clockwise) is 
used.  
 
WATERSHED INDEX: 
Values are assigned in the same manner as for the REGION INDEX. 
 
_____________________________ 

Page D-2 Entry for DISTANCE references section 7.5.2.  This should be section 5.7.2 
 
_____________________________ 
 

Page Ref-1 New References added to list 
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Appendix B:  MACCS2 Binary Results File Format  
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B-1 BINARY FILE OVERVIEW 
With the WinMACCS development, it became necessary to create a file for easy communication 
of results between the MACCS2 modeling engine and the WinMACCS interface. All that existed 
at the point of MACCS2 1.12 was an ASCII formatted output file. The information on this file 
did not have sufficient structure to serve as a generic output file. It was believed to be an 
unreasonable constraint to require the MACCS2 ASCII output file to always comply with a 
format that WinMACCS could automatically process. In a development environment, output 
files often change formats. It was decided that there would be a separate file created by 
MACCS2 that would provide a better interface between MACCS2 and WinMACCS with the 
following design criteria. 

The format of the file was to be in binary rather than ASCII format. This reduced the size of the 
file to one quarter of its ASCII equivalent. Additionally, the real and integer representations of 
the results are on the binary file, reflecting the accuracy of the calculated results without the 
round off caused by FORTRAN formatted write statements.  

If the MACCS2 developer adds new variables to the file in a later version of MACCS2, 
WinMACCS would not have to be modified to display the new data.  

The binary file would need to support multivariate data. For example, a variable value may be 
tied to a plume number, a radionuclide and an evacuation scenario.   

B-2 FILE STRUCTURE 
The binary file is a sequence of records.  Each record begins with a “BOR” (beginning of record) 
marker and ends with a “EOR” (end of record) marker. 

This file is created by MACCS2 using the following FORTRAN statement 

Open (UNIT=FileID, FILE=FileName, FORM='BINARY') 

Note:  If the FORTRAN compiler used is not Intel 7.0, there may be incompatibles in reading 
this file in WinMACCS.  This is because the exact record contents of a binary file record 
varies between FORTRAN compliers. 

B-2.1 Record Structure Overview 
Data are written to the binary file using the following data types: 

• Fixed strings.  For example, the RecordBOR field is a fixed ASCII string.  Each 
character in the four character marker (e.g., E, O, R, space) is written as a single 
byte in ASCII representation. 

• Variable length strings.  The length of the string (as a 4 byte integer) always 
precedes the character array representing the string on the binary file.  For 
example, the string “HEADER” is encoded as: 

o Integer representation of 7 using 4 bytes 
o 7 byte ASCII string “HEADER” 
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• 4 byte integers. 
• 4 byte real numbers. 

Each record in the file adheres to the following standard: 

 

Table B-1.  Structure of a Record in the Binary File 
Field Description 

RecordBOR 4 byte fixed ASCII string, begin of 
record marker (“BOR”) 

RecordLab Variable length ASCII string 
identifying the record type. This is 
descriptive. 

RecordID 4 byte fixed ASCII string 
identifying the record type. These 
are always four digits.  

RecordData Determined by RecordID 
RecordEOR 4 Byte ASCII end of record 

marker, “EOR”. 
 

B-2.2 Record Types 
The following record types are supported: 

 
Table B-2.  Record Types Written to the Binary File 

RecordLab RecordID Description of RecordData 
HEADER 0000 Record contains time stamp, versioning 

information and other miscellaneous 
information.  
Heading type record. 

QUALIFIERS 0001 Record contains details regarding the 
multivariate data (qualifiers), such as labels and 
units. For example, (“Distance”, “km”).  
Heading type record.  

VARIABLES 0002 Record contains details regarding the result 
variables such as labels and units. For example, 
(“Release”, “Sv”) and has qualifiers (“Plume”, 
“Nuclide”, “Left Distance”, “Right Distance”).   
Heading type record. 

STATS 0003 Record contains details regarding statistical 
labels.   
Heading type record.  

VECTOR_ RESULTS 0004 Record contains result vectors or variables with 
a single value.  
Results type record. 
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RecordLab RecordID Description of RecordData 
2-D_ RESULTS 0005 Record contains (x,y) pairs of data results.  

Results type record. 
STAT_ RESULTS 0006 Record contains blocks of statistical results.   

Results type record. 
CCDF_RESULTS  0007 Record contains cumulative probability 

distributions (CCDF) as (x,y) pairs of data. 
Results type record. 

 

Heading type records occur only once, and precede all results type records. Results type records 
contain calculated MACCS2 results. There are multiple occurrences of these records. 

WinMACCS version 3.0 graphics does not support 2-D_RESULTS. With respect to 
Vector_Results type records, WinMACCS version 3.0 supports only single values variables 
(vectors of length one).   

These data types were included in the MACCS2 structure for future enhancements. 

B-2.3  RecordData Fields 
B-2.3.1 RecordData Field for the Header Record 
The following variables are written to the RecordData field when RecordLab=HEADER: 

1. Date is a variable length string containing date (e.g., 20010402 is April 2, 2001). 
2. Time Stamp is a variable length string containing time.  10-byte character array, (e.g., 

151141.589 is 15th hour, 11th minute and 41.589 sec). 
3. MACCS Version is a variable length string containing version number (e.g., 1.13.0.6). 
4. Undefined_Int is a 4-byte integer containing value of a 4-byte undefined integer. 
5. Undefined_Real is a 4-byte real containing value of a 4-byte undefined real. 

B-2.3.2 RecordData Field for the Qualifiers Record 
MACCS2 data is multivariate data. An example of the multidimensionality of variables is a 
plume release. This variable is described by three qualifiers, the plume number, the nuclide 
released and the ATMOS source term set. 

The QUALIFIERS RecordData field lists all of the qualifiers referenced in the results type 
records. The following variables are written to the RecordData field when 
RecordLab=QUALIFIERS: 

NQual is a 4 byte integer containing the number of qualifiers defined in this block. This is 
followed by NQual sets of data. Each set of data describes a qualifier as follows: 



 183  

• QualID is a 4 byte integer identifying the qualifier. This ID is referenced in the 
results records 

• QualName is a variable length string containing the qualifier name (e.g., 
“Distance”) 

• Units is a variable length string  describing units (e.g., “km”) 
• Type 4 byte integer identifying data type 

1 – Character Data 

2 – 4 byte Integer 

3 – 4 Byte Real 

4 – TypeNoKey, character data that is not used by WinMACCS to build a key for data 
lookup. The intension was to link a copy of the output request to the data. 

Example: (2, “Distance”, “km”, “3”) 

Note: For simplicity in viewing these files in an ASCII editor, the qualifier values in the results 
record are written as variable length strings. However, the Type variable aids the 
processing software (e.g., WinMACCS) in translating values. 

The following values are used to build the qualifiers record in MACCS2 2.0. However, new 
qualifiers can be added without impacting the processing of this file in WinMACCS. 

 
Table B-3.  Record Qualifiers associated with Results 

[QualID] [QualName] [Units] [Type] Example Value 
1 Nuclide none Character Co-60 
2 Ldistance km Real 5.3 
3 Rdistance km Real 6.5 
4 Distance km Real 6.6 
5 Plume none Integer 3 
6 Evacuation none Integer 1 
7 Health Effect none Character ERL INJ/PRODROMAL 

VOMIT 
8 Exceeds Risk km Real 5.6 
9 Organ none Character A-LUNGS 
10 Exceeds Dose sV Real 5.2 
11 Source Term none Integer 1 
12 Angle none Character ENE 
13 Pathway None Character GRD 
14 Elevation Dose Sv Real 10. 
15 Elevation Concentrat Bq/m2 Real 4.2 
16 MACCS2_Input None TypeNoKey TYPE1OUT001 ‘ERL 

FAT/TOTAL' 1 26 NONE 
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B-2.3.3 RecordData Field for the Variables Record 
The VARIABLES RecordData field lists all of the variable labels and the variable’s required 
qualifiers. The VarID is referenced in the results type records.    

The following variable is written to the RecordData field when RecordLab=VARIABLES: 

• NVar is a 4 byte integer defining the number of variables defined in this block. 

This is followed by NVar sets of data. Each set of data describes a variable as follows: 

1. VarID is a 4 byte integer identifying the variable. 
2. VarLab  is a variable length string describing the variable. 
3. NQual is a 4 byte integer identifying the number of qualifiers associated with this 

variable. 
 
This is followed by NQual 4 byte integers, QualID( ), containing the qualifier IDs 
associated with this variable. Details regarding these qualifier IDs are in the Qualifiers 
Record. 

6. Units is a variable length string describing the units associated with this variable. 

Example: (0110, “Centerline Air Concentration”, 5, 11, 5, 1, 2, 3, “Bq-s/m3”). In this example, 
the sequence 5, 11, 5, 1, 2, 3 means that there are five qualifiers associated with this 
variable with Qualifier ID’s 11, 5, 1, 2, and 3 corresponding to Source Term, Plume, 
etc. (see the QUALIFIERS RecordData field description). 

What follows is a description of the variables that are written to the MACCS2 Version 2.1 binary 
output file. 
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Table B-4.  Results Written to the Binary File 
Maccs2 Variable Name containing 

value of VarID 
VarID VarLab Comments Qualifiers Units 

ATMOS 
BIN_RELEASE 1 Release 

 
 

This output is always 
included in the ATMOS 
output.  There are 
entries for each isotope 
(1 to NUMISO), for 
each plume release, and 
for each ATMOS 
change set (or source 
term) 

Source Term 
Plume 
Nuclide 

Bq 

BIN_CLINE_AIR_CON 2 Centerline Air 
Concentration 
 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

Bq-s/m3 

BIN_GROUND_AIR_CON 3 Ground-Level Air 
Concentration 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

Bq-s/m3 

BIN_CLINE_GROUND_CON 4 Centerline Ground 
Concentration 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

Bq/m2 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_TOT_CLINE_GROUND_CON 5 Total Centerline 
Ground 
Concentration 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

Bq/m2 

BIN_GROUND_DISP 6 Ground-Level 
Dispersion 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

s/m3 

BIN_SOURCE_STREN 7 Source Strength Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

 Bq 

BIN_PLUME_CROSS_SZ 8 Plume Crosswind 
Size 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

m 



 187 NUREG/CR-XXXX 

Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_VERT_SZ 9 Plume Vertical 
Size 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

 m 

BIN_PLUME_CLINE_HEIGHT 10 Plume Centerline 
Height 
 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

 m 

BIN_PLUME_TIME 11 Plume Arrival 
Time 

Type 0 output Source Term 
Plume 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

s 
 

EARLY 
BIN_NEARLY_HEALTH 12 Number Early 

Health Effects 
Cases 

Type 1 output Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
MACCS2_Input 

none 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_HEALTH_LNT_DOSE 81 Health Effects 
LNT Population 
Dose 

Type 1 output 
Note: This output is 
only printed when 
the Threshold or 
Piecewise model is 
used 

Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
Organ 
MACCS2_Input 

Sv 

BIN_HEALTH_USED_DOSE 82 Health Effects 
Used Population 
Dose 

Type1 output 
Note: This output is 
only printed when 
the Threshold or 
Piecewise model is 
used 

Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
Organ 
MACCS2_Input 

Sv 

BIN_EARLY_FAT_RAD 13 Early Fatality 
Radius 

Type 2 output Source Term 
Evacuation 
Exceeds Risk 
MACCS2_Input 

km 

BIN_NEARLY_POP_X_DOSE 14 Number Early 
Population 
Exceeding Dose 

Type 3 output Source Term 
Evacuation 
Organ 
Exceeds Dose 
MACCS2_Input 

none 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_EARLY_AVG_RISK 15 Early Average 
Individual Risk 
 

Type 4 output Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
MACCS2_Input 

none 

BIN_LIFE_POP_DOSE 16 Lifetime 
Population Dose 
 

Type 5 output Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

Sv 

BIN_PATH_CLINE_DOSE 17 Pathway Specific 
Centerline Dose 
 

Type 6 output Source Term 
Evacuation 
Organ 
Pathway 
Ldistance 
Rdistance 
MACCS2_Input 

Sv 

BIN_CLINE_RISK 18 Centerline Risk 
 

Type 7 output Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
MACCS2_Input 

none 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_POP_RATED_RISK 19 Population Rated 
Risk 
 

Type 8 output Source Term 
Evacuation 
Health Effect 
Ldistance 
Rdistance 
MACCS2_Input 

none 

BIN_PEAK_DOSE 20 Peak dose 
 

Type A output Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

Sv 

BIN_PEAK_RAD_DOSE 21 Peak dose (radial) 
 

Type B results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
Angle 
MACCS2_Input 

Sv 

BIN_DOSE_ALL_LOC 22 Dose at all 
Locations  
 

Type C results Source Term 
Evacuation 
Organ 
Angle 
Ldistance 
Rdistance 
MACCS2_Input 

Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_DOSE_ALL_LOC_ELEV 79 Dose at all 
locations Area 
That Exceeds 
Threshold 
 

Type C results Source Term 
Evacuation 
Elevation Dose 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

Ha 

BIN_EARLY_GROUND_CON 23 Early Ground 
Concentration 
 

Type D output Source Term 
Evacuation 
Nuclide 
Angle 
Ldistance 
Rdistance 
MACCS2_Input 

Bq/m2 

BIN_EARLY_GROUND_CON_ELEV 80 Early Ground 
Conc Area That 
Exceeds 
Threshold 
 

Type D output Source Term 
Evacuation 
Elevation 
Concentration 
Nuclide 
Ldistance 
Rdistance 
MACCS2_Input 

Ha 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_EARLY_AIR_CON 24 Early Air 
Concentration 
 

Type D output Source Term 
Evacuation 
Nuclide 
Angle 
Ldistance 
Rdistance 
MACCS2_Input 

Bq-s/m3 

CHRONC 
BIN_PATHWAY_DOSE 25 Tot Long-Term 

Pathways Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_EXP_PATH 26 Tot Long-Term 
Direct Exposure 
Pathways 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGESTION_DOSE 27 Tot Ingestion 
Pathways Dose  
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_GROUND_DOSE 28 Long-Term 
Groundshine Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_RESUSP_DOSE 29 Long-Term 
Resuspension 
Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_POP_DECON_DOSE 30 Population 
Dependent 
Decontamination 
Dose 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_FARM_DECON_DOSE 31 Farm Dependent 
Decontamination 
Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_WATER_INGEST_DOSE 32 Water Ingestion 
Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_MILK_DOSE 33 Milk Growing 
Season Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_CROP_DOSE 34 Crop Growing 
Season Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_LONG_MILK_DOSE 35 Milk Long-Term 
Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_LONG_CROP_DOSE 36 Crop Long-Term 
Dose 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_GRAINS 37 Ingestion of 
Grains 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_LEAFY 38 Ingestion of Leafy 
Vegetables 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_ROOT 39 Ingestion of Root 
Crops 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_INGEST_FRUIT 40 Ingestion of Fruits 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_LEGU 41 Ingestion of 
Legumes 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_BEEF 42 Ingestion of Beef 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_INGEST_MILK 43 Ingestion of Milk 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_INGEST_POULTRY 44 Ingestion of 
Poultry 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 
 

BIN_INGEST_OTHER 45 Ingestion of Other 
Meat Crops 
 

Type 9 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

person-Sv 

BIN_TOT_ECO_COST 46 Total Economic 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_POP_COST 47 Pop Dependent 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_FARM_COST 48 Farm Dependent 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_POP_DECON_COST 49 Pop Dependent 
Decontamination 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_FARM_DECON_COST 50 Farm Dependent 
Decontamination 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_POP_INTERD_COST 51 Pop Dependent 
Interdiction Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_FARM_INTERD_COST 52 Farm Dependent 
Interdiction Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_POP_COND_COST 
 

53 Pop Dependent 
Condemnation 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_FARM_COND_COST 54 Farm Dependent 
Condemnation 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN-EMERGENCY_COST 55 Emergency Phase 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN-INTERMEDIATE-COST 56 Intermediate 
Phase Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_MILK_DISP_COST 57 Milk Disposal 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 

BIN_CROP_DISP_COST 58 Crop Disposal 
Costs 
 

Type 10 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

$ 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_FARM_DECON_DIST 59 Farm Dependent 
Decontamination 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_POP_DECON_DIST 60 Pop Dependent 
Decontamination 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_FARM_INTERD_DIST 61 Farm Dependent 
Interdiction 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_POP_INTERD_DIST 62 Pop Dependent 
Interdiction 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_FARM_COND_DIST 63 Farm Dependent 
Condemnation 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_POP_COND_DIST 64 Pop Dependent 
Condemnation 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_MILK_DIST 65 Milk Disposal 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_CROP_DIST 66 Crop Disposal 
Distance 
 

Type 11 results Source Term 
Evacuation 
MACCS2_Input 

km 

BIN_FARM_DECON_AFF 67 Farm 
Decontamination 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_POP_DECON_AFF 68 Pop 
Decontamination 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

individuals 

BIN_POP_DECON_AREA 69 Pop 
Decontamination 
Area  
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_FARM_INERD 70 Farm Interdiction 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_POP_INTERD 71 Pop Interdiction 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

individuals 

BIN_POP_INTERD_AREA 72 Pop Interdiction 
Area  
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_FARM_COND 73 Farm 
Condemnation 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_POP_COND 74 Pop 
Condemnation 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

individuals 

BIN_POP_COND_AREA 75 Pop 
Condemnation 
Area  
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 
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Maccs2 Variable Name containing 
value of VarID 

VarID VarLab Comments Qualifiers Units 

BIN_MILK_DISP_AREA 76 Milk Disposal 
Area 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_CROP_DISP_AREA 77 Crop Disposal 
Area 
 

Type 12 results Source Term 
Evacuation 
Ldistance 
Rdistance 
MACCS2_Input 

ha 

BIN_MAX_FOOD_DOSE 78 Maximum Annual 
Food Dose 

Type 13 results Source Term 
Evacuation 
Organ 
Ldistance 
Rdistance 
MACCS2_Input 

Sv 

 



 

 

 

B-2.3.4 Record Data Field for the Statistics Record 
The following variable is written to the RecordData field when RecordLab=STATISTICS: 

• NStat is a 4 byte integer containing the number of statistics defined in this block. 

This is followed by NStat sets of data. Each set of data describes a statistic as follows: 

• StatID  is a 4byte integer identifying the variable 
• StatLab is a variable length string describing the statistic 

Example: (3,”50th Quantile”) 

 

Table B-5.  Statistics Written to the Binary File 

StatID StatLab 
1 Probability Non-zero  
2 Mean  
3 50th Quantile  
4 90th Quantile  
5 95th Quantile  
6 99th Quantile  
7 99.5th Quantile  
8 Peak Concentration  
9 Peak Probability  
10 Peak Trial  

 

B-2.3.5 RecordData Field for the Results Records 
There are four different types of results supported, vectors, ordered pairs, statistical blocks and 
statistical ordered pairs representing a cumulative probability distribution (CCDF). Some of the 
MACCS results are single numbers (e.g., a radioactivity level). Other results are probability 
distributions, for example the distribution of a dose. Other results are summaries of probabilities, 
such as the mean or trial where the peak value occurs.   

All results records must have information about the variable and qualifiers that are being 
reported.   
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The following format for the RecordData field is as follows when 
RecordLab=VECTOR_RESULTS, 2-D_RESULTS, STAT_RESULTS or CCDF_RESULTS. 

 

Table B-6.  Formatting Details of the Results Records 
Field Description Example 

VarID 

4 byte integer 
identifying variable.  
This value refers to one 
of the reported values 
of VarID in the 
RecordData field of the 
Variables record. 

4 
Note: This represents Centerline Ground 

Concentration 

“BQU ” 
4 character fixed string 
indicating beginning of 
qualifier block 

“BQU ” 

QualID 

Long integer 
identifying qualifier ID.  
This value refers to one 
of the reported values 
of QualID in the 
RecordData field of the 
Qualifiers  record. 

11 
Note: This represents source term.  This matches 
qualID as listed in record 0001  

QualVal 
Variable length string 
containing qualifier 
value. 

“1” 
Note: This identifies the source term as the first  

“EQU ” 
4 character fixed string 
indicating end of 
qualifier block. 

“EQU ” 

Repeated 
Qualifier 
blocks, “BQU”,  
QualID, 
QualVal, 
“EQU”  

Above fields are 
repeated until all 
qualifiers are defined. 

11, “1”, 5, “2”, 1, “Co-60”, 2, “4.5”, 3, “8.2” 
 
Note: This represents source term 1, plume 2, 

Co-60 from 4.5 to 8.2 km on the radial 
grid. These values are grouped as follows: 

{11, “1”}, {5, “2”}, {1, “Co_60”}, {2, “4.5”},  
{3, “8.2”} 
 
In this example, VarID=4. There are five sets of 
qualifiers. Set one corresponds to source term 
(QualID=11), set two to plume (QualID=5), set 
three to nuclide (QualID=1), set four to Ldistance 
(QualID=2) and set five to Rdistance (QualID=3) 
 

Results 
Results record, this 
format is determined by 
record type 

 



 

 

 
B-2.3.5.1 Results Field for the VECTOR_RESULTS Records 

The format of the Results field is as follows: 

1. Length is a 4 byte integer identifying number of real numbers that follow. 
2. Values is a vector of 4 byte real numbers.   

B-2.3.5.2 Results Field for the 2-D_RESULTS Records 

The format of the Results field is as follows: 

1. Length is a 4 byte integer identifying the number of (x,y) pairs that follow. 
2. Values is an array of 4 byte real numbers of size 2 by Length containing (x,y) pairs of 

results written to the file in row major order. 
B-2.3.5.3 Results Field for the STAT_RESULTS Records 

The format of the Results field is as follows: 

Values is a vector of 4 byte real numbers of size NStat (part of the Statistics record). The value of 
NStat for MACCS2 version 2.0 is ten. Data is in the same order as listed in the Statistics record. 

B-2.3.5.4 Results Field for the CCDF_RESULTS Records 

The format of the Results field is as follows: 

1. Length is a 4 byte integer identifying the number of (x,y) pairs that follow. 
2. Values is an array of 4 byte real numbers of size 2 by Length containing (x,y) pairs of 

results written to the file in row major order.   
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Appendix C:  FGR-13 Dose Factor Files 
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C-1  Introduction 
WinMACCS is supplied with a set of 51 “adult” dose factor files which are based on the CD 
supplement to Federal Guidance Report 13 (EPA 2002).  Data for 825 isotopes is provided.  This 
dose factor file set supports WinMACCS calculations using the linear no threshold, annual 
threshold, piecewise linear, and acute health risk models.   
 
These dose factors utilize ICRP publication 60 (ICRP 1991) tissue weighting and the respiratory 
tract model defined in ICRP-publication 66 (ICRP 1994).  Federal Guidance Report 13 dose 
factors are generally similar to those published in ICRP publication 72 (1996), but they 
incorporate modifications to ICRP publication 72 assumptions that were agreed to by the U. S. 
Environmental Protection Agency and the ORNL Center for Biokinetic and Dosimetric 
Research.  Minor differences between Federal Guidance Report 13 and ICRP publication 72 dose 
coefficients are largely attributable to differences in:   

• Assumptions of shared kinetics in some decay chains 
• Systemic biokinetic models for some elements, and  
• Gastrointestinal tract absorption-to-blood fractions, f1.   

 

C-2  Lung Clearance Behavior 
With few exceptions, the absorption types are consistent with those used in the current dose 
factor files. The dose factor files do not show an absorption type for certain isotopes when either 
there was no choice of clearance type in Federal Guidance Report 13, or the choice was 
superfluous because the inhalation dose coefficients were zero. 

C-3  Gastrointestinal Tract Uptake Fraction, F1 

Federal Guidance Report 13 assigned f1 values for uptake of elements from the digestive tract 
via the ingestion pathway based on the chemical form expected to be encountered in the 
environment, and these values were not necessarily consistent with the f1 values used in the 
computation of inhalation dose coefficients.  There were choices of f1 to be made for only four 
elements, hydrogen, sulfur, mercury, and polonium.  The ingestion dose coefficient for tritium 
was based on tritiated water (HTO).  Sulfur, mercury, and polonium isotopes were assigned 
ingestion dose coefficient based on the form and f1 that gave the highest dose.   

 

C-4  Particle Size Distribution 
Inhalation dose coefficients for micron sized particles depend on the activity median 
aerodynamic diameter (AMAD).  The Federal Guidance Report 13 inhalation dose factors are 
based on an AMAD of 1 µm.  

 

C-5  Organs Included in Data Set 
The following organs and tissues are included in the Federal Guidance Report 13 dose factor 
files.   
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Table C-1. Organs Included in Federal Guidance Report 13 Files.  

Organs with Annual and 50-Year 
Equivalent Dose Commitment 
Coefficients 

Organs with Acute Dose 
Commitment Coefficients 

Adrenals  
Urinary Bladder Wall  
Bone Surface  
Brain  
Breasts  
Stomach Wall Stomach Wall 
Small Intestine Wall Small Intestine Wall 
Upper Lg Intestine Wall (ULI)  
Lower Large Intestine Wall (LLI) Lower Large Intestine Wall 
Kidneys  
Liver  
Esophagus  
Muscle  
Ovaries  
Pancreas  
Red Marrow Red Marrow 
Skin  
Spleen  
Testes  
Thymus  
Thyroid Thyroid 
Uterus  
Lungs Lungs 
Colon  
Gonads  
Remainder  
Effective  
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C-6  Annual and 50-year Equivalent Dose Commitment Factors 
The annual and 50-year dose commitment factors are intended for stochastic health effect 
(cancer and heritable effect) estimation, so they include a radiation weighting factor of 20 for the 
high linear energy transfer (LET) contributions to these dose coefficients. 
 

C-7  Calculating annual and 50-year dose commitment factors for “composite 
organs” 
Dose factors for composite organs were calculated from dose factors for the underlying tissues or 
organs as follows: 

• The esophagus was assigned the corresponding inhalation dose coefficients and 
ingestion dose coefficients of the thymus.  

• Inhalation and ingestion dose coefficients for the colon were calculated as a weighted 
sum of the dose coefficients for upper large intestine (57%) and lower large intestine 
(43%)  

• The inhalation and ingestion dose coefficients for the lung (thoracic portion of 
respiratory tract) and ETReg (the extra-thoracic region of the respiratory tract) were 
calculated using equations on page 35 of ICRP publication 66. The lung coefficient is 
the weighted sum of the coefficients for the several respiratory tract tissues.  

• The dose coefficients for remainder were calculated using equations on ICRP 
publication 71 (ICRP 1995) page 27.  

• The dose coefficients for gonads were the larger of the dose coefficients for testes 
and ovaries. 

• The dose coefficients for effective were computed from the individual organ dose 
coefficients using the ICRP 60 tissue weighting method. 

 

C-8  Acute Inhalation Dose Factors 
Reliable data on relative biological effectiveness, RBE, of high LET radiation at causing acute 
health effects were not available; so the acute inhalation dose factors were based on an RBE of 
10 for consistency with DOSFAC2 dose factor files.   
 
Next, the resulting acute dose coefficients DCF[i, at, org, cp] were weighted by acute dose 
protraction factors, WTFRAC[cp,org], and then summed to obtain adjusted acute dose 
coefficients, DCF[i, at, org].  The values of WTFRAC[cp, org] that were used are given in the 
DOSFAC2 Users Manual (Young and Chanin, 1997).  
 

C-9  Designating Pseudo-Stable Isotopes When Using Federal Guidance Report 
13 Dose Factor Files 
 
In contrast to DOSFAC2 and FGRDCF dose factor files, Federal Guidance Report 13 dose 
factors make no assumptions about the degree of equilibrium within decay chains for radioactive 
materials in the environment or for intakes of radioactive materials from the environment. 
Consequently, one must be mindful about specifying both parent and the corresponding progeny 
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that are released or form as decay products in the environment via the WinMACCS 
“Radionuclide Core Inventory and Chemical Group” window.  For long decay chains, such as 
uranium-238, the sixth member of the chain (thorium-230 for example) must be identified as 
pseudo-stable. If the pseudo-stable isotope conventions commonly observed for DOSFAC2 or 
FGRDCF dose factor files are used with Federal Guidance Report 13 dose factor files, then doses 
and health effects may be significantly underestimated.  
 

C-10 Known Issues 
The FGR-13 dose factor files have inherited the following issues from the CD Supplement to 
FGR-13: 

• The ingestion and inhalation dose coefficients for four alpha-emitting rare-earth 
isotopes (Sm-146, Sm-147, Gd-148, and Gd-152) are incorrect.  

• The ingestion and inhalation dose coefficients for four isotopes having significant 
spontaneous fission decay modes (Cm-248, Cm-250, Cf-252, and Cf-254) are 
listed as zero.  

 


